summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-05-01 22:08:20 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-05-01 23:21:56 +0200
commit494ec0c253357d84f04eeb29b38ed40f3edb8632 (patch)
treec87e9ffe0c7b88e7079c406b143ada7ef5aa4f6b /kde-misc
parentkde-plasma/discover: Fix build with dev-libs/glib-2.68 (diff)
downloadgentoo-494ec0c253357d84f04eeb29b38ed40f3edb8632.tar.gz
gentoo-494ec0c253357d84f04eeb29b38ed40f3edb8632.tar.bz2
gentoo-494ec0c253357d84f04eeb29b38ed40f3edb8632.zip
kde-misc/plasma-pass: Drop -Werror
Closes: https://bugs.gentoo.org/785832 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/plasma-pass/files/plasma-pass-1.2.0-no-werror.patch31
-rw-r--r--kde-misc/plasma-pass/plasma-pass-1.2.0.ebuild2
2 files changed, 33 insertions, 0 deletions
diff --git a/kde-misc/plasma-pass/files/plasma-pass-1.2.0-no-werror.patch b/kde-misc/plasma-pass/files/plasma-pass-1.2.0-no-werror.patch
new file mode 100644
index 000000000000..42c40bfe923a
--- /dev/null
+++ b/kde-misc/plasma-pass/files/plasma-pass-1.2.0-no-werror.patch
@@ -0,0 +1,31 @@
+From 468db75d4a4f2620921c00ebd91fd7d12e7a2bce Mon Sep 17 00:00:00 2001
+From: David Faure <faure@kde.org>
+Date: Sat, 1 May 2021 21:58:56 +0200
+Subject: [PATCH] Remove -Werror, one can't predict what future compilers will
+ do
+
+I assume this was supposed to be set only temporarily.
+
+CCMAIL: dvratil@kde.org
+---
+ CMakeLists.txt | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 8131494..26cea6e 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -46,8 +46,8 @@ find_package(Qt5 ${QT_MIN_VERSION} CONFIG REQUIRED COMPONENTS
+ add_definitions(-DQT_DISABLE_DEPRECATED_BEFORE=0x050d00)
+ add_definitions(-DQT_NO_FOREACH)
+
+-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Werror -pedantic")
+-set(CMAKE_C_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Werror -pedantic")
++set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -pedantic")
++set(CMAKE_C_FLAGS "${CMAKE_CXX_FLAGS} -Wall -pedantic")
+
+ # plasmoid
+ plasma_install_package(package org.kde.plasma.pass)
+--
+GitLab
+
diff --git a/kde-misc/plasma-pass/plasma-pass-1.2.0.ebuild b/kde-misc/plasma-pass/plasma-pass-1.2.0.ebuild
index d713294e830f..b62a307e42dd 100644
--- a/kde-misc/plasma-pass/plasma-pass-1.2.0.ebuild
+++ b/kde-misc/plasma-pass/plasma-pass-1.2.0.ebuild
@@ -35,3 +35,5 @@ RDEPEND="${DEPEND}
>=dev-qt/qtquickcontrols2-${QTMIN}:5
>=kde-frameworks/kirigami-${KFMIN}:5
"
+
+PATCHES=( "${FILESDIR}"/${P}-no-werror.patch ) # bug 785832