summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-12 12:11:54 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-12 12:47:17 +0100
commit74964ce8932e9e213253a95c85035b7a94d1ab3a (patch)
tree2b9d2dcae3b7385ea60c4d241da3a6a30eb77f03 /kde-misc
parentkde-misc/kolor-manager: Port to ecm.eclass and kde.org.eclass (diff)
downloadgentoo-74964ce8932e9e213253a95c85035b7a94d1ab3a.tar.gz
gentoo-74964ce8932e9e213253a95c85035b7a94d1ab3a.tar.bz2
gentoo-74964ce8932e9e213253a95c85035b7a94d1ab3a.zip
kde-misc/wacomtablet: Port away from kde5.eclass, update HOMEPAGE
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/wacomtablet/wacomtablet-3.2.0.ebuild48
1 files changed, 25 insertions, 23 deletions
diff --git a/kde-misc/wacomtablet/wacomtablet-3.2.0.ebuild b/kde-misc/wacomtablet/wacomtablet-3.2.0.ebuild
index 74a5f2521ad7..fb00967bfb2e 100644
--- a/kde-misc/wacomtablet/wacomtablet-3.2.0.ebuild
+++ b/kde-misc/wacomtablet/wacomtablet-3.2.0.ebuild
@@ -1,39 +1,41 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-KDE_HANDBOOK="forceoptional"
+ECM_HANDBOOK="forceoptional"
+KFMIN=5.60.0
+QTMIN=5.12.3
VIRTUALX_REQUIRED="test"
-inherit kde5
+inherit ecm kde.org
DESCRIPTION="System settings module for Wacom tablets"
-HOMEPAGE="https://userbase.kde.org/Wacomtablet https://store.kde.org/p/1127862"
-SRC_URI="mirror://kde/stable/${PN}/${PV}/${P}.tar.xz"
+HOMEPAGE="https://kde.org/applications/system/org.kde.wacomtablet
+https://userbase.kde.org/Wacomtablet"
LICENSE="GPL-2"
+SLOT="5"
KEYWORDS="amd64 x86"
-IUSE=""
BDEPEND="sys-devel/gettext"
RDEPEND="
- $(add_frameworks_dep kconfig)
- $(add_frameworks_dep kconfigwidgets)
- $(add_frameworks_dep kcoreaddons)
- $(add_frameworks_dep kdbusaddons)
- $(add_frameworks_dep kglobalaccel)
- $(add_frameworks_dep ki18n)
- $(add_frameworks_dep knotifications)
- $(add_frameworks_dep kwidgetsaddons)
- $(add_frameworks_dep kwindowsystem)
- $(add_frameworks_dep kxmlgui)
- $(add_frameworks_dep plasma)
- $(add_qt_dep qtdbus)
- $(add_qt_dep qtdeclarative)
- $(add_qt_dep qtgui)
- $(add_qt_dep qtwidgets)
- $(add_qt_dep qtx11extras)
>=dev-libs/libwacom-0.30
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kglobalaccel-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-frameworks/plasma-${KFMIN}:5
>=x11-drivers/xf86-input-wacom-0.20.0
x11-libs/libXi
x11-libs/libxcb
@@ -49,5 +51,5 @@ src_test() {
-E "(Test.KDED.DBusTabletService)"
)
- kde5_src_test
+ ecm_src_test
}