summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-10-24 20:15:27 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-10-24 20:15:27 +0200
commitcc4b5436d6e45bf56c6b08f726b810254851c50e (patch)
tree76fe7206f6db54e027eacbd7fc5c8409412c0621 /kde-misc
parentdev-qt/qtwebengine: Fix x86 build with GCC-8 (again) (diff)
downloadgentoo-cc4b5436d6e45bf56c6b08f726b810254851c50e.tar.gz
gentoo-cc4b5436d6e45bf56c6b08f726b810254851c50e.tar.bz2
gentoo-cc4b5436d6e45bf56c6b08f726b810254851c50e.zip
kde-misc/ktoshiba: Fix build with Qt 5.11
Closes: https://bugs.gentoo.org/669518 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/ktoshiba/files/ktoshiba-5.3.1-qt-5.11.patch10
-rw-r--r--kde-misc/ktoshiba/ktoshiba-5.3.1.ebuild5
2 files changed, 13 insertions, 2 deletions
diff --git a/kde-misc/ktoshiba/files/ktoshiba-5.3.1-qt-5.11.patch b/kde-misc/ktoshiba/files/ktoshiba-5.3.1-qt-5.11.patch
new file mode 100644
index 000000000000..c7ec51226ad8
--- /dev/null
+++ b/kde-misc/ktoshiba/files/ktoshiba-5.3.1-qt-5.11.patch
@@ -0,0 +1,10 @@
+--- a/src/fnactions.cpp 2016-06-06 17:41:50.425121940 +0200
++++ b/src/fnactions.cpp 2018-10-24 20:10:45.872718660 +0200
+@@ -17,6 +17,7 @@
+ */
+
+ #include <QDesktopWidget>
++#include <QIcon>
+ #include <QTimer>
+
+ #include <KLocalizedString>
diff --git a/kde-misc/ktoshiba/ktoshiba-5.3.1.ebuild b/kde-misc/ktoshiba/ktoshiba-5.3.1.ebuild
index 4295ad18882d..6bfd01a7e52c 100644
--- a/kde-misc/ktoshiba/ktoshiba-5.3.1.ebuild
+++ b/kde-misc/ktoshiba/ktoshiba-5.3.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -28,11 +28,12 @@ RDEPEND="
$(add_qt_dep qtwidgets)
net-libs/libmnl
"
-
DEPEND="${RDEPEND}
sys-devel/gettext
"
+PATCHES=( "${FILESDIR}/${P}-qt-5.11.patch" )
+
src_configure() {
local mycmakeargs=(
-DLIBMNL_INCLUDE_DIRS=/usr/include/libmnl