summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-11-20 15:48:34 +0100
committerJohannes Huber <johu@gentoo.org>2016-11-20 15:48:57 +0100
commit2b40b901fd89257ad0b835206201464d77943f92 (patch)
treec18a96177519b654b6d66fca53f5f9d409bcf535 /kde-plasma
parentnet-mail/notmuch: Bump version (diff)
downloadgentoo-2b40b901fd89257ad0b835206201464d77943f92.tar.gz
gentoo-2b40b901fd89257ad0b835206201464d77943f92.tar.bz2
gentoo-2b40b901fd89257ad0b835206201464d77943f92.zip
kde-base/kcheckpass -> kde-plasma/kcheckpass
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/kcheckpass/Manifest1
-rw-r--r--kde-plasma/kcheckpass/files/kcheckpass-4.4.2-no-SUID-no-GUID.patch15
-rw-r--r--kde-plasma/kcheckpass/kcheckpass-4.11.22-r1.ebuild36
-rw-r--r--kde-plasma/kcheckpass/metadata.xml8
-rw-r--r--kde-plasma/kscreenlocker/kscreenlocker-5.7.5.ebuild2
-rw-r--r--kde-plasma/kscreenlocker/kscreenlocker-5.8.3.ebuild2
6 files changed, 62 insertions, 2 deletions
diff --git a/kde-plasma/kcheckpass/Manifest b/kde-plasma/kcheckpass/Manifest
new file mode 100644
index 000000000000..db5163f83985
--- /dev/null
+++ b/kde-plasma/kcheckpass/Manifest
@@ -0,0 +1 @@
+DIST kde-workspace-4.11.22.tar.xz 13553668 SHA256 f035334e843d67ee88551ae9e6c5f64bf7b1edfe311b12501575fe74be0b03b7 SHA512 9def2cc8d1e597259966cd6cc44e9aad7ebe2c7cde5943e362c6782d1344e7da4fff0dddd0fe0c948bca159dba128d8a36006e1ae409415cd22f74955d0a9b95 WHIRLPOOL 14b0fcef19bda4b92a42612387fb6307a50dbb3620e911e3e0aaf5d764fb263e1959baae2e55cb71d92d064542844ae963b170bb960a9b7dc18a11627b731802
diff --git a/kde-plasma/kcheckpass/files/kcheckpass-4.4.2-no-SUID-no-GUID.patch b/kde-plasma/kcheckpass/files/kcheckpass-4.4.2-no-SUID-no-GUID.patch
new file mode 100644
index 000000000000..78520d4acc4b
--- /dev/null
+++ b/kde-plasma/kcheckpass/files/kcheckpass-4.4.2-no-SUID-no-GUID.patch
@@ -0,0 +1,15 @@
+Index: kcheckpass/CMakeLists.txt
+===================================================================
+--- kcheckpass/CMakeLists.txt (revision 1112521)
++++ kcheckpass/CMakeLists.txt (working copy)
+@@ -23,10 +23,6 @@
+ macro_add_compile_flags(kcheckpass -U_REENTRANT)
+ target_link_libraries(kcheckpass ${KDE4_KDEFAKES_LIBS} ${UNIXAUTH_LIBRARIES} ${SOCKET_LIBRARIES})
+ install(TARGETS kcheckpass DESTINATION ${LIBEXEC_INSTALL_DIR})
+-install(CODE "
+- set(KCP_PATH \"\$ENV{DESTDIR}${LIBEXEC_INSTALL_DIR}/kcheckpass\")
+- EXECUTE_PROCESS(COMMAND sh -c \"chown root '\${KCP_PATH}' && chmod +s '\${KCP_PATH}'\")
+-")
+
+ install_pam_service(kcheckpass)
+
diff --git a/kde-plasma/kcheckpass/kcheckpass-4.11.22-r1.ebuild b/kde-plasma/kcheckpass/kcheckpass-4.11.22-r1.ebuild
new file mode 100644
index 000000000000..4a2efa822b5a
--- /dev/null
+++ b/kde-plasma/kcheckpass/kcheckpass-4.11.22-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KMNAME="kde-workspace"
+inherit kde4-meta
+
+DESCRIPTION="A simple password checker, used by any software in need of user authentication"
+KEYWORDS="amd64 ~arm x86 ~amd64-linux ~x86-linux"
+IUSE="debug pam"
+
+DEPEND="
+ pam? ( virtual/pam )
+"
+RDEPEND="${DEPEND}
+ pam? ( || (
+ >=kde-base/kdebase-pam-7
+ kde-plasma/kscreenlocker:5
+ ) )
+"
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ use pam && epatch "${FILESDIR}/${PN}-4.4.2-no-SUID-no-GUID.patch"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with pam)
+ )
+
+ kde4-meta_src_configure
+}
diff --git a/kde-plasma/kcheckpass/metadata.xml b/kde-plasma/kcheckpass/metadata.xml
new file mode 100644
index 000000000000..0cf59224b009
--- /dev/null
+++ b/kde-plasma/kcheckpass/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>kde@gentoo.org</email>
+ <name>Gentoo KDE Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/kde-plasma/kscreenlocker/kscreenlocker-5.7.5.ebuild b/kde-plasma/kscreenlocker/kscreenlocker-5.7.5.ebuild
index 3c5d39555126..620f63804146 100644
--- a/kde-plasma/kscreenlocker/kscreenlocker-5.7.5.ebuild
+++ b/kde-plasma/kscreenlocker/kscreenlocker-5.7.5.ebuild
@@ -47,7 +47,7 @@ DEPEND="${COMMON_DEPEND}
"
RDEPEND="${COMMON_DEPEND}
$(add_plasma_dep kde-cli-tools)
- !<kde-base/kcheckpass-4.11.22-r1:4
+ !<kde-plasma/kcheckpass-4.11.22-r1:4
!kde-base/kdebase-pam:0
!<kde-plasma/plasma-workspace-5.4.50
"
diff --git a/kde-plasma/kscreenlocker/kscreenlocker-5.8.3.ebuild b/kde-plasma/kscreenlocker/kscreenlocker-5.8.3.ebuild
index 519db8d36c1b..888250eb79d3 100644
--- a/kde-plasma/kscreenlocker/kscreenlocker-5.8.3.ebuild
+++ b/kde-plasma/kscreenlocker/kscreenlocker-5.8.3.ebuild
@@ -47,7 +47,7 @@ DEPEND="${COMMON_DEPEND}
"
RDEPEND="${COMMON_DEPEND}
$(add_plasma_dep kde-cli-tools)
- !<kde-base/kcheckpass-4.11.22-r1:4
+ !<kde-plasma/kcheckpass-4.11.22-r1:4
!kde-base/kdebase-pam:0
!<kde-plasma/plasma-workspace-5.4.50
"