summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno <hanno@gentoo.org>2016-09-14 00:45:58 +0200
committerHanno <hanno@gentoo.org>2016-09-14 00:45:58 +0200
commit5f034c30288a6df8ba711d4b1909dd84b5336755 (patch)
tree9031a31add37f7853c1f87de8f9386bffb30e68d /lxde-base/lxtask/lxtask-0.1.7.ebuild
parentlxde-base/lxtask: Remove old versions and patches (diff)
downloadgentoo-5f034c30288a6df8ba711d4b1909dd84b5336755.tar.gz
gentoo-5f034c30288a6df8ba711d4b1909dd84b5336755.tar.bz2
gentoo-5f034c30288a6df8ba711d4b1909dd84b5336755.zip
lxde-base/lxtask: version bump to 0.1.7
Add patch to fix compilation with -fno-common. Package-Manager: portage-2.3.0
Diffstat (limited to 'lxde-base/lxtask/lxtask-0.1.7.ebuild')
-rw-r--r--lxde-base/lxtask/lxtask-0.1.7.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/lxde-base/lxtask/lxtask-0.1.7.ebuild b/lxde-base/lxtask/lxtask-0.1.7.ebuild
new file mode 100644
index 000000000000..a91695e33aac
--- /dev/null
+++ b/lxde-base/lxtask/lxtask-0.1.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+DESCRIPTION="LXDE Task manager"
+HOMEPAGE="http://lxde.sf.net/"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.xz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~x86 ~arm-linux ~x86-linux"
+SLOT="0"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ dev-libs/glib:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/gettext
+ >=dev-util/intltool-0.40.0"
+
+# Upstream report:
+# https://sourceforge.net/p/lxde/patches/535/
+PATCHES=( "${FILESDIR}/lxtask-0.1.7-fix-no-common.patch" )
+
+src_install () {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS README
+}