summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcharIes17 <charles17@arcor.de>2018-01-20 22:34:33 +0100
committerAaron Bauman <bman@gentoo.org>2018-03-26 20:42:01 -0400
commit943d4ab4e41925dd8b1c76ff543ad6e07cc12866 (patch)
tree8d3b94e2d961576aa539b3d550e7633c067bd518 /lxde-base
parentlxde-base/lxde-common: Version bump to 0.99.2 (diff)
downloadgentoo-943d4ab4e41925dd8b1c76ff543ad6e07cc12866.tar.gz
gentoo-943d4ab4e41925dd8b1c76ff543ad6e07cc12866.tar.bz2
gentoo-943d4ab4e41925dd8b1c76ff543ad6e07cc12866.zip
lxde-base/lxinput: Add locale handling
Package-Manager: Portage-2.3.19, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/6919
Diffstat (limited to 'lxde-base')
-rw-r--r--lxde-base/lxinput/lxinput-0.3.5-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/lxde-base/lxinput/lxinput-0.3.5-r1.ebuild b/lxde-base/lxinput/lxinput-0.3.5-r1.ebuild
new file mode 100644
index 000000000000..3b5faf9e9c5c
--- /dev/null
+++ b/lxde-base/lxinput/lxinput-0.3.5-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PLOCALES="af ar ast be bg bn_IN bn ca cs da de el en_GB eo es et eu fa fi fo fr frp
+gl he hr hu id is it ja kk ko lg lt ml ms nb nl nn pa pl ps pt_BR pt ro
+ru si sk sl sr@latin sr sv te th tr tt_RU ug uk ur_PK ur vi zh_CN zh_TW"
+
+PLOCALE_BACKUP="en_GB"
+
+inherit l10n
+
+DESCRIPTION="LXDE keyboard and mouse configuration tool"
+HOMEPAGE="http://lxde.org/"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~x86 ~arm-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-libs/glib:2
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig
+ >=dev-util/intltool-0.40.0"
+
+src_prepare() {
+ default
+
+ export LINGUAS="${LINGUAS:-${PLOCALE_BACKUP}}"
+ l10n_get_locales > po/LINGUAS || die
+}