summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcharIes17 <charles17@arcor.de>2018-01-15 07:43:34 +0100
committerAaron Bauman <bman@gentoo.org>2018-03-26 20:57:24 -0400
commitab2079189ff72033d46d55349add649ffb2db6de (patch)
tree618144e6bb1c1bc108b4276c46c94975480fe2a5 /lxde-base
parentlxde-base/menu-cache: Remove old (diff)
downloadgentoo-ab2079189ff72033d46d55349add649ffb2db6de.tar.gz
gentoo-ab2079189ff72033d46d55349add649ffb2db6de.tar.bz2
gentoo-ab2079189ff72033d46d55349add649ffb2db6de.zip
lxde-base/lxpanel: RDEPEND x11-libs/gdk-pixbuf[X]
Closes: https://bugs.gentoo.org/614086 Also adds locale handling to 0.9.3-r1 Closes: https://github.com/gentoo/gentoo/pull/6864
Diffstat (limited to 'lxde-base')
-rw-r--r--lxde-base/lxpanel/lxpanel-0.9.3-r1.ebuild74
-rw-r--r--lxde-base/lxpanel/lxpanel-0.9.3.ebuild2
2 files changed, 75 insertions, 1 deletions
diff --git a/lxde-base/lxpanel/lxpanel-0.9.3-r1.ebuild b/lxde-base/lxpanel/lxpanel-0.9.3-r1.ebuild
new file mode 100644
index 000000000000..246d9549e289
--- /dev/null
+++ b/lxde-base/lxpanel/lxpanel-0.9.3-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PLOCALES="af ar be bg bn_IN bn ca cs da de el en_GB es et eu fa fi fo fr frp
+gl he hr hu id is it ja kk km ko lg lt lv ml ms nb nl nn pa pl ps pt_BR pt ro
+ru sk sl sr@latin sr sv te th tr tt_RU ug uk ur_PK ur vi zh_CN zh_HK zh_TW"
+
+PLOCALE_BACKUP="en_GB"
+
+inherit l10n readme.gentoo-r1
+
+DESCRIPTION="Lightweight X11 desktop panel for LXDE"
+HOMEPAGE="https://wiki.lxde.org/en/LXPanel"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="+alsa wifi"
+
+RDEPEND="dev-libs/keybinder:0=
+ x11-libs/gtk+:2
+ >=x11-libs/libfm-1.2.0[gtk]
+ x11-libs/libwnck:1
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf[X]
+ x11-libs/libX11
+ lxde-base/lxmenu-data
+ lxde-base/menu-cache
+ alsa? ( media-libs/alsa-lib )
+ wifi? ( net-wireless/wireless-tools )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+DOC_CONTENTS="If you have problems with broken icons shown in the main panel,
+you will have to configure panel settings via its menu.
+This will not be an issue with first time installations."
+
+src_prepare() {
+ default
+
+ export LINGUAS="${LINGUAS:-${PLOCALE_BACKUP}}"
+ l10n_get_locales > po/LINGUAS || die
+}
+
+src_configure() {
+ local plugins="netstatus,volume,cpu,deskno,batt, \
+ kbled,xkb,thermal,cpufreq,monitors"
+
+ use wifi && plugins+=",netstat"
+ use alsa && plugins+=",volumealsa"
+ [[ ${CHOST} == *-interix* ]] && plugins=deskno,kbled,xkb
+
+ econf $(use_enable alsa) --with-x --with-plugins="${plugins}"
+ # the gtk+ dep already pulls in libX11, so we might as well hardcode with-x
+}
+
+src_install () {
+ default
+
+ # Get rid of the .la files.
+ find "${D}" -name '*.la' -delete
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/lxde-base/lxpanel/lxpanel-0.9.3.ebuild b/lxde-base/lxpanel/lxpanel-0.9.3.ebuild
index 2c22a239d326..0f628687d4df 100644
--- a/lxde-base/lxpanel/lxpanel-0.9.3.ebuild
+++ b/lxde-base/lxpanel/lxpanel-0.9.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"