summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaolo Pedroni <paolo.pedroni@iol.it>2015-11-24 12:30:46 +0100
committerPaolo Pedroni <paolo.pedroni@iol.it>2015-11-26 09:20:10 +0100
commit30a69a2b74b43c11504df46fe57445fd2548cf70 (patch)
treef09e563049fa83faa3ad7ec1b72ec5c00b2b4508 /lxqt-base/lxqt-notificationd
parentlxqt-base/lxqt-meta: Version bump to 0.10.0 (diff)
downloadgentoo-30a69a2b74b43c11504df46fe57445fd2548cf70.tar.gz
gentoo-30a69a2b74b43c11504df46fe57445fd2548cf70.tar.bz2
gentoo-30a69a2b74b43c11504df46fe57445fd2548cf70.zip
lxqt-base/lxqt-notificationd: Version bump to 0.10.0
Thanks to Alpha Bravo <aos@ungwana.de> in bug #564718
Diffstat (limited to 'lxqt-base/lxqt-notificationd')
-rw-r--r--lxqt-base/lxqt-notificationd/lxqt-notificationd-0.10.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-notificationd/lxqt-notificationd-0.10.0.ebuild b/lxqt-base/lxqt-notificationd/lxqt-notificationd-0.10.0.ebuild
new file mode 100644
index 000000000000..b6f0fc17fee8
--- /dev/null
+++ b/lxqt-base/lxqt-notificationd/lxqt-notificationd-0.10.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="LXQt notification daemon and library"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="GPL-2 LGPL-2.1+"
+SLOT="0"
+
+RDEPEND="
+ >=dev-libs/libqtxdg-1.0.0
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ kde-frameworks/kwindowsystem:5
+ ~lxqt-base/liblxqt-${PV}
+ =lxqt-base/lxqt-common-0.10*
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+"