summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaolo Pedroni <PPed72@users.noreply.github.com>2015-11-24 12:01:52 +0100
committerPaolo Pedroni <paolo.pedroni@iol.it>2015-11-26 09:19:33 +0100
commit6f5560139f66739a9182d8aef59172e8225ed7c8 (patch)
tree725a303dcafd7834ada0b2f0357a5a72e6945b2a /lxqt-base
parentlxqt-base/lxqt-admin: Version bump to 0.10.0 (diff)
downloadgentoo-6f5560139f66739a9182d8aef59172e8225ed7c8.tar.gz
gentoo-6f5560139f66739a9182d8aef59172e8225ed7c8.tar.bz2
gentoo-6f5560139f66739a9182d8aef59172e8225ed7c8.zip
lxqt-base/lxqt-common: Version bump to 0.10.0
Thanks to Alpha Bravo <aos@ungwana.de> in bug #564718
Diffstat (limited to 'lxqt-base')
-rw-r--r--lxqt-base/lxqt-common/lxqt-common-0.10.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-common/lxqt-common-0.10.0.ebuild b/lxqt-base/lxqt-common/lxqt-common-0.10.0.ebuild
new file mode 100644
index 000000000000..7748d34d1900
--- /dev/null
+++ b/lxqt-base/lxqt-common/lxqt-common-0.10.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="LXQt common resources"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+DEPEND=">=lxqt-base/liblxqt-0.10.0"
+RDEPEND="${DEPEND}"
+PDEPEND=">=lxqt-base/lxqt-session-0.10.0"
+
+src_install() {
+ cmake-utils_src_install
+ dodir "/etc/X11/Sessions"
+ dosym "/usr/bin/startlxqt" "/etc/X11/Sessions/lxqt"
+}