summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bock <nicolasbock@gentoo.org>2017-12-03 06:41:06 -0700
committerNicolas Bock <nicolasbock@gentoo.org>2017-12-03 06:41:22 -0700
commitc1b51a267ca87d73bb37216fe1059fa4dc6dce93 (patch)
treebdce42d6c318c66ce0982e7ab1644764afbea8a9 /mail-client/neomutt
parentmail-client/neomutt: Make ebuild more generic (diff)
downloadgentoo-c1b51a267ca87d73bb37216fe1059fa4dc6dce93.tar.gz
gentoo-c1b51a267ca87d73bb37216fe1059fa4dc6dce93.tar.bz2
gentoo-c1b51a267ca87d73bb37216fe1059fa4dc6dce93.zip
mail-client/neomutt: Add warning about changed USE flags
As part of https://bugs.gentoo.org/637176 the crypto related USE flags were renamed. This change adds a warning to the user that this has happened. The old flags are still usable, but their use is deprecated and will be removed at some point. Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'mail-client/neomutt')
-rw-r--r--mail-client/neomutt/neomutt-9999.ebuild20
1 files changed, 17 insertions, 3 deletions
diff --git a/mail-client/neomutt/neomutt-9999.ebuild b/mail-client/neomutt/neomutt-9999.ebuild
index 3460d4747433..8a0f8bb25dd2 100644
--- a/mail-client/neomutt/neomutt-9999.ebuild
+++ b/mail-client/neomutt/neomutt-9999.ebuild
@@ -20,9 +20,9 @@ HOMEPAGE="https://www.neomutt.org/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="berkdb doc gdbm gnutls gpgme idn kerberos kyotocabinet libressl lmdb nls
- notmuch pgp_classic qdbm sasl selinux slang smime_classic ssl
- tokyocabinet"
+IUSE="berkdb crypt doc gdbm gnutls gpg gpgme idn kerberos kyotocabinet
+ libressl lmdb nls notmuch pgp_classic qdbm sasl selinux slang smime
+ smime_classic ssl tokyocabinet"
CDEPEND="
app-misc/mime-types
@@ -34,6 +34,7 @@ CDEPEND="
qdbm? ( dev-db/qdbm )
tokyocabinet? ( dev-db/tokyocabinet )
gnutls? ( >=net-libs/gnutls-1.0.17 )
+ gpg? ( >=app-crypt/gpgme-0.9.0 )
gpgme? ( >=app-crypt/gpgme-0.9.0 )
idn? ( net-dns/libidn )
kerberos? ( virtual/krb5 )
@@ -68,10 +69,13 @@ src_prepare() {
src_configure() {
local myconf=(
"$(use_enable doc)"
+ "$(use_enable gpg gpgme)"
"$(use_enable gpgme)"
"$(use_enable nls)"
"$(use_enable notmuch)"
+ "$(use_enable crypt pgp)"
"$(use_enable pgp_classic pgp)"
+ "$(use_enable smime)"
"$(use_enable smime_classic smime)"
"$(use_with berkdb bdb)"
"$(use_with gdbm)"
@@ -114,3 +118,13 @@ src_install() {
dodoc COPYRIGHT LICENSE* ChangeLog* README*
}
+
+pkg_postinst() {
+ ewarn "Pleae note that the crypto related USE flags of neomutt have changed."
+ ewarn "(https://bugs.gentoo.org/637176)"
+ ewarn "crypt -> pgp_classic"
+ ewarn "gpg -> gpgme"
+ ewarn "smime -> smime_classic"
+ ewarn "The old USE flags still work but their use is deprecated and will"
+ ewarn "be removed in a future release."
+}