summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2016-07-09 16:27:12 +0200
committerFabian Groffen <grobian@gentoo.org>2016-07-09 17:48:48 +0200
commit2b6dd73b8ce4078cb0d809fee9b5b8cedab49861 (patch)
treeb7dcc231433926e99eaa3c4818b3d6dff80099d3 /mail-client
parentdev-vcs/vcsh: disable tests entirely (diff)
downloadgentoo-2b6dd73b8ce4078cb0d809fee9b5b8cedab49861.tar.gz
gentoo-2b6dd73b8ce4078cb0d809fee9b5b8cedab49861.tar.bz2
gentoo-2b6dd73b8ce4078cb0d809fee9b5b8cedab49861.zip
mail-client/mutt: version bump to 1.6.2, neomutt-20160709
Package-Manager: portage-2.2.28
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/mutt/Manifest2
-rw-r--r--mail-client/mutt/mutt-1.6.2.ebuild260
2 files changed, 262 insertions, 0 deletions
diff --git a/mail-client/mutt/Manifest b/mail-client/mutt/Manifest
index 90a552f3c1ed..c85304a5086c 100644
--- a/mail-client/mutt/Manifest
+++ b/mail-client/mutt/Manifest
@@ -9,3 +9,5 @@ DIST mutt-1.6.0.tar.gz 3954591 SHA256 29afb6238ab7a540c0e3a78ce25c970f975ab6c0f0
DIST mutt-1.6.1-gentoo-patches-r5.tar.xz 173228 SHA256 cce80ae3b385ed43bedb3674859cb971644c71dde2ac4b00ce4fd94e52eda6a1 SHA512 c328fa30cf0e3ed14753d0c95daac62d295dfb5c4482323b7bfdc7af89e3d4563678101e74d39c8cdccd40f49e8fca5becd1a211c75e44f66e85190bc8b0ee64 WHIRLPOOL 9893878cc6c262b0564920b71d2e906c2f8b0c199e3f7e6883779be63b0af03fdc7a581bc8295c038fb2184d7114a8446356785eb0dfb2680e747e897f6983b4
DIST mutt-1.6.1-neomutt-patches-3d90396616d009a7dcbfbb17d8a74b3eee70bd9a.zip 538034 SHA256 d76441eb51295afccc060bfee40ef03ab1b865de1187ea1f26349281d11784a6 SHA512 ca5334c9d0a295cba8749d1d7315d6d7a8ac93f48cfd9a1e112f9b5dd61f808966ec320464aab282cc626c08764294844368dca1520bc9dc6029c12004b7bb50 WHIRLPOOL b14ae9b58c6ba81956caefe049a0c6706436700e060402a9d869d9b98b61d74df5478dd07ee9cd520c4e6012a22b01d29857f74a8e3955680948e06f4e04cbec
DIST mutt-1.6.1.tar.gz 3956840 SHA256 98b26cecc6b1713082fc880344fa345c20bd7ded6459abe18c84429c7cf8ed20 SHA512 a45c7bc681ea31a6ee37e95a11f3ec84f580478367250c80eaf5aceeba87e34411346a8b7e80a0f236c507cec1199ddc3ccf4596b81d7e31c235099dccdd4fd5 WHIRLPOOL 8cc8e699fbf1832eb411f4f3d59eac57450afade4ddfee3ecb89c0bbaaa92414779f8f2015ec05a9ed19deb88b40298b2f786afb91acbfc2a44a3f8f4876a712
+DIST mutt-1.6.2-patches-neomutt-20160709.tar.gz 498453 SHA256 9601f07fc163577f6222d2786c9ac8081d5498658e06ab1b646a16c6e2b61952 SHA512 9c0f069a82b72f5d1fc05c3edf4012a3044e2acf4cc1771bf7a4103c352bd165dd58e41f65434fb2e57464ce2981b3722c55e54b4c700b29863c7576f9cf1928 WHIRLPOOL 66291b9388bb089410146d53faddc540cf659caf129674cdbe8519eac89161c547e770a0094f630fff951b2cf8bf60404fe64804ae9c514c69301c1a3c894483
+DIST mutt-1.6.2.tar.gz 3956745 SHA256 c5d02ef06486cdf04f9eeb9e9d7994890d8dfa7f47e7bfeb53a2a67da2ac1d8e SHA512 c4348ba55459a2f9d5bedda1ec63b7520c0bdcd285bf791972dbd11a947be47e7c88b02c7d244e65c7c0f1be252c43240b570457a5812bf8160611bba7b01916 WHIRLPOOL 4adf29c59dffa50f5e7c8500a81f89ddbda894ade20bc3110cbedefbcdd7db3c2e84aae78d0cb4bc74930a94256738a3b0b1880b840fd81ec433b23b609887de
diff --git a/mail-client/mutt/mutt-1.6.2.ebuild b/mail-client/mutt/mutt-1.6.2.ebuild
new file mode 100644
index 000000000000..13231173c375
--- /dev/null
+++ b/mail-client/mutt/mutt-1.6.2.ebuild
@@ -0,0 +1,260 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit eutils flag-o-matic autotools
+
+NEOMUTT="neomutt-20160709"
+
+DESCRIPTION="A small but very powerful text-based mail client"
+HOMEPAGE="http://www.mutt.org/"
+SRC_URI="ftp://ftp.mutt.org/pub/mutt/${P}.tar.gz
+ https://bitbucket.org/${PN}/${PN}/downloads/${P}.tar.gz
+ https://github.com/neomutt/integration/archive/${NEOMUTT}.tar.gz -> ${P}-patches-${NEOMUTT}.tar.gz"
+IUSE="berkdb crypt debug doc gdbm gnutls gpg idn imap kerberos libressl mbox nls nntp notmuch pop qdbm sasl selinux sidebar slang smime smtp ssl tokyocabinet"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~x86 ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+CDEPEND="
+ app-misc/mime-types
+ nls? ( virtual/libintl )
+ tokyocabinet? ( dev-db/tokyocabinet )
+ !tokyocabinet? (
+ qdbm? ( dev-db/qdbm )
+ !qdbm? (
+ gdbm? ( sys-libs/gdbm )
+ !gdbm? ( berkdb? ( >=sys-libs/db-4 ) )
+ )
+ )
+ imap? (
+ gnutls? ( >=net-libs/gnutls-1.0.17 )
+ !gnutls? (
+ ssl? (
+ !libressl? ( >=dev-libs/openssl-0.9.6:0 )
+ libressl? ( dev-libs/libressl )
+ )
+ )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )
+ )
+ kerberos? ( virtual/krb5 )
+ pop? (
+ gnutls? ( >=net-libs/gnutls-1.0.17 )
+ !gnutls? (
+ ssl? (
+ !libressl? ( >=dev-libs/openssl-0.9.6:0 )
+ libressl? ( dev-libs/libressl )
+ )
+ )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )
+ )
+ smtp? (
+ gnutls? ( >=net-libs/gnutls-1.0.17 )
+ !gnutls? (
+ ssl? (
+ !libressl? ( >=dev-libs/openssl-0.9.6:0 )
+ libressl? ( dev-libs/libressl )
+ )
+ )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )
+ )
+ idn? ( net-dns/libidn )
+ gpg? ( >=app-crypt/gpgme-0.9.0 )
+ smime? (
+ !libressl? ( >=dev-libs/openssl-0.9.6:0 )
+ libressl? ( dev-libs/libressl )
+ )
+ notmuch? ( net-mail/notmuch )
+ slang? ( sys-libs/slang )
+ !slang? ( >=sys-libs/ncurses-5.2:0 )
+"
+DEPEND="${CDEPEND}
+ net-mail/mailbase
+ doc? (
+ dev-libs/libxml2
+ dev-libs/libxslt
+ app-text/docbook-xsl-stylesheets
+ || ( www-client/lynx www-client/w3m www-client/elinks )
+ )"
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-mutt )
+"
+
+src_prepare() {
+ local PATCHDIR="${WORKDIR}"/integration-${NEOMUTT}
+
+ # apply NeoMutt patches
+ export EPATCH_FORCE="yes"
+ export EPATCH_SUFFIX="patch"
+ # order of patches from README.md
+ local patches=(
+ bugs-common
+ features-common
+ features-extra
+ bugs-neomutt
+ gentoo-pre
+ gentoo
+ )
+ local patchset
+ for patchset in "${patches[@]}" ; do
+ einfo "Applying NeoMutt ${NEOMUTT} patchset ${patchset}"
+ EPATCH_SOURCE="${PATCHDIR}"/${patchset} epatch \
+ || die "NeoMutt patchset ${patchset} failed"
+ done
+ # add some explanation as to why not going to upstream
+ sed -i \
+ -e '/ReachingUs = N_(/a\"This release of Mutt is heavily enriched by NeoMutt patches.\\nFor this reason, any bugs are better reported at https://bugs.gentoo.org/\\nor directly to the NeoMutt project.\\n\\n"' \
+ version.c || die "Failed to add bug instructions"
+
+ local upatches=
+ # allow user patches
+ eapply_user && upatches=" with user patches"
+
+ # patch version string for bug reports
+ rm VERSION.neo || die # we already flag it appropriate
+ sed -i -e 's/"Mutt %s (%s)"/"Mutt %s (%s, Gentoo '"${PVR}${upatches}, NeoMutt ${NEOMUTT})"'"/' \
+ muttlib.c || die "failed patching in Gentoo version"
+
+ # many patches touch the buildsystem, we always need this
+ AT_M4DIR="m4" eautoreconf
+
+ # the configure script contains some "cleverness" whether or not to setgid
+ # the dotlock program, resulting in bugs like #278332
+ sed -i -e 's/@DOTLOCK_GROUP@//' \
+ Makefile.in || die "sed failed"
+
+ # don't just build documentation (lengthy process, with big dependencies)
+ if use !doc ; then
+ sed -i -e '/SUBDIRS =/s/doc//' Makefile.in || die
+ fi
+}
+
+src_configure() {
+ local myconf="
+ $(use_enable crypt pgp) \
+ $(use_enable debug) \
+ $(use_enable gpg gpgme) \
+ $(use_enable imap) \
+ $(use_enable nls) \
+ $(use_enable nntp) \
+ $(use_enable pop) \
+ $(use_enable sidebar) \
+ $(use_enable smime) \
+ $(use_enable smtp) \
+ $(use_enable notmuch) \
+ $(use_with idn) \
+ $(use_with kerberos gss) \
+ $(use slang && echo --with-slang=${EPREFIX}/usr) \
+ $(use !slang && echo --with-curses=${EPREFIX}/usr) \
+ --enable-compressed \
+ --enable-external-dotlock \
+ --enable-nfs-fix \
+ --sysconfdir=${EPREFIX}/etc/${PN} \
+ --with-docdir=${EPREFIX}/usr/share/doc/${PN}-${PVR} \
+ --with-regex \
+ --with-exec-shell=${EPREFIX}/bin/sh"
+
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ # arrows in index view do not show when using wchar_t
+ myconf+=" --without-wc-funcs"
+ fi
+
+ # mutt prioritizes gdbm over bdb, so we will too.
+ # hcache feature requires at least one database is in USE.
+ if use tokyocabinet; then
+ myconf="${myconf} --enable-hcache \
+ --with-tokyocabinet --without-qdbm --without-gdbm --without-bdb"
+ elif use qdbm; then
+ myconf="${myconf} --enable-hcache \
+ --without-tokyocabinet --with-qdbm --without-gdbm --without-bdb"
+ elif use gdbm ; then
+ myconf="${myconf} --enable-hcache \
+ --without-tokyocabinet --without-qdbm --with-gdbm --without-bdb"
+ elif use berkdb; then
+ myconf="${myconf} --enable-hcache \
+ --without-tokyocabinet --without-qdbm --without-gdbm --with-bdb"
+ else
+ myconf="${myconf} --disable-hcache \
+ --without-tokyocabinet --without-qdbm --without-gdbm --without-bdb"
+ fi
+
+ # there's no need for gnutls, ssl or sasl without socket support
+ if use pop || use imap || use smtp ; then
+ if use gnutls; then
+ myconf="${myconf} --with-gnutls"
+ elif use ssl; then
+ myconf="${myconf} --with-ssl"
+ fi
+ # not sure if this should be mutually exclusive with the other two
+ myconf="${myconf} $(use_with sasl)"
+ else
+ myconf="${myconf} --without-gnutls --without-ssl --without-sasl"
+ fi
+
+ if use mbox; then
+ myconf="${myconf} --with-mailpath=${EPREFIX}/var/spool/mail"
+ else
+ myconf="${myconf} --with-homespool=Maildir"
+ fi
+
+ econf ${myconf} || die "configure failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ if use mbox; then
+ insinto /etc/mutt
+ newins "${FILESDIR}"/Muttrc.mbox Muttrc
+ else
+ insinto /etc/mutt
+ doins "${FILESDIR}"/Muttrc
+ fi
+
+ # A newer file is provided by app-misc/mime-types. So we link it.
+ rm "${ED}"/etc/${PN}/mime.types
+ dosym /etc/mime.types /etc/${PN}/mime.types
+
+ # A man-page is always handy, so fake one
+ if use !doc; then
+ emake -C doc DESTDIR="${D}" muttrc.man || die
+ # make the fake slightly better, bug #413405
+ sed -e 's#@docdir@/manual.txt#http://www.mutt.org/doc/devel/manual.html#' \
+ -e 's#in @docdir@,#at http://www.mutt.org/,#' \
+ -e "s#@sysconfdir@#${EPREFIX}/etc/${PN}#" \
+ -e "s#@bindir@#${EPREFIX}/usr/bin#" \
+ doc/mutt.man > mutt.1
+ cp doc/muttbug.man flea.1
+ cp doc/muttrc.man muttrc.5
+ doman mutt.1 flea.1 muttrc.5
+ else
+ # nuke manpages that should be provided by an MTA, bug #177605
+ rm "${ED}"/usr/share/man/man5/{mbox,mmdf}.5 \
+ || ewarn "failed to remove files, please file a bug"
+ fi
+
+ if use !prefix ; then
+ fowners root:mail /usr/bin/mutt_dotlock
+ fperms g+s /usr/bin/mutt_dotlock
+ fi
+
+ dodoc BEWARE COPYRIGHT ChangeLog NEWS OPS* PATCHES README* TODO VERSION
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ echo
+ elog "If you are new to mutt you may want to take a look at"
+ elog "the Gentoo QuickStart Guide to Mutt E-Mail:"
+ elog " https://wiki.gentoo.org/wiki/Mutt"
+ echo
+ else
+ echo
+ elog "This version of Mutt is entirely based on NeoMutt patches."
+ elog "Please visit http://www.neomutt.org/ to learn more about this project."
+ elog "As a result, SmartTime functionality has been replaced with"
+ elog "CondDate feature. To mimic SmartTime, use this CondDate formatter:"
+ elog "%<[12m?%<[7d?%<[12H?%[%H:%M ]&%[%a-%d]>&%[%d-%b]>&%[%b-%y]>"
+ echo
+ fi
+}