summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-02-17 21:30:26 -0500
committerMichael Orlitzky <mjo@gentoo.org>2017-02-17 21:30:26 -0500
commit6479a33da7e746a4aa3fed299943a8cdecaa18c9 (patch)
treefbcac9a755483e1562a17ea6ae0d4867fbc549d3 /mail-client
parentsys-apps/openrc: remove the tools use flag from the live ebuild for #600742 (diff)
downloadgentoo-6479a33da7e746a4aa3fed299943a8cdecaa18c9.tar.gz
gentoo-6479a33da7e746a4aa3fed299943a8cdecaa18c9.tar.bz2
gentoo-6479a33da7e746a4aa3fed299943a8cdecaa18c9.zip
mail-client/alpine: remove two old revisions with permission from robbat2.
Package-Manager: portage-2.3.3
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/alpine/alpine-2.00-r5.ebuild112
-rw-r--r--mail-client/alpine/alpine-2.00-r6.ebuild115
-rw-r--r--mail-client/alpine/metadata.xml1
3 files changed, 0 insertions, 228 deletions
diff --git a/mail-client/alpine/alpine-2.00-r5.ebuild b/mail-client/alpine/alpine-2.00-r5.ebuild
deleted file mode 100644
index 8d4a68fa03d3..000000000000
--- a/mail-client/alpine/alpine-2.00-r5.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=4
-
-inherit eutils flag-o-matic autotools multilib toolchain-funcs
-
-CHAPPA_PL=115
-DESCRIPTION="alpine is an easy to use text-based based mail and news client"
-HOMEPAGE="http://www.washington.edu/alpine/ http://patches.freeiz.com/alpine/"
-SRC_URI="ftp://ftp.cac.washington.edu/alpine/${P}.tar.bz2
- chappa? ( http://patches.freeiz.com/alpine/patches/alpine-2.00/all.patch.gz
- -> ${P}-chappa-${CHAPPA_PL}-all.patch.gz )"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="alpha amd64 ia64 ppc sparc x86"
-IUSE="doc ipv6 kerberos ldap nls onlyalpine passfile smime spell ssl threads topal +chappa"
-
-DEPEND="virtual/pam
- >=net-libs/c-client-2007f-r4[topal=,chappa=]
- >=sys-libs/ncurses-5.1
- ssl? ( dev-libs/openssl )
- ldap? ( net-nds/openldap )
- kerberos? ( app-crypt/mit-krb5 )
- spell? ( app-text/aspell )
- topal? ( >=net-mail/topal-72 )"
-RDEPEND="${DEPEND}
- app-misc/mime-types
- !onlyalpine? ( !mail-client/pine )
- !<=net-mail/uw-imap-2004g"
-
-pkg_setup() {
- if use smime && use topal ; then
- ewarn "You can not have USE='smime topal'. Assuming topal is more important."
- fi
-}
-
-src_prepare() {
- use chappa && epatch "${DISTDIR}/${P}-chappa-${CHAPPA_PL}-all.patch.gz"
- use topal && epatch /usr/share/topal/patches/"${P}".patch-{1,2}
-
- # do not use the bundled c-client
- ebegin "Unbundling the c-client library"
- rm -rf "${S}"/imap
- local f
- while read f ; do
- sed -i -e \
- 's~^#include[[:blank:]]".*/c-client/\(.*\)"~#include <imap/\1>~g' "$f"
- done < <(find "${S}" -name "*.c" -o -name "*.h")
- eend $?
-
- epatch "${FILESDIR}"/2.00-lpam.patch
- epatch "${FILESDIR}"/2.00-lcrypto.patch
- epatch "${FILESDIR}"/2.00-c-client.patch
- epatch "${FILESDIR}"/2.00-qa.patch
- use chappa && epatch "${FILESDIR}/2.00-qa-chappa-${CHAPPA_PL}.patch"
-
- eautoreconf
-}
-
-src_configure() {
- local myconf="--without-tcl
- --with-system-pinerc=/etc/pine.conf
- --with-system-fixed-pinerc=/etc/pine.conf.fixed"
- #--disable-debug"
- # fixme
- # --with-system-mail-directory=DIR?
-
- if use ssl; then
- myconf+=" --with-ssl
- --with-ssl-include-dir=/usr
- --with-ssl-lib-dir=/usr/$(get_libdir)
- --with-ssl-certs-dir=/etc/ssl/certs"
- else
- myconf+="--without-ssl"
- fi
- econf \
- $(use_with ldap) \
- $(use_with passfile passfile .pinepwd) \
- $(use_with kerberos krb5) \
- $(use_with threads pthread) \
- $(use_with spell interactive-spellcheck /usr/bin/aspell) \
- $(use_enable nls) \
- $(use_with ipv6) \
- $(use topal || use_with smime) \
- ${myconf}
-}
-
-src_compile() {
- emake AR=$(tc-getAR)
-}
-
-src_install() {
- if use onlyalpine ; then
- dobin alpine/alpine
- doman doc/alpine.1
- else
- emake DESTDIR="${D}" install
- doman doc/rpdump.1 doc/rpload.1
- fi
-
- dodoc NOTICE README*
-
- if use doc ; then
- dodoc doc/brochure.txt doc/tech-notes.txt
-
- docinto html/tech-notes
- dohtml -r doc/tech-notes/
- fi
-}
diff --git a/mail-client/alpine/alpine-2.00-r6.ebuild b/mail-client/alpine/alpine-2.00-r6.ebuild
deleted file mode 100644
index d4855a9c4e5e..000000000000
--- a/mail-client/alpine/alpine-2.00-r6.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=4
-
-inherit eutils flag-o-matic autotools multilib toolchain-funcs
-
-CHAPPA_PL=115
-DESCRIPTION="alpine is an easy to use text-based based mail and news client"
-HOMEPAGE="http://www.washington.edu/alpine/ http://patches.freeiz.com/alpine/"
-SRC_URI="ftp://ftp.cac.washington.edu/alpine/${P}.tar.bz2
- chappa? ( http://patches.freeiz.com/alpine/patches/alpine-2.00/all.patch.gz
- -> ${P}-chappa-${CHAPPA_PL}-all.patch.gz )"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
-IUSE="doc ipv6 kerberos ldap libressl nls onlyalpine passfile smime spell ssl threads topal +chappa"
-
-DEPEND="virtual/pam
- >=net-libs/c-client-2007f-r4[topal=,chappa=]
- >=sys-libs/ncurses-5.1
- ssl? (
- !libressl? ( dev-libs/openssl:0 )
- libressl? ( dev-libs/libressl )
- )
- ldap? ( net-nds/openldap )
- kerberos? ( app-crypt/mit-krb5 )
- spell? ( app-text/aspell )
- topal? ( >=net-mail/topal-72 )"
-RDEPEND="${DEPEND}
- app-misc/mime-types
- !onlyalpine? ( !mail-client/pine )
- !<=net-mail/uw-imap-2004g"
-
-pkg_setup() {
- if use smime && use topal ; then
- ewarn "You can not have USE='smime topal'. Assuming topal is more important."
- fi
-}
-
-src_prepare() {
- use chappa && epatch "${DISTDIR}/${P}-chappa-${CHAPPA_PL}-all.patch.gz"
- use topal && epatch /usr/share/topal/patches/"${P}".patch-{1,2}
-
- # do not use the bundled c-client
- ebegin "Unbundling the c-client library"
- rm -rf "${S}"/imap
- local f
- while read f ; do
- sed -i -e \
- 's~^#include[[:blank:]]".*/c-client/\(.*\)"~#include <imap/\1>~g' "$f"
- done < <(find "${S}" -name "*.c" -o -name "*.h")
- eend $?
-
- epatch "${FILESDIR}"/2.00-lpam.patch
- epatch "${FILESDIR}"/2.00-lcrypto.patch
- epatch "${FILESDIR}"/2.00-c-client.patch
- epatch "${FILESDIR}"/2.00-qa.patch
- use chappa && epatch "${FILESDIR}/2.00-qa-chappa-${CHAPPA_PL}.patch"
-
- eautoreconf
-}
-
-src_configure() {
- local myconf="--without-tcl
- --with-system-pinerc=/etc/pine.conf
- --with-system-fixed-pinerc=/etc/pine.conf.fixed"
- #--disable-debug"
- # fixme
- # --with-system-mail-directory=DIR?
-
- if use ssl; then
- myconf+=" --with-ssl
- --with-ssl-include-dir=/usr
- --with-ssl-lib-dir=/usr/$(get_libdir)
- --with-ssl-certs-dir=/etc/ssl/certs"
- else
- myconf+="--without-ssl"
- fi
- econf \
- $(use_with ldap) \
- $(use_with passfile passfile .pinepwd) \
- $(use_with kerberos krb5) \
- $(use_with threads pthread) \
- $(use_with spell interactive-spellcheck /usr/bin/aspell) \
- $(use_enable nls) \
- $(use_with ipv6) \
- $(use topal || use_with smime) \
- ${myconf}
-}
-
-src_compile() {
- emake AR=$(tc-getAR)
-}
-
-src_install() {
- if use onlyalpine ; then
- dobin alpine/alpine
- doman doc/alpine.1
- else
- emake DESTDIR="${D}" install
- doman doc/rpdump.1 doc/rpload.1
- fi
-
- dodoc NOTICE README*
-
- if use doc ; then
- dodoc doc/brochure.txt doc/tech-notes.txt
-
- docinto html/tech-notes
- dohtml -r doc/tech-notes/
- fi
-}
diff --git a/mail-client/alpine/metadata.xml b/mail-client/alpine/metadata.xml
index e5896a708f8e..a2485d48e63f 100644
--- a/mail-client/alpine/metadata.xml
+++ b/mail-client/alpine/metadata.xml
@@ -13,6 +13,5 @@
<flag name="passfile">Adds support for caching passwords into a file
between sessions</flag>
<flag name="smime">Enable support for S/MIME</flag>
- <flag name="topal">Enable support for <pkg>net-mail/topal</pkg></flag>
</use>
</pkgmetadata>