summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2016-09-01 15:07:09 +0200
committerFabian Groffen <grobian@gentoo.org>2016-09-01 15:08:10 +0200
commit7e18cbcde5883a589de28e3dbdc3a6528261725b (patch)
tree286d17008c9e6a0d27a2870bae702d23901fe978 /mail-client
parentwww-client/chromium: x86 stable wrt bug #592630 (diff)
downloadgentoo-7e18cbcde5883a589de28e3dbdc3a6528261725b.tar.gz
gentoo-7e18cbcde5883a589de28e3dbdc3a6528261725b.tar.bz2
gentoo-7e18cbcde5883a589de28e3dbdc3a6528261725b.zip
mail-client/mutt: version bump to 1.7.0
Package-Manager: portage-2.2.28
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/mutt/Manifest2
-rw-r--r--mail-client/mutt/mutt-1.7.0.ebuild263
2 files changed, 265 insertions, 0 deletions
diff --git a/mail-client/mutt/Manifest b/mail-client/mutt/Manifest
index 8825d7a72b34..db81b945f0d3 100644
--- a/mail-client/mutt/Manifest
+++ b/mail-client/mutt/Manifest
@@ -6,3 +6,5 @@ DIST mutt-1.6.1-gentoo-patches-r5.tar.xz 173228 SHA256 cce80ae3b385ed43bedb36748
DIST mutt-1.6.1.tar.gz 3956840 SHA256 98b26cecc6b1713082fc880344fa345c20bd7ded6459abe18c84429c7cf8ed20 SHA512 a45c7bc681ea31a6ee37e95a11f3ec84f580478367250c80eaf5aceeba87e34411346a8b7e80a0f236c507cec1199ddc3ccf4596b81d7e31c235099dccdd4fd5 WHIRLPOOL 8cc8e699fbf1832eb411f4f3d59eac57450afade4ddfee3ecb89c0bbaaa92414779f8f2015ec05a9ed19deb88b40298b2f786afb91acbfc2a44a3f8f4876a712
DIST mutt-1.6.2-patches-neomutt-20160710.tar.gz 498925 SHA256 9bceb0cbc66ccbdebe9d6e043125a4589586bc8bfded61168f9ed0a9956f6d67 SHA512 1d9aa8f29cef200c84fbb0e33b1c6d5f9abffb1b038bacf1a1da3b35e9faa2dc6cc43656eaf5a8e3f6ee2af3f999ccee54ce0e842950ac7b7036e83fdbcb8d04 WHIRLPOOL fae79c8d419f8c3cc1e527c9b4f20c2b1257c3e86fac066f6fc9dafe8262417a181685f8d3f2cabfed34fcb1dd42077171a89ac1f04b0ca6d7f8ee74d3e16ed6
DIST mutt-1.6.2.tar.gz 3956745 SHA256 c5d02ef06486cdf04f9eeb9e9d7994890d8dfa7f47e7bfeb53a2a67da2ac1d8e SHA512 c4348ba55459a2f9d5bedda1ec63b7520c0bdcd285bf791972dbd11a947be47e7c88b02c7d244e65c7c0f1be252c43240b570457a5812bf8160611bba7b01916 WHIRLPOOL 4adf29c59dffa50f5e7c8500a81f89ddbda894ade20bc3110cbedefbcdd7db3c2e84aae78d0cb4bc74930a94256738a3b0b1880b840fd81ec433b23b609887de
+DIST mutt-1.7.0.tar.gz 4019567 SHA256 1d3e987433d8c92ef88a604f4dcefdb35a86ce73f3eff0157e2e491e5b55b345 SHA512 60ff00f268285c12b48e39ca0b5a8bd7e09323255874a6211edc94218ed191ad24ad437dd9c180c45ea6d5a9f163d04bb5515ddf3488c92f4e9411588c550612 WHIRLPOOL 90d28dcb1b522e4cf1ce995e7dad69b5546f26e6878f7d1c2785c9e7e2c12fdfd464c7b2490fa7efa873aa22cf117f7369b1a69adfb1c9efe13e61ed15e27e05
+DIST mutt-gentoo-1.7.0-patches-r0.tar.xz 150888 SHA256 1df4e408ad4acadeb9cc44570b43b145bb096619d436a27cfb62904c223fd796 SHA512 69e9d487ace18d25e0bdf44d78b9e382d4bd2ef3e2878836cbc62af1a58486191716085a82e064f758fc5bf410fee1108c371fea25bf12aba28e22f042cfdb21 WHIRLPOOL cd566c849b3f1ce276011f9867d5537b4bfac1a161fc1e2bc800ca662c5f4fd9ddabba4decfb45e71cc8748fddc5a72e9ca1c51e1dc191500c1de7ccbd03e370
diff --git a/mail-client/mutt/mutt-1.7.0.ebuild b/mail-client/mutt/mutt-1.7.0.ebuild
new file mode 100644
index 000000000000..ac0fa93c4836
--- /dev/null
+++ b/mail-client/mutt/mutt-1.7.0.ebuild
@@ -0,0 +1,263 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit eutils flag-o-matic autotools
+
+#NEOMUTT="neomutt-20160710"
+NEOMUTT="gentoo r0"
+
+DESCRIPTION="A small but very powerful text-based mail client"
+HOMEPAGE="http://www.mutt.org/"
+SRC_URI="ftp://ftp.mutt.org/pub/mutt/${P}.tar.gz
+ https://bitbucket.org/${PN}/${PN}/downloads/${P}.tar.gz
+ https://dev.gentoo.org/~grobian/distfiles/mutt-gentoo-1.7.0-patches-r0.tar.xz"
+ #https://github.com/neomutt/integration/archive/${NEOMUTT}.tar.gz -> ${P}-patches-${NEOMUTT}.tar.gz"
+IUSE="berkdb crypt debug doc gdbm gnutls gpg idn imap kerberos libressl mbox nls nntp notmuch pop qdbm sasl selinux sidebar slang smime smtp ssl tokyocabinet"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~x86 ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+CDEPEND="
+ app-misc/mime-types
+ nls? ( virtual/libintl )
+ tokyocabinet? ( dev-db/tokyocabinet )
+ !tokyocabinet? (
+ qdbm? ( dev-db/qdbm )
+ !qdbm? (
+ gdbm? ( sys-libs/gdbm )
+ !gdbm? ( berkdb? ( >=sys-libs/db-4 ) )
+ )
+ )
+ imap? (
+ gnutls? ( >=net-libs/gnutls-1.0.17 )
+ !gnutls? (
+ ssl? (
+ !libressl? ( >=dev-libs/openssl-0.9.6:0 )
+ libressl? ( dev-libs/libressl )
+ )
+ )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )
+ )
+ kerberos? ( virtual/krb5 )
+ pop? (
+ gnutls? ( >=net-libs/gnutls-1.0.17 )
+ !gnutls? (
+ ssl? (
+ !libressl? ( >=dev-libs/openssl-0.9.6:0 )
+ libressl? ( dev-libs/libressl )
+ )
+ )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )
+ )
+ smtp? (
+ gnutls? ( >=net-libs/gnutls-1.0.17 )
+ !gnutls? (
+ ssl? (
+ !libressl? ( >=dev-libs/openssl-0.9.6:0 )
+ libressl? ( dev-libs/libressl )
+ )
+ )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )
+ )
+ idn? ( net-dns/libidn )
+ gpg? ( >=app-crypt/gpgme-0.9.0 )
+ smime? (
+ !libressl? ( >=dev-libs/openssl-0.9.6:0 )
+ libressl? ( dev-libs/libressl )
+ )
+ notmuch? ( net-mail/notmuch )
+ slang? ( sys-libs/slang )
+ !slang? ( >=sys-libs/ncurses-5.2:0 )
+"
+DEPEND="${CDEPEND}
+ net-mail/mailbase
+ doc? (
+ dev-libs/libxml2
+ dev-libs/libxslt
+ app-text/docbook-xsl-stylesheets
+ || ( www-client/lynx www-client/w3m www-client/elinks )
+ )"
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-mutt )
+"
+
+src_prepare() {
+ #local PATCHDIR="${WORKDIR}"/integration-${NEOMUTT}
+ local PATCHDIR="${WORKDIR}"/gentoo-mutt-1.7.0-patches
+
+ # apply NeoMutt patches
+ export EPATCH_FORCE="yes"
+ export EPATCH_SUFFIX="patch"
+ # order of patches from README.md
+ local patches=(
+ #bugs-common
+ bugs-gentoo
+ features-common
+ features-extra
+ #bugs-neomutt
+ gentoo
+ )
+ local patchset
+ for patchset in "${patches[@]}" ; do
+ einfo "Applying NeoMutt ${NEOMUTT} patchset ${patchset}"
+ EPATCH_SOURCE="${PATCHDIR}"/${patchset} epatch \
+ || die "NeoMutt patchset ${patchset} failed"
+ done
+ # add some explanation as to why not going to upstream
+ sed -i \
+ -e '/ReachingUs = N_(/a\"This release of Mutt is heavily enriched by NeoMutt patches.\\nFor this reason, any bugs are better reported at https://bugs.gentoo.org/\\nor directly to the NeoMutt project.\\n\\n"' \
+ version.c || die "Failed to add bug instructions"
+
+ local upatches=
+ # allow user patches
+ eapply_user && upatches=" with user patches"
+
+ # patch version string for bug reports
+ #rm VERSION.neo || die # we already flag it appropriate
+ sed -i -e 's/"Mutt %s (%s)"/"Mutt %s (%s, Gentoo '"${PVR}${upatches}, NeoMutt ${NEOMUTT})"'"/' \
+ muttlib.c || die "failed patching in Gentoo version"
+
+ # many patches touch the buildsystem, we always need this
+ AT_M4DIR="m4" eautoreconf
+
+ # the configure script contains some "cleverness" whether or not to setgid
+ # the dotlock program, resulting in bugs like #278332
+ sed -i -e 's/@DOTLOCK_GROUP@//' \
+ Makefile.in || die "sed failed"
+
+ # don't just build documentation (lengthy process, with big dependencies)
+ if use !doc ; then
+ sed -i -e '/SUBDIRS =/s/doc//' Makefile.in || die
+ fi
+}
+
+src_configure() {
+ local myconf="
+ $(use_enable crypt pgp) \
+ $(use_enable debug) \
+ $(use_enable gpg gpgme) \
+ $(use_enable imap) \
+ $(use_enable nls) \
+ $(use_enable nntp) \
+ $(use_enable pop) \
+ $(use_enable sidebar) \
+ $(use_enable smime) \
+ $(use_enable smtp) \
+ $(use_enable notmuch) \
+ $(use_with idn) \
+ $(use_with kerberos gss) \
+ $(use slang && echo --with-slang=${EPREFIX}/usr) \
+ $(use !slang && echo --with-curses=${EPREFIX}/usr) \
+ --enable-compressed \
+ --enable-external-dotlock \
+ --enable-nfs-fix \
+ --sysconfdir=${EPREFIX}/etc/${PN} \
+ --with-docdir=${EPREFIX}/usr/share/doc/${PN}-${PVR} \
+ --with-regex \
+ --with-exec-shell=${EPREFIX}/bin/sh"
+
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ # arrows in index view do not show when using wchar_t
+ myconf+=" --without-wc-funcs"
+ fi
+
+ # mutt prioritizes gdbm over bdb, so we will too.
+ # hcache feature requires at least one database is in USE.
+ if use tokyocabinet; then
+ myconf="${myconf} --enable-hcache \
+ --with-tokyocabinet --without-qdbm --without-gdbm --without-bdb"
+ elif use qdbm; then
+ myconf="${myconf} --enable-hcache \
+ --without-tokyocabinet --with-qdbm --without-gdbm --without-bdb"
+ elif use gdbm ; then
+ myconf="${myconf} --enable-hcache \
+ --without-tokyocabinet --without-qdbm --with-gdbm --without-bdb"
+ elif use berkdb; then
+ myconf="${myconf} --enable-hcache \
+ --without-tokyocabinet --without-qdbm --without-gdbm --with-bdb"
+ else
+ myconf="${myconf} --disable-hcache \
+ --without-tokyocabinet --without-qdbm --without-gdbm --without-bdb"
+ fi
+
+ # there's no need for gnutls, ssl or sasl without socket support
+ if use pop || use imap || use smtp ; then
+ if use gnutls; then
+ myconf="${myconf} --with-gnutls"
+ elif use ssl; then
+ myconf="${myconf} --with-ssl"
+ fi
+ # not sure if this should be mutually exclusive with the other two
+ myconf="${myconf} $(use_with sasl)"
+ else
+ myconf="${myconf} --without-gnutls --without-ssl --without-sasl"
+ fi
+
+ if use mbox; then
+ myconf="${myconf} --with-mailpath=${EPREFIX}/var/spool/mail"
+ else
+ myconf="${myconf} --with-homespool=Maildir"
+ fi
+
+ econf ${myconf} || die "configure failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ if use mbox; then
+ insinto /etc/mutt
+ newins "${FILESDIR}"/Muttrc.mbox Muttrc
+ else
+ insinto /etc/mutt
+ doins "${FILESDIR}"/Muttrc
+ fi
+
+ # A newer file is provided by app-misc/mime-types. So we link it.
+ rm "${ED}"/etc/${PN}/mime.types
+ dosym /etc/mime.types /etc/${PN}/mime.types
+
+ # A man-page is always handy, so fake one
+ if use !doc; then
+ emake -C doc DESTDIR="${D}" muttrc.man || die
+ # make the fake slightly better, bug #413405
+ sed -e 's#@docdir@/manual.txt#http://www.mutt.org/doc/devel/manual.html#' \
+ -e 's#in @docdir@,#at http://www.mutt.org/,#' \
+ -e "s#@sysconfdir@#${EPREFIX}/etc/${PN}#" \
+ -e "s#@bindir@#${EPREFIX}/usr/bin#" \
+ doc/mutt.man > mutt.1
+ cp doc/muttbug.man flea.1
+ cp doc/muttrc.man muttrc.5
+ doman mutt.1 flea.1 muttrc.5
+ else
+ # nuke manpages that should be provided by an MTA, bug #177605
+ rm "${ED}"/usr/share/man/man5/{mbox,mmdf}.5 \
+ || ewarn "failed to remove files, please file a bug"
+ fi
+
+ if use !prefix ; then
+ fowners root:mail /usr/bin/mutt_dotlock
+ fperms g+s /usr/bin/mutt_dotlock
+ fi
+
+ dodoc BEWARE COPYRIGHT ChangeLog NEWS OPS* PATCHES README* TODO VERSION
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ echo
+ elog "If you are new to mutt you may want to take a look at"
+ elog "the Gentoo QuickStart Guide to Mutt E-Mail:"
+ elog " https://wiki.gentoo.org/wiki/Mutt"
+ echo
+ else
+ echo
+ elog "This version of Mutt is entirely based on NeoMutt patches."
+ elog "Please visit http://www.neomutt.org/ to learn more about this project."
+ elog "As a result, SmartTime functionality has been replaced with"
+ elog "CondDate feature. To mimic SmartTime, use this CondDate formatter:"
+ elog "%<[12m?%<[7d?%<[12H?%[%H:%M ]&%[%a-%d]>&%[%d-%b]>&%[%b-%y]>"
+ echo
+ fi
+}