summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfe İzbudak <efe.izbudak@metu.edu.tr>2022-11-18 09:43:35 -0500
committerJoonas Niilola <juippis@gentoo.org>2022-11-25 10:09:35 +0200
commit7ecdb86e475d263c967289aa0793800b4734b5cf (patch)
treef8daf96194f8e53bc8ace953e85251205739e6a4 /mail-client
parentsys-cluster/charliecloud: drop 0.28 (diff)
downloadgentoo-7ecdb86e475d263c967289aa0793800b4734b5cf.tar.gz
gentoo-7ecdb86e475d263c967289aa0793800b4734b5cf.tar.bz2
gentoo-7ecdb86e475d263c967289aa0793800b4734b5cf.zip
mail-client/mutt-wizard: add 3.3.1
Signed-off-by: Efe İzbudak <efe.izbudak@metu.edu.tr> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/mutt-wizard/Manifest1
-rw-r--r--mail-client/mutt-wizard/mutt-wizard-3.3.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/mail-client/mutt-wizard/Manifest b/mail-client/mutt-wizard/Manifest
index b90033263cea..ff044cd6f8da 100644
--- a/mail-client/mutt-wizard/Manifest
+++ b/mail-client/mutt-wizard/Manifest
@@ -1 +1,2 @@
DIST mutt-wizard-3.2.1.tar.gz 33468 BLAKE2B 60087ca8b6cfe2f69e1f078942ef24be8d387fbadcacfdf0105e6ee6df315a57fb21320635b685dad5e5e15860adb9cef147dc9b029d77bfdfd196f219faca91 SHA512 bcd72a937d142bddb2c3b55bd6f5442a96421850ef57931e147aad8feefd6752de90cc7076802f5c806edc9a530e05a24576e33f301196eee707a75aa16279a6
+DIST mutt-wizard-3.3.1.tar.gz 34813 BLAKE2B 8f900700349441fb1d80e16697c2310d4a9319d8abb655657306bced8826b3a31b31e89146eef89610c18ff3eae39462a43670148336de527ffd7434c78d6ce2 SHA512 be41917935e21f8d2fe1eac4efcd832484c8cc93d8c6b6891c679615f8d5309b8450d2fe64e85742bae5e9fd8ef069be5764a667feccece25d2e775961e6c58c
diff --git a/mail-client/mutt-wizard/mutt-wizard-3.3.1.ebuild b/mail-client/mutt-wizard/mutt-wizard-3.3.1.ebuild
new file mode 100644
index 000000000000..29ac2070ab81
--- /dev/null
+++ b/mail-client/mutt-wizard/mutt-wizard-3.3.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature
+
+DESCRIPTION="A system for automatically configuring neomutt and isync"
+HOMEPAGE="https://github.com/LukeSmithxyz/mutt-wizard"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/LukeSmithxyz/mutt-wizard.git"
+else
+ SRC_URI="https://github.com/LukeSmithxyz/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="
+ app-admin/pass
+ mail-client/neomutt[notmuch,sasl]
+ mail-mta/msmtp
+ net-mail/isync[ssl]
+"
+
+# needed because there is no 'all' target defined in MAKEFILE
+src_compile() {
+ return 0;
+}
+
+src_install() {
+ emake PREFIX="${EPREFIX}/usr" DESTDIR="${D}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ optfeature "enable viewing html mails" www-client/lynx
+ optfeature "enable periodic syncing of mails" virtual/cron
+ optfeature "enable viewing of simple images" media-gfx/imagemagick
+ optfeature "enable notifications when syncing using mailsync" x11-libs/libnotify
+ optfeature "enable command line address book" app-misc/abook
+ optfeature "enable use of gpg for signing and verifying" app-crypt/gnupg
+}