summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /mail-filter/clamassassin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'mail-filter/clamassassin')
-rw-r--r--mail-filter/clamassassin/Manifest1
-rw-r--r--mail-filter/clamassassin/clamassassin-1.2.4.ebuild39
-rw-r--r--mail-filter/clamassassin/metadata.xml10
3 files changed, 50 insertions, 0 deletions
diff --git a/mail-filter/clamassassin/Manifest b/mail-filter/clamassassin/Manifest
new file mode 100644
index 000000000000..58e71b5e15d2
--- /dev/null
+++ b/mail-filter/clamassassin/Manifest
@@ -0,0 +1 @@
+DIST clamassassin-1.2.4.tar.gz 35350 SHA256 63bae3963d27548d0fc7bbf76eb6bc5506291e9e1cb95aa13390497c4c17a100
diff --git a/mail-filter/clamassassin/clamassassin-1.2.4.ebuild b/mail-filter/clamassassin/clamassassin-1.2.4.ebuild
new file mode 100644
index 000000000000..f9968aef65cc
--- /dev/null
+++ b/mail-filter/clamassassin/clamassassin-1.2.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="A simple spamassassin-like script for virus scanning (through clamav) and filtering e-mail messages"
+HOMEPAGE="http://jameslick.com/clamassassin/"
+SRC_URI="http://jameslick.com/clamassassin/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+IUSE="subject-rewrite clamd"
+DEPEND=">=app-antivirus/clamav-0.90
+ sys-apps/debianutils
+ sys-apps/which
+ mail-filter/procmail"
+
+src_compile() {
+ # Try to get location of clamd's DatabaseDirectory
+ local clamav_dbdir=`awk '$1 == "DatabaseDirectory" { print $2 }' \
+ /etc/clamd.conf`
+ # If not defined in clamd.conf, go with default
+ if [ -z "$clamav_dbdir" ] ; then
+ clamav_dbdir="/var/lib/clamav"
+ fi
+ # Add an entry to sandbox write prediction list, so sandbox doesn't complain
+ addpredict ${clamav_dbdir}/
+
+ econf \
+ $(use_enable subject-rewrite) \
+ $(use_enable clamd clamdscan) \
+ || die
+ # Fix problems with Portage exporting TMP and breaking clamassassin. #61806
+ sed -i -e "s:${TMP}:/tmp:" clamassassin
+}
+
+src_install() {
+ dobin clamassassin
+ dodoc CHANGELOG LICENSE README
+}
diff --git a/mail-filter/clamassassin/metadata.xml b/mail-filter/clamassassin/metadata.xml
new file mode 100644
index 000000000000..065f543536b2
--- /dev/null
+++ b/mail-filter/clamassassin/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-mail</herd>
+<use>
+ <flag name='clamd'>Use the <pkg>app-antivirus/clamav</pkg> daemon for virus
+ checking</flag>
+ <flag name='subject-rewrite'>Adds support for subject rewriting</flag>
+</use>
+</pkgmetadata>