summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2016-05-26 09:20:26 +0000
committerEray Aslan <eras@gentoo.org>2016-05-26 09:20:26 +0000
commita21e3d837224c170f12bbae98872094ff1d609fe (patch)
tree9afa14ff9bc837b6fc71f2c6fdc0c07b1234db56 /mail-filter/mailfilter/mailfilter-0.8.4.ebuild
parentgit-r3.eclass: Remove special logic for obsolete Google Code (diff)
downloadgentoo-a21e3d837224c170f12bbae98872094ff1d609fe.tar.gz
gentoo-a21e3d837224c170f12bbae98872094ff1d609fe.tar.bz2
gentoo-a21e3d837224c170f12bbae98872094ff1d609fe.zip
mail-filter/mailfilter: version bump to 0.8.4
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'mail-filter/mailfilter/mailfilter-0.8.4.ebuild')
-rw-r--r--mail-filter/mailfilter/mailfilter-0.8.4.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/mail-filter/mailfilter/mailfilter-0.8.4.ebuild b/mail-filter/mailfilter/mailfilter-0.8.4.ebuild
new file mode 100644
index 000000000000..fe77ba7b3586
--- /dev/null
+++ b/mail-filter/mailfilter/mailfilter-0.8.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Mailfilter is a utility to get rid of unwanted spam mails"
+HOMEPAGE="http://mailfilter.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mailfilter/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="+ssl"
+
+DEPEND="sys-devel/flex
+ ssl? ( dev-libs/openssl:* )"
+RDEPEND=""
+
+src_configure() {
+ econf $(use_with ssl openssl)
+}
+
+src_install() {
+ default
+ dodoc INSTALL doc/FAQ "${FILESDIR}"/rcfile.example{1,2}
+}