summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /mail-filter/scmail
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'mail-filter/scmail')
-rw-r--r--mail-filter/scmail/Manifest1
-rw-r--r--mail-filter/scmail/files/scmail-doc-encoding.diff28
-rw-r--r--mail-filter/scmail/files/scmail-gauche-0.9.diff35
-rw-r--r--mail-filter/scmail/metadata.xml7
-rw-r--r--mail-filter/scmail/scmail-1.3.ebuild35
5 files changed, 106 insertions, 0 deletions
diff --git a/mail-filter/scmail/Manifest b/mail-filter/scmail/Manifest
new file mode 100644
index 000000000000..1d4f2e79602f
--- /dev/null
+++ b/mail-filter/scmail/Manifest
@@ -0,0 +1 @@
+DIST scmail-1.3.tar.gz 52744 SHA256 04648e6d9d48e934b2324596d2b0b887cc6d8b324d4d6533e248ba511b6bb525
diff --git a/mail-filter/scmail/files/scmail-doc-encoding.diff b/mail-filter/scmail/files/scmail-doc-encoding.diff
new file mode 100644
index 000000000000..5ed00a62d02d
--- /dev/null
+++ b/mail-filter/scmail/files/scmail-doc-encoding.diff
@@ -0,0 +1,28 @@
+--- scmail-1.3.orig/doc/embed.scm
++++ scmail-1.3/doc/embed.scm
+@@ -1,3 +1,4 @@
++(use gauche.charconv)
+ (use gauche.regexp)
+ (define (escape str)
+ (set! str (regexp-replace-all #/&/ str "&amp;"))
+@@ -15,12 +16,18 @@
+ (define (main args)
+ (call-with-input-file (cadr args)
+ (lambda (in)
+- (let* ((content (port->string in))
++ (let* ((content (port->string (open-input-conversion-port in "*jp")))
+ (content (regexp-replace-all #/#\{(.*?)\}/ content
+ (lambda (m)
+ (string-append
+ "<pre>\n"
+ (read-file-and-escape (rxmatch-substring m 1))
+- "</pre>\n")))))
++ "</pre>\n"))))
++ (content (regexp-replace #/(encoding=").*?(")/ content
++ (lambda (m)
++ (string-append
++ (rxmatch-substring m 1)
++ (ces-guess-from-string content "*jp")
++ (rxmatch-substring m 2))))))
+ (display content))))
+ 0)
diff --git a/mail-filter/scmail/files/scmail-gauche-0.9.diff b/mail-filter/scmail/files/scmail-gauche-0.9.diff
new file mode 100644
index 000000000000..36fc3b3daa77
--- /dev/null
+++ b/mail-filter/scmail/files/scmail-gauche-0.9.diff
@@ -0,0 +1,35 @@
+--- scmail-1.3.orig/scbayes.in
++++ scmail-1.3/scbayes.in
+@@ -16,6 +16,7 @@
+
+ (use gauche.parseopt)
+ (use gauche.parameter)
++(use gauche.version)
+ (use dbm)
+ (use dbm.gdbm) ;; should be customizable
+ (use util.digest)
+@@ -130,12 +131,18 @@
+ (sys-rename (temporary-table-file) (table-file))
+ (sys-rename (temporary-digest-file) (digest-file)))))
+
+-(define (lock)
+- (unless (eq? (create-directory* (lock-file)) #t)
+- (scmail-wformat "~a is now being updated" (table-file))
+- (scmail-wformat "or perhaps ~a is staled." (lock-file))
+- (scmail-eformat "(Please remove the lock file if it is staled.)"))
+- )
++(if (version<? (gauche-version) "0.9")
++ (define (lock)
++ (unless (eq? (create-directory* (lock-file)) #t)
++ (scmail-wformat "~a is now being updated" (table-file))
++ (scmail-wformat "or perhaps ~a is staled." (lock-file))
++ (scmail-eformat "(Please remove the lock file if it is staled.)")))
++ (define (lock)
++ (guard (e (else
++ (scmail-wformat "~a is now being updated" (table-file))
++ (scmail-wformat "or perhaps ~a is staled." (lock-file))
++ (scmail-eformat "(Please remove the lock file if it is staled.)")))
++ (create-directory* (lock-file)))))
+
+ (define force-learn? (make-parameter #f))
+
diff --git a/mail-filter/scmail/metadata.xml b/mail-filter/scmail/metadata.xml
new file mode 100644
index 000000000000..d4a08224d284
--- /dev/null
+++ b/mail-filter/scmail/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>hattya@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/mail-filter/scmail/scmail-1.3.ebuild b/mail-filter/scmail/scmail-1.3.ebuild
new file mode 100644
index 000000000000..78cb1ff70c6f
--- /dev/null
+++ b/mail-filter/scmail/scmail-1.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils fixheadtails
+
+DESCRIPTION="a mail filter written in Scheme"
+HOMEPAGE="http://0xcc.net/scmail/"
+SRC_URI="http://0xcc.net/scmail/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND="dev-scheme/gauche"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-*.diff
+ ht_fix_file tests/scmail-commands
+ # replace make -> $(MAKE)
+ sed -i "s/make\( \|$\)/\$(MAKE)\1/g" Makefile
+}
+
+src_install() {
+ emake \
+ PREFIX="${ED}/usr" \
+ SITELIBDIR="${ED}$(gauche-config --sitelibdir)" \
+ DATADIR="${ED}/usr/share/doc/${P}" \
+ install
+ dohtml doc/*.html
+}