summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2015-08-23 21:44:46 -0400
committerMichael Orlitzky <mjo@gentoo.org>2015-08-23 21:55:13 -0400
commit86c0ba4ada7933bb88c60aa74cdef42e1a03125a (patch)
tree8c3c39105cb793bda6cf38e06eedf2e9fe8dc162 /mail-filter
parentprofiles: mask USE=jit for dev-qt/qtdeclarative where unsupported. (diff)
downloadgentoo-86c0ba4ada7933bb88c60aa74cdef42e1a03125a.tar.gz
gentoo-86c0ba4ada7933bb88c60aa74cdef42e1a03125a.tar.bz2
gentoo-86c0ba4ada7933bb88c60aa74cdef42e1a03125a.zip
mail-filter/pypolicyd-spf: version bump to v1.3.2.
Standard version bump. In the process, SRC_URI was changed to use pypi which is mirrored (and allows us to drop versionator.eclass). Package-Manager: portage-2.2.20.1
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/pypolicyd-spf/Manifest1
-rw-r--r--mail-filter/pypolicyd-spf/pypolicyd-spf-1.3.2.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/mail-filter/pypolicyd-spf/Manifest b/mail-filter/pypolicyd-spf/Manifest
index e13c38e0290..70f65c12626 100644
--- a/mail-filter/pypolicyd-spf/Manifest
+++ b/mail-filter/pypolicyd-spf/Manifest
@@ -2,3 +2,4 @@ DIST pypolicyd-spf-1.1.2.tar.gz 30813 SHA256 f8999a9febc5ccb4a66f9961e4ec2d8f81b
DIST pypolicyd-spf-1.1.tar.gz 469687 SHA256 93ca747e1e62d05a3e3fa54b9415f6c6da7fa40644e32507d0bb56980e31cc56 SHA512 7968425ae5b966571b0787769eff484f4d779f02c8460f515b98549117fdf270de70861f61b8c3e7d9da2092e91c191055cd9a312303c50a2b4707e9dd92840e WHIRLPOOL cd47648c122a13e99c08dac9cfee5cbe12b5b4301dc389397ca824ef19ed976beeee02e7f17fb0faf8abe29184be3aeb73c7ab327a0e6b19d7f84434f20b3635
DIST pypolicyd-spf-1.2.tar.gz 30783 SHA256 e1a94c79ad91cfea17b9c8b19b035536f06d75ff9ee2e8478191e7c27fe69f74 SHA512 266dc129f0d0bf59b809d3ec6f47369c73d6c5287b1505f0762a9e92ab9dbc3b6afc14ff59d8298012dc4c8b2e7c05d85bab227e71592bc0ee47b0a88cf4df45 WHIRLPOOL 8817c0357aa6850010f144d66408048edf569977eb65f733bedbc3f996273a1d636948ce86ec38cf4b81df66d5546acc2d8dced0185ec93f469d919242405e8e
DIST pypolicyd-spf-1.3.1.tar.gz 32093 SHA256 5b575638e3d30db5583ed4e3c0902b9a6d90ba7e126a9d37b9bffe2e6b201808 SHA512 3ae52b22ef3c4f801a523aa98b6c918b7afd76c5867e8cb431b643555e4191f85b1232d7ef431fbfbdd76cfc59bd021ce452b2f323ab0166ab68d1bf06cc1a10 WHIRLPOOL ebd9997369510ead087c039ec505904fb58fd36eed3c9d38bc1602569b7c3b1e0d1648b69fbf6b1c83a84a7ec4de52f180fc30498cc2850fb53c836cec1e5900
+DIST pypolicyd-spf-1.3.2.tar.gz 32973 SHA256 7174c46a26c9c35b0d66ddba821b02b0dc2df9d1f6bf0c9da71dcd60795b2966 SHA512 e80b13a0cf9f8406592db5edcb9770051352b3f637d4d9d5bd96295710bf3728a8350c0697e5b430698b0d9d226c83c9decb67923ed5cdb3502ee15509715af4 WHIRLPOOL 91051b0702098b14d0e8281184219f7c96304b59b8a56b7088810af83383b18feb414b53eb259f9d13a37a108373633adeb4a7f866bbd54a480cb1ec287af6a6
diff --git a/mail-filter/pypolicyd-spf/pypolicyd-spf-1.3.2.ebuild b/mail-filter/pypolicyd-spf/pypolicyd-spf-1.3.2.ebuild
new file mode 100644
index 00000000000..080046136cb
--- /dev/null
+++ b/mail-filter/pypolicyd-spf/pypolicyd-spf-1.3.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+# With >=python-3.3, the built-in ipaddress module handles the parsing
+# of IP addresses. If python is built without ipv6 support, then
+# ipaddress can't parse ipv6 addresses, and the daemon will crash if it
+# sees an ipv6 SPF record. In other words, it's completely broken.
+#
+# Ideally this would remain optional for python-2.x, but until there's
+# an easy way to do that, "maybe annoying" seems a better option than
+# "maybe broken."
+PYTHON_REQ_USE="ipv6"
+
+inherit distutils-r1
+
+DESCRIPTION="Python-based policy daemon for Postfix SPF verification"
+HOMEPAGE="https://launchpad.net/${PN}"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# ipaddr is only needed with <python-3.3.
+#
+# The lower bound on pyspf is not strictly necessary, but some features
+# are silently disabled with older versions of pyspf.
+#
+DEPEND="$(python_gen_cond_dep \
+ '>=dev-python/ipaddr-2.1.10[${PYTHON_USEDEP}]' \
+ 'python2*')
+ >=dev-python/pyspf-2.0.9[${PYTHON_USEDEP}]"
+
+RDEPEND="${DEPEND}
+ dev-python/authres[${PYTHON_USEDEP}]"
+
+DOCS=( CHANGES policyd-spf.conf.commented README README.per_user_whitelisting )
+
+python_prepare_all() {
+ # The "real" config file mentions the commented one, so we point
+ # users in the right direction.
+ local oldconf="policyd-spf.conf.commented"
+ local newconf="/usr/share/doc/${PF}/${oldconf}"
+
+ sed -i "1 s~ ${oldconf}~,\n# ${newconf}~" policyd-spf.conf \
+ || die 'failed to update commented config file path'
+
+ distutils-r1_python_prepare_all
+}