summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com>2019-06-11 09:22:59 -0400
committerMichał Górny <mgorny@gentoo.org>2019-06-18 13:34:50 +0200
commitb7ed9f6c0a61212a4f641dae13d2a9c8fde17736 (patch)
tree5d13dd3212258aa45dc12d4d027f209267ef153e /mail-filter
parentmedia-libs/jbig2dec: ia64 stable wrt bug #681528 (diff)
downloadgentoo-b7ed9f6c0a61212a4f641dae13d2a9c8fde17736.tar.gz
gentoo-b7ed9f6c0a61212a4f641dae13d2a9c8fde17736.tar.bz2
gentoo-b7ed9f6c0a61212a4f641dae13d2a9c8fde17736.zip
mail-filter/postforward: Version bump to 1.1.1
Copy of the 1.1.0 ebuild, update copyright & EAPI, and tweak to remove double-negative new_src_dir check. Closes: https://bugs.gentoo.org/687858 Closes: https://github.com/gentoo/gentoo/pull/12239 Signed-off-by: Philippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com> Package-Manager: Portage-2.3.66, Repoman-2.3.11 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/postforward/Manifest1
-rw-r--r--mail-filter/postforward/postforward-1.1.1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/mail-filter/postforward/Manifest b/mail-filter/postforward/Manifest
index 7cdc14db3424..b81a6d09c8e4 100644
--- a/mail-filter/postforward/Manifest
+++ b/mail-filter/postforward/Manifest
@@ -1 +1,2 @@
DIST postforward-1.1.0.tar.gz 5707 BLAKE2B 2dc994628820b40caf3b9c65ad6be48e220abff8f5a6d6054b109600d9d368fab3e6e642dbc5a98235f440359600a3f4bbc19f7ead06fd84802a8900fa465dc1 SHA512 39d7a33c454b1529a691b24fd69b311ba368caf59168d39146654cfe319ebc3cf73835e66e6c95a43747f389a6b954ac8da0d7e934e562c16cb85dc20c0f4804
+DIST postforward-1.1.1.tar.gz 6086 BLAKE2B ecf344af646b745fa9860279f6c91ba5ab74a5dc93a1cb09168091b01ebe5e804062afa32a51b34f65c5c89c08e401a8a4e1beb145c07bcfb848c970f6f4e1f7 SHA512 1f29e1731ef9fd1292f932a8e195577ce238f69c2e6ae1ffac81a577607fda98563b454564841011ce077cc8453e5ad78d2ab904fdf0fea67c15a69f6b2a3d92
diff --git a/mail-filter/postforward/postforward-1.1.1.ebuild b/mail-filter/postforward/postforward-1.1.1.ebuild
new file mode 100644
index 000000000000..f9f2be8689ca
--- /dev/null
+++ b/mail-filter/postforward/postforward-1.1.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit golang-build
+
+DESCRIPTION="Postfix Sender Rewriting Scheme forwarding agent"
+EGO_PN="${PN}"
+SRC_URI="https://github.com/zoni/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/zoni/postforward"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-lang/go:0"
+RDEPEND="
+ mail-filter/postsrsd"
+
+PATCHES=( "${FILESDIR}/${PN}_apply-sendmail-path.patch" )
+
+src_prepare() {
+ default
+
+ # Dynamically fix EPREFIX lines made by ${PN}_apply-sendmail-path.patch
+ sed -i -e "s/@GENTOO_PORTAGE_EPREFIX@/${EPREFIX}/" *.go || die
+
+ # go build assumes files will be in src dir, but
+ # source files are in root in this package, so move
+ # them.
+ local new_src_dir="${S}/src/${EGO_PN}"
+ # Freak out if there's already something there because
+ # it means the package has changed and we'll need to
+ # adjust to it.
+ [[ -e "${new_src_dir}" ]] && die "${new_src_dir} already exists"
+ mkdir -p "${new_src_dir}" || die
+ mv *.go "${new_src_dir}" || die
+}
+
+# Standard golang-build src_install complains about pkg not
+# existing, so we go custom.
+src_install() {
+ einstalldocs
+ dosbin "${PN}"
+}