summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2016-10-12 14:10:31 +0200
committerJason A. Donenfeld <zx2c4@gentoo.org>2016-10-12 14:10:31 +0200
commitf53035a57c8fd1eee881fb85b2dc3c194c7729ca (patch)
tree2bdc00e205bcad06452be2bff142f671717f01c3 /mail-filter
parentmail-mta/opensmtpd: bump (diff)
downloadgentoo-f53035a57c8fd1eee881fb85b2dc3c194c7729ca.tar.gz
gentoo-f53035a57c8fd1eee881fb85b2dc3c194c7729ca.tar.bz2
gentoo-f53035a57c8fd1eee881fb85b2dc3c194c7729ca.zip
mail-filter/opensmtpd-extras: bump
Package-Manager: portage-2.3.2
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/opensmtpd-extras/Manifest1
-rw-r--r--mail-filter/opensmtpd-extras/opensmtpd-extras-5.9.2.201609141255.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/mail-filter/opensmtpd-extras/Manifest b/mail-filter/opensmtpd-extras/Manifest
index c123151bcf90..7eaf4ff32c92 100644
--- a/mail-filter/opensmtpd-extras/Manifest
+++ b/mail-filter/opensmtpd-extras/Manifest
@@ -1 +1,2 @@
DIST opensmtpd-extras-201606062304.tar.gz 631098 SHA256 d04e00200adfd850d5f2ed98108f71cb789dc904b212e16bb0a775f8fa06fa2d SHA512 7af916ed71fb81518bccbc7a82946a2a8252d2b70663238d7eea21841c82926221f03ab7afebd79d49f41e970e62c2dd70234ebaa0d27be5a9c5bbb4ae4ef7d8 WHIRLPOOL 077522d35e1c526490441f6a41bb69d441ddd25f53cebdc1f11380332b44956320cf0304687e7e5b5bf82be523801a7d4e6b5aacf7d87506b795d4fe96dbdb4f
+DIST opensmtpd-extras-201609141255.tar.gz 561289 SHA256 2a892e538fdf9cc9963a4a2cfc596494ffd244e5f220f34514f73b523353f82e SHA512 df9caf235095edd1f8535e41a3aedc51a5674a62d66d0749d5bb0d4433f3ea54e0b31a8b3a4d619b7ca79b64bcb1576b97f220c60cb3f48080d1972b7a46cc0b WHIRLPOOL 7e74a9eb03dbca479f90eac3f2def4cdafaef437b6bbf30b8a2ebb37167ee929e53ded91ada425a5f6d197405e7a5e69f903026c156f434ba21c41284b544b08
diff --git a/mail-filter/opensmtpd-extras/opensmtpd-extras-5.9.2.201609141255.ebuild b/mail-filter/opensmtpd-extras/opensmtpd-extras-5.9.2.201609141255.ebuild
new file mode 100644
index 000000000000..78bc40450109
--- /dev/null
+++ b/mail-filter/opensmtpd-extras/opensmtpd-extras-5.9.2.201609141255.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic autotools versionator
+
+DESCRIPTION="Extra tables, filters, and various other addons for OpenSMTPD"
+HOMEPAGE="https://github.com/OpenSMTPD/OpenSMTPD-extras"
+SRC_URI="https://www.opensmtpd.org/archives/${PN}-$(get_version_component_range 4-).tar.gz"
+
+LICENSE="ISC BSD BSD-1 BSD-2 BSD-4"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+MY_COMPONENTS="
+ filter-monkey
+ filter-stub
+ filter-trace
+ filter-void
+
+ queue-null
+ queue-python
+ queue-ram
+ queue-stub
+
+ scheduler-python
+ scheduler-ram
+ scheduler-stub
+
+ table-ldap
+ table-mysql
+ table-passwd
+ table-postgres
+ table-python
+ table-redis
+ table-socketmap
+ table-sqlite
+ table-stub
+"
+IUSE="${MY_COMPONENTS} libressl luajit"
+
+# Deps:
+# mysql needs -lmysqlclient
+# sqlite needs -lsqlite3
+# redis needs -lhiredis
+# postgres requires -lpq
+# ldap uses internal library and requires no deps
+# spamassassin uses internal library and requires no deps
+# clamav uses internal library and requires no deps
+# dnsbl needs -lasr
+# python requires python, currently pegged at 2.7
+# lua requires any lua version
+
+#filter-python? ( dev-lang/python:2.7 )
+#filter-perl? ( dev-lang/perl )
+#filter-dnsbl? ( net-libs/libasr )
+#filter-lua? ( luajit? ( dev-lang/luajit:2 ) !luajit? ( dev-lang/lua:* ) )
+DEPEND="mail-mta/opensmtpd
+ dev-libs/libevent
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )
+ table-sqlite? ( dev-db/sqlite:3 )
+ table-mysql? ( virtual/mysql )
+ table-postgres? ( dev-db/postgresql:* )
+ table-redis? ( dev-libs/hiredis )
+ table-python? ( dev-lang/python:2.7 )
+ scheduler-python? ( dev-lang/python:2.7 )
+ queue-python? ( dev-lang/python:2.7 )
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}-$(get_version_component_range 4-)
+
+src_prepare() {
+ eautoreconf
+}
+src_configure() {
+ econf $(for use in $MY_COMPONENTS; do use_with $use; done) \
+ --with-user-smtpd=smtpd \
+ --sysconfdir=/etc/opensmtpd
+ #--with-lua-type=$(usex luajit luajit lua) \
+}