summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-03-07 16:39:06 -0500
committerMike Frysinger <vapier@gentoo.org>2016-03-07 16:39:06 -0500
commitfd0c3a3111e0809008e02050368fd10980a53140 (patch)
tree7886a45d1b3b94dbd669a88ab9b4d235aecf44d8 /mail-mta/nullmailer
parentsys-apps/pciutils: enable LFS support #471102 (diff)
downloadgentoo-fd0c3a3111e0809008e02050368fd10980a53140.tar.gz
gentoo-fd0c3a3111e0809008e02050368fd10980a53140.tar.bz2
gentoo-fd0c3a3111e0809008e02050368fd10980a53140.zip
mail-mta/nullmailer: style cleanups -- no functional changes
Diffstat (limited to 'mail-mta/nullmailer')
-rw-r--r--mail-mta/nullmailer/asd123
-rw-r--r--mail-mta/nullmailer/nullmailer-2.0.ebuild4
2 files changed, 2 insertions, 125 deletions
diff --git a/mail-mta/nullmailer/asd b/mail-mta/nullmailer/asd
deleted file mode 100644
index c461dea32331..000000000000
--- a/mail-mta/nullmailer/asd
+++ /dev/null
@@ -1,123 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit autotools eutils flag-o-matic multilib systemd user
-
-DESCRIPTION="Simple relay-only local mail transport agent"
-HOMEPAGE="http://untroubled.org/nullmailer/"
-SRC_URI="http://untroubled.org/${PN}/archive/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="amd64 ppc x86"
-IUSE="ssl"
-
-DEPEND="
- sys-apps/groff
- ssl? ( net-libs/gnutls )"
-RDEPEND="
- virtual/logger
- virtual/shadow
- ssl? ( net-libs/gnutls )
- !mail-mta/courier
- !mail-mta/esmtp
- !mail-mta/exim
- !mail-mta/mini-qmail
- !mail-mta/msmtp
- !mail-mta/netqmail
- !mail-mta/postfix
- !mail-mta/qmail-ldap
- !mail-mta/sendmail
- !mail-mta/opensmtpd
- !mail-mta/ssmtp"
-
-pkg_setup() {
- enewgroup nullmail 88
- enewuser nullmail 88 -1 /var/spool/nullmailer nullmail
-}
-
-src_prepare() {
- sed -e "s#/usr/local/etc#/etc#" -e "s#/usr/local/libexec#/usr/libexec#" -i doc/nullmailer-send.8
-}
-
-src_configure() {
- econf \
- --localstatedir=/var \
- $(use_enable ssl tls)
-}
-
-src_install () {
- emake DESTDIR="${D}" install
-
- dodoc AUTHORS BUGS HOWTO INSTALL ChangeLog NEWS README TODO doc/DIAGRAM
-
- # A small bit of sample config
- insinto /etc/nullmailer
- newins "${FILESDIR}"/remotes.sample-1.13 remotes
-
- # This contains passwords, so should be secure
- fperms 0640 /etc/nullmailer/remotes
- fowners root:nullmail /etc/nullmailer/remotes
-
- # daemontools stuff
- dodir /var/spool/nullmailer/service{,/log}
-
- insinto /var/spool/nullmailer/service
- newins scripts/nullmailer.run run
- fperms 700 /var/spool/nullmailer/service/run
-
- insinto /var/spool/nullmailer/service/log
- newins scripts/nullmailer-log.run run
- fperms 700 /var/spool/nullmailer/service/log/run
-
- # usability
- dosym /usr/sbin/sendmail usr/$(get_libdir)/sendmail
-
- # permissions stuff
- keepdir /var/log/nullmailer /var/spool/nullmailer/{tmp,queue}
- fperms 770 /var/log/nullmailer /var/spool/nullmailer/{tmp,queue}
- fowners nullmail:nullmail /usr/sbin/nullmailer-queue /usr/bin/mailq
- fperms 4711 /usr/sbin/nullmailer-queue /usr/bin/mailq
-
- newinitd "${FILESDIR}"/init.d-nullmailer-r4 nullmailer
- systemd_dounit scripts/${PN}.service
-}
-
-pkg_postinst() {
- if [ ! -e "${ROOT}"/var/spool/nullmailer/trigger ]; then
- mkfifo "${ROOT}"/var/spool/nullmailer/trigger
- fi
- chown nullmail:nullmail \
- "${ROOT}"/var/log/nullmailer "${ROOT}"/var/spool/nullmailer/{tmp,queue,trigger} || die
- chmod 770 "${ROOT}"/var/log/nullmailer "${ROOT}"/var/spool/nullmailer/{tmp,queue} || die
- chmod 660 "${ROOT}"/var/spool/nullmailer/trigger || die
-
- # This contains passwords, so should be secure
- chmod 0640 "${ROOT}"/etc/nullmailer/remotes || die
- chown root:nullmail "${ROOT}"/etc/nullmailer/remotes || die
-
- if [[ -z ${REPLACING_VERSIONS} ]]; then
- elog "To create an initial setup, please do:"
- elog "emerge --config =${CATEGORY}/${PF}"
- fi
-}
-
-pkg_postrm() {
- if [[ -e "${ROOT}"/var/spool/nullmailer/trigger ]]; then
- rm "${ROOT}"/var/spool/nullmailer/trigger || die
- fi
-}
-
-pkg_config() {
- if [ ! -s "${ROOT}"/etc/nullmailer/me ]; then
- einfo "Setting /etc/nullmailer/me"
- /bin/hostname --fqdn > "${ROOT}"/etc/nullmailer/me
- fi
- if [ ! -s "${ROOT}"/etc/nullmailer/defaultdomain ]; then
- einfo "Setting /etc/nullmailer/defaultdomain"
- /bin/hostname --domain > "${ROOT}"/etc/nullmailer/defaultdomain
- fi
-}
diff --git a/mail-mta/nullmailer/nullmailer-2.0.ebuild b/mail-mta/nullmailer/nullmailer-2.0.ebuild
index 1c3e959c890b..859c4b300a8d 100644
--- a/mail-mta/nullmailer/nullmailer-2.0.ebuild
+++ b/mail-mta/nullmailer/nullmailer-2.0.ebuild
@@ -10,8 +10,8 @@ DESCRIPTION="Simple relay-only local mail transport agent"
HOMEPAGE="http://untroubled.org/nullmailer/"
SRC_URI="http://untroubled.org/${PN}/archive/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="ssl"
@@ -61,7 +61,7 @@ src_configure() {
$(use_enable ssl tls)
}
-src_install () {
+src_install() {
default
# A small bit of sample config