summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuel Holland <samuel@sholland.org>2017-01-11 17:19:19 -0600
committerJason A. Donenfeld <zx2c4@gentoo.org>2017-04-12 16:05:23 +0200
commit8a8806e399ae2045c594aaaa6bdabc203d67208d (patch)
tree12784d586ee9190d1718b55cdfd58847b061a87f /mail-mta/opensmtpd/files/opensmtpd-6.0.2_p1-musl.patch
parentdev-libs/libIDL: add prefix keywords (diff)
downloadgentoo-8a8806e399ae2045c594aaaa6bdabc203d67208d.tar.gz
gentoo-8a8806e399ae2045c594aaaa6bdabc203d67208d.tar.bz2
gentoo-8a8806e399ae2045c594aaaa6bdabc203d67208d.zip
mail-mta/opensmtpd: revbump to fix libressl and musl
One patch is a backport from upstream. The other two have been submitted upstream as pull requests. Gentoo-Bug: 598822 Fixes: #3438
Diffstat (limited to 'mail-mta/opensmtpd/files/opensmtpd-6.0.2_p1-musl.patch')
-rw-r--r--mail-mta/opensmtpd/files/opensmtpd-6.0.2_p1-musl.patch51
1 files changed, 51 insertions, 0 deletions
diff --git a/mail-mta/opensmtpd/files/opensmtpd-6.0.2_p1-musl.patch b/mail-mta/opensmtpd/files/opensmtpd-6.0.2_p1-musl.patch
new file mode 100644
index 000000000000..065fbcdbe1a6
--- /dev/null
+++ b/mail-mta/opensmtpd/files/opensmtpd-6.0.2_p1-musl.patch
@@ -0,0 +1,51 @@
+From 2ab442623e689532910b34ff0dbbc2167da02330 Mon Sep 17 00:00:00 2001
+From: Samuel Holland <samuel@sholland.org>
+Date: Wed, 11 Jan 2017 17:39:07 -0600
+Subject: [PATCH] fix musl compatibility (missing function prototypes)
+
+inet_net_pton is already compiled, but no prototype is provided.
+res_hnok is provided by the compatibility layer in libasr.
+
+These fixes avoid warnings about implicit function declaration.
+
+Fixes #758
+---
+ configure.ac | 1 +
+ openbsd-compat/openbsd-compat.h | 8 ++++++++
+ 2 files changed, 9 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+index 42e092f..e27c514 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -594,6 +594,7 @@ AC_CHECK_FUNCS([ \
+ pledge \
+ pw_dup \
+ reallocarray \
++ res_hnok \
+ setenv \
+ setlinebuf \
+ setproctitle \
+diff --git a/openbsd-compat/openbsd-compat.h b/openbsd-compat/openbsd-compat.h
+index a51385b..5d2e2c2 100644
+--- a/openbsd-compat/openbsd-compat.h
++++ b/openbsd-compat/openbsd-compat.h
+@@ -208,10 +208,18 @@ void *reallocarray(void *, size_t, size_t);
+ void errc(int, int, const char *, ...);
+ #endif
+
++#ifndef HAVE_INET_NET_PTON
++int inet_net_pton(int, const char *, void *, size_t);
++#endif
++
+ #ifndef HAVE_PLEDGE
+ #define pledge(promises, paths) 0
+ #endif
+
++#ifndef HAVE_RES_HNOK
++int res_hnok(const char *);
++#endif
++
+ #if !HAVE_DECL_AF_LOCAL
+ #define AF_LOCAL AF_UNIX
+ #endif