summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2018-04-16 18:38:19 +0200
committerFabian Groffen <grobian@gentoo.org>2018-04-16 18:38:30 +0200
commit3077289440d70b8f87a042cdfed42dae72b7ce49 (patch)
treebb19552756e4cc87675d880b36971552b0f5a73a /mail-mta
parentmedia-libs/vigra: amd64 stable (diff)
downloadgentoo-3077289440d70b8f87a042cdfed42dae72b7ce49.tar.gz
gentoo-3077289440d70b8f87a042cdfed42dae72b7ce49.tar.bz2
gentoo-3077289440d70b8f87a042cdfed42dae72b7ce49.zip
mail-mta/exim: specify best matching db version, bug #653252
Upstream banned >=db-6 for various reasons, so we need to tell explicitly which version of db is available (<6) to be used. Closes: https://bugs.gentoo.org/653252 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'mail-mta')
-rw-r--r--mail-mta/exim/exim-4.91.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/mail-mta/exim/exim-4.91.ebuild b/mail-mta/exim/exim-4.91.ebuild
index ff66e6daa53..d4c8a7abd70 100644
--- a/mail-mta/exim/exim-4.91.ebuild
+++ b/mail-mta/exim/exim-4.91.ebuild
@@ -3,7 +3,7 @@
EAPI="6"
-inherit eutils toolchain-funcs multilib pam systemd
+inherit db-use eutils toolchain-funcs multilib pam systemd
IUSE="arc dane dcc +dkim dlfunc dmarc +dnsdb doc dovecot-sasl dsn elibc_glibc exiscan-acl gnutls idn ipv6 ldap libressl lmtp maildir mbx mysql nis pam perl pkcs11 postgres +prdr proxy radius redis sasl selinux spf sqlite srs ssl syslog tcpd +tpda X"
REQUIRED_USE="
@@ -196,9 +196,11 @@ src_configure() {
# use the "native" interfaces to the DBM and CDB libraries, support
# passwd and directory lookups by default
+ local DB_VERS="5.3 5.1 4.8 4.7 4.6 4.5 4.4 4.3 4.2 3.2"
cat >> Makefile <<- EOC
USE_DB=yes
- DBMLIB=-ldb
+ CFLAGS+=-I$(db_includedir ${DB_VERS})
+ DBMLIB=-l$(db_libname ${DB_VERS})
LOOKUP_CDB=yes
LOOKUP_PASSWD=yes
LOOKUP_DSEARCH=yes