summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThibaud CANALE <thican@thican.net>2023-05-08 18:36:08 +0200
committerSam James <sam@gentoo.org>2023-05-08 18:34:33 +0100
commit21478a95290398fff0c5b83d341f8c829a997d26 (patch)
treea4857d7e468017a6be772c0cad4d3459c8e555cf /mate-base
parentapp-emacs/eglot: fix loading autoloads (diff)
downloadgentoo-21478a95290398fff0c5b83d341f8c829a997d26.tar.gz
gentoo-21478a95290398fff0c5b83d341f8c829a997d26.tar.bz2
gentoo-21478a95290398fff0c5b83d341f8c829a997d26.zip
mate-base/mate-desktop: add 1.26.1
Fix use after free and memory leak. Source: https://github.com/mate-desktop/mate-desktop/releases/tag/v1.26.1 Closes: https://bugs.gentoo.org/905843 Signed-off-by: Thibaud CANALE <thican@thican.net> Closes: https://github.com/gentoo/gentoo/pull/30936 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'mate-base')
-rw-r--r--mate-base/mate-desktop/Manifest1
-rw-r--r--mate-base/mate-desktop/mate-desktop-1.26.1.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/mate-base/mate-desktop/Manifest b/mate-base/mate-desktop/Manifest
index 07497e4a9ef9..937c498d6a37 100644
--- a/mate-base/mate-desktop/Manifest
+++ b/mate-base/mate-desktop/Manifest
@@ -1 +1,2 @@
DIST mate-desktop-1.26.0.tar.xz 1189048 BLAKE2B c12f4213d608b09c91b2381632f664f2e234ce6abdd13eb9f8de11d7aa575ca496945a5cc13b3e3a910094503d8572912ee0acfdad928b0be9414473432c894f SHA512 73189cf2d5106fa632ed9272d7ba069ed4ff4b3032d279dce9953e322b487463fca5ffc42af00eed4344cfdecbc9a2f95f1f2ae96386d26c0ad0cfcd0ed226cc
+DIST mate-desktop-1.26.1.tar.xz 1195960 BLAKE2B 174530b247619acdf6fd8b8c7675450ca743c644e2730a168acd8267d28bdda57cef18a95d5ba988d87a2aa88cfea10fa92109468556fbaf433b71d1ca46e561 SHA512 e5261b420da8782795899b73203c6ec3c6a45f88f09e50082020743ccaa4535fd8c1767ab5d59f1d5c295fa2d4fc8ffd0b4df787ec503b9b3a7d757eba9e18ff
diff --git a/mate-base/mate-desktop/mate-desktop-1.26.1.ebuild b/mate-base/mate-desktop/mate-desktop-1.26.1.ebuild
new file mode 100644
index 000000000000..432f8358f49d
--- /dev/null
+++ b/mate-base/mate-desktop/mate-desktop-1.26.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ "${PV}" != *9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="Libraries for the MATE desktop that are not part of the UI"
+LICENSE="FDL-1.1 GPL-2+ LGPL-2+ MIT-with-advertising"
+SLOT="0"
+
+IUSE="X debug +introspection startup-notification"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.50:2
+ >=gnome-base/dconf-0.13.4
+ x11-libs/cairo
+ x11-libs/libX11
+ >=x11-libs/libXrandr-1.3
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.7:= )
+ startup-notification? ( >=x11-libs/startup-notification-0.5:0 )
+"
+
+RDEPEND="${COMMON_DEPEND}"
+
+BDEPEND="
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/iso-codes
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=sys-devel/gettext-0.19.8
+ >=x11-libs/gdk-pixbuf-2.36.5
+ virtual/pkgconfig
+"
+
+DEPEND="${COMMON_DEPEND}
+ x11-base/xorg-proto
+"
+
+src_configure() {
+ mate_src_configure \
+ --enable-mate-about \
+ $(use_with X x) \
+ $(use_enable debug) \
+ $(use_enable introspection) \
+ $(use_enable startup-notification)
+}