summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2019-05-12 16:20:14 -0400
committerGöktürk Yüksek <gokturk@gentoo.org>2019-05-12 17:02:01 -0400
commit6659bf94d92e6e7bc788723977c8c3255aed1e0b (patch)
treef65424daee60d88527d39eb2b4f932a13e902d94 /mate-base
parentmate-base/mate-session-manager: bump to 1.22.1 (diff)
downloadgentoo-6659bf94d92e6e7bc788723977c8c3255aed1e0b.tar.gz
gentoo-6659bf94d92e6e7bc788723977c8c3255aed1e0b.tar.bz2
gentoo-6659bf94d92e6e7bc788723977c8c3255aed1e0b.zip
mate-base/mate-menus: remove unnecessary postinst
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
Diffstat (limited to 'mate-base')
-rw-r--r--mate-base/mate-menus/mate-menus-1.22.0-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/mate-base/mate-menus/mate-menus-1.22.0-r1.ebuild b/mate-base/mate-menus/mate-menus-1.22.0-r1.ebuild
new file mode 100644
index 000000000000..5fa032f4de2e
--- /dev/null
+++ b/mate-base/mate-menus/mate-menus-1.22.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+GNOME2_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="MATE menu system, implementing the F.D.O cross-desktop spec"
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+
+IUSE="debug +introspection"
+
+COMMON_DEPEND=">=dev-libs/glib-2.50:2
+ virtual/libintl
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )"
+
+RDEPEND="${COMMON_DEPEND}"
+
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.40
+ sys-devel/gettext:*
+ virtual/pkgconfig:*"
+
+src_configure() {
+ # Do NOT compile with --disable-debug/--enable-debug=no as it disables API
+ # usage checks.
+ mate_src_configure \
+ --enable-debug=$(usex debug yes minimum) \
+ $(use_enable introspection)
+}
+
+src_install() {
+ mate_src_install
+
+ exeinto /etc/X11/xinit/xinitrc.d/
+ doexe "${FILESDIR}/10-xdg-menu-mate"
+}