summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOz N Tiram <oz.tiram@gmail.com>2022-06-15 23:53:30 +0200
committerSam James <sam@gentoo.org>2022-06-28 07:07:54 +0100
commitb9724e15d854be7570eb6d2f94bce65a5e5e7cf3 (patch)
tree0edb997e2ce43fcc81d1030c27e9717902de7a36 /mate-base
parentmate-base/mate-menus: add 1.26.0 (diff)
downloadgentoo-b9724e15d854be7570eb6d2f94bce65a5e5e7cf3.tar.gz
gentoo-b9724e15d854be7570eb6d2f94bce65a5e5e7cf3.tar.bz2
gentoo-b9724e15d854be7570eb6d2f94bce65a5e5e7cf3.zip
mate-base/mate-panel: add 1.26.0
Signed-off-by: Oz N Tiram <oz.tiram@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/25917 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'mate-base')
-rw-r--r--mate-base/mate-panel/Manifest1
-rw-r--r--mate-base/mate-panel/mate-panel-1.26.0.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/mate-base/mate-panel/Manifest b/mate-base/mate-panel/Manifest
index 16f21101caee..f19eedb0fa9c 100644
--- a/mate-base/mate-panel/Manifest
+++ b/mate-base/mate-panel/Manifest
@@ -1 +1,2 @@
DIST mate-panel-1.24.2.tar.xz 3271432 BLAKE2B ca866ae2ba743d5871f75ba8840f05b556d77bcfb9263542f5e945310ebbaccdb211a266c3235ab706c70209740cd4a8a9f390363ddf18fc305ffd875723974d SHA512 6dd7b1329fc51389ad6213b5490fd44f8db7b76d17c1fa8f24b197390e9f24d4090fc7c439b7cc9c94be76f6b896ac31e69e920e903c067e297f941c844a1280
+DIST mate-panel-1.26.0.tar.xz 3303980 BLAKE2B b36ddb6d4db174bd26986193829e72e498f81e31d129aa0e64ef3927b3571b58c3bb940a1d3c4ceb14165d5d7810d812a3b39dd2ea7aad4bd9cdaf4dae84751e SHA512 394cf6a4a081980d286a03488370a5335dca681964271329b28d7254fc877457bc42883c95ad9f197a319f1bef71e237052d64b98606df616f5e11b9f9ae5f31
diff --git a/mate-base/mate-panel/mate-panel-1.26.0.ebuild b/mate-base/mate-panel/mate-panel-1.26.0.ebuild
new file mode 100644
index 000000000000..db28c21f76fa
--- /dev/null
+++ b/mate-base/mate-panel/mate-panel-1.26.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="The MATE panel"
+LICENSE="FDL-1.1+ GPL-2+ LGPL-2+"
+SLOT="0"
+
+IUSE="+X +introspection wayland"
+
+REQUIRED_USE="|| ( X wayland )"
+
+COMMON_DEPEND="
+ dev-libs/atk
+ >=dev-libs/glib-2.50:2
+ >=dev-libs/libmateweather-1.17.0
+ dev-libs/libxml2:2
+ >=gnome-base/dconf-0.13.4
+ >=mate-base/mate-desktop-1.17.0
+ >=mate-base/mate-menus-1.21.0
+ >=sys-apps/dbus-1.1.2
+ >=x11-libs/cairo-1.0.0[X?]
+ >=x11-libs/gdk-pixbuf-2.26.0:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ x11-libs/libICE
+ x11-libs/libSM
+ >=x11-libs/libwnck-3.4.6:3[introspection?]
+ >=x11-libs/pango-1.15.4:0[introspection?]
+ X? (
+ x11-libs/libX11
+ x11-libs/libXau
+ >=x11-libs/libXrandr-1.3
+ )
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+ wayland? ( gui-libs/gtk-layer-shell )
+"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/libintl
+"
+
+DEPEND="${COMMON_DEPEND}"
+
+BDEPEND="
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/yelp-tools
+ >=dev-lang/perl-5:=
+ dev-util/glib-utils
+ dev-util/gdbus-codegen
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ mate_src_configure \
+ --libexecdir=/usr/libexec/mate-applets \
+ --disable-deprecation-flags \
+ $(use_enable X x11) \
+ $(use_enable introspection) \
+ $(use_enable wayland)
+}