summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /mate-extra/caja-extensions
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'mate-extra/caja-extensions')
-rw-r--r--mate-extra/caja-extensions/Manifest1
-rw-r--r--mate-extra/caja-extensions/caja-extensions-1.8.0.ebuild78
-rw-r--r--mate-extra/caja-extensions/files/caja-extensions-1.8.0-sendto-options.patch316
-rw-r--r--mate-extra/caja-extensions/metadata.xml16
4 files changed, 411 insertions, 0 deletions
diff --git a/mate-extra/caja-extensions/Manifest b/mate-extra/caja-extensions/Manifest
new file mode 100644
index 000000000000..58750a53ba9d
--- /dev/null
+++ b/mate-extra/caja-extensions/Manifest
@@ -0,0 +1 @@
+DIST caja-extensions-1.8.0.tar.xz 343784 SHA256 71b4353236b4f13e1984a8497ff80ed63d74141833ba47a32629a5d3505bbc91 SHA512 1a59bf3ed7300d790f47494d0bef677a760fa069aaf76c2f35eb4d17b67be0fcdfa904e3a05d45ca1ff9f3016961c689aa620d37f020ed199ca2ddb3d8dd3663 WHIRLPOOL f192f8e966de8272ca65d7e856ebf26bfdbca8cf559da7571c6e372b5c9ad3b21f1e08691014546ed4cd9b6b60a5840b8a02c53d9d7ed34a8876a873771dc2be
diff --git a/mate-extra/caja-extensions/caja-extensions-1.8.0.ebuild b/mate-extra/caja-extensions/caja-extensions-1.8.0.ebuild
new file mode 100644
index 000000000000..ba75d64c3c72
--- /dev/null
+++ b/mate-extra/caja-extensions/caja-extensions-1.8.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils gnome2
+
+MATE_BRANCH="$(get_version_component_range 1-2)"
+
+SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz"
+DESCRIPTION="Several Caja extensions"
+HOMEPAGE="http://www.mate-desktop.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+SENDTO="cdr gajim +mail pidgin upnp"
+IUSE="image-converter +open-terminal share ${SENDTO}"
+
+RDEPEND=">=x11-libs/gtk+-2.18:2
+ >=dev-libs/glib-2.26:2
+ >=mate-base/caja-1.8:0
+ virtual/libintl:0
+ x11-libs/gdk-pixbuf:2
+ open-terminal? ( >=mate-base/mate-desktop-1.8:0 )
+ cdr? ( >=app-cdr/brasero-2.32.1:0= )
+ gajim? (
+ net-im/gajim:0
+ >=dev-libs/dbus-glib-0.60:0
+ >=sys-apps/dbus-1:0
+ )
+ pidgin? ( >=dev-libs/dbus-glib-0.60:0 )
+ upnp? ( >=net-libs/gupnp-0.13:0= )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.18:*
+ >=mate-base/mate-common-1.8:0
+ sys-devel/gettext:*
+ virtual/pkgconfig:*
+ !!mate-extra/mate-file-manager-open-terminal
+ !!mate-extra/mate-file-manager-sendto
+ !!mate-extra/mate-file-manager-image-converter
+ !!mate-extra/mate-file-manager-share"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.8.0-sendto-options.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ MY_CONF=""
+
+ if use cdr || use mail || use pidgin || use gajim || use upnp ; then
+ MY_CONF="${MY_CONF} --enable-sendto"
+ MY_CONF="${MY_CONF} --with-sendto-plugins=removable-devices"
+ use cdr && MY_CONF="${MY_CONF},caja-burn"
+ use mail && MY_CONF="${MY_CONF},emailclient"
+ use pidgin && MY_CONF="${MY_CONF},pidgin"
+ use gajim && MY_CONF="${MY_CONF},gajim"
+ use upnp && MY_CONF="${MY_CONF},upnp"
+ else
+ MYCONF="${MY_CONF} --disable-sendto"
+ fi
+
+ gnome2_src_configure ${MY_CONF} \
+ --disable-gksu \
+ $(use_enable image-converter) \
+ $(use_enable open-terminal) \
+ $(use_enable share)
+}
+
+DOCS="AUTHORS ChangeLog NEWS README"
diff --git a/mate-extra/caja-extensions/files/caja-extensions-1.8.0-sendto-options.patch b/mate-extra/caja-extensions/files/caja-extensions-1.8.0-sendto-options.patch
new file mode 100644
index 000000000000..5e0953a01718
--- /dev/null
+++ b/mate-extra/caja-extensions/files/caja-extensions-1.8.0-sendto-options.patch
@@ -0,0 +1,316 @@
+diff --git a/configure.ac b/configure.ac
+index fcf02d6..c38061f 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -102,19 +102,173 @@ if test "x$enable_sendto" = "xyes"; then
+ GUPNP_REQUIRED=0.13
+ PKG_CHECK_MODULES(SENDTO,
+ glib-2.0 >= $GLIB_REQUIRED
+- gio-2.0 >= $GLIB_REQUIRED
+ gthread-2.0 >= $GTHREAD_REQUIRED
+ gmodule-2.0 >= $GLIB_REQUIRED
+ gobject-2.0 >= $GLIB_REQUIRED
+- gtk+-$GTK_API_VERSION >= $GTK_REQUIRED
+- dbus-1 >= $DBUS_REQUIRED
+- dbus-glib-1 >= $DBUS_GLIB_REQUIRED
+- gupnp-1.0 >= $GUPNP_REQUIRED)
++ gtk+-$GTK_API_VERSION >= $GTK_REQUIRED)
+ AC_SUBST(SENDTO_CFLAGS)
+ AC_SUBST(SENDTO_LIBS)
+- AC_DEFINE_UNQUOTED(GAJIM_SHARE_DIR, "$prefix/share/gajim", [path to gajim share dir])
+-fi
+
++ # The full list of plugins
++ allowed_sendto_plugins="emailclient gajim caja-burn pidgin removable-devices upnp"
++
++ sendto_plugin_error_or_ignore()
++ {
++ if test "${error_on_bad_sendto_plugin}" = "1" ; then
++ AC_MSG_ERROR([$1])
++ else
++ AC_MSG_WARN([$1 (disabling sendto plugin)])
++ fi
++ }
++
++ AC_ARG_WITH([sendto-plugins],
++ [AS_HELP_STRING([--with-sendto-plugins],[Which caja-sendto plugins to compile (default: auto; "all", "autodetect" are valid)])],
++ [], [with_sendto_plugins=autodetect])
++
++ used_sendto_plugins=""
++ used_sendto_plugins2=""
++
++ if test "x${with_sendto_plugins}" = "xautodetect" ; then
++ # Default to all plugins and just ignore them if they won't compile
++ with_sendto_plugins="all"
++ error_on_bad_sendto_plugin="0"
++ else
++ # Clean up the plugin list and error if a plugin won't compile
++ with_sendto_plugins=`echo ,"${with_sendto_plugins}", | sed -e 's/[[ ,]][[ ,]]*/ /g' -e 's/,$//'`
++ error_on_bad_sendto_plugin="1"
++ fi
++
++ # Iterate through the wanted plugins and weed out bad ones (or error)
++ for wanted_sendto_plugin in ${with_sendto_plugins}; do
++ for allowed_sendto_plugin in ${allowed_sendto_plugins}; do
++ case ${wanted_sendto_plugin} in
++ all)
++ # List all plugins as being used
++ used_sendto_plugins=${allowed_sendto_plugins}
++ ;;
++ autodetect)
++ # List all plugins as being used
++ used_sendto_plugins=${allowed_sendto_plugins}
++ ;;
++ ${allowed_sendto_plugin}) used_sendto_plugins="${used_sendto_plugins} ${wanted_sendto_plugin}";; # List the plugin
++ *) ;;
++ esac
++ done
++ done
++
++ # Check for plugin-specific requirements and error if necessary
++ for sendto_plugin in ${used_sendto_plugins}; do
++ add_sendto_plugin="1"
++
++ case ${sendto_plugin} in
++ emailclient)
++ PKG_CHECK_MODULES(EMAILCLIENT, gio-2.0,
++ enable_emailclient=yes, enable_emailclient=no)
++ if test "${enable_emailclient}" != "yes" ; then
++ sendto_plugin_error_or_ignore "you need gio-2.0 to build the emailclient plugin"
++ add_sendto_plugin="0"
++ fi
++ ;;
++ gajim)
++ AC_ARG_WITH(sendto_gajim,
++ [AS_HELP_STRING(--with-sendto-gajim,[Path to Gajim install prefix])],
++ [GAJIM_PATH="$withval"],[GAJIM_PATH="$prefix"])
++
++ GAJIM_SHARE_DIR="$GAJIM_PATH"/share/gajim
++
++ PKG_CHECK_MODULES(DBUS, dbus-1 >= $DBUS_REQUIRED dbus-glib-1 >= $DBUS_GLIB_REQUIRED,
++ [AC_SUBST(DBUS_CFLAGS)
++ AC_SUBST(DBUS_LIBS)
++ enable_sendto_gajim=yes
++ AC_DEFINE_UNQUOTED(GAJIM_SHARE_DIR, "$GAJIM_SHARE_DIR", [path to gajim share dir])],
++ [enable_gajim=no])
++
++ if test "${enable_gajim}" != "yes" ; then
++ sendto_plugin_error_or_ignore "you need gajim and dbus-glib installed for the gajim plugin"
++ add_sendto_plugin="0"
++ fi
++ ;;
++ caja-burn)
++ PKG_CHECK_MODULES(GIO, gio-2.0,
++ enable_burn=yes, enable_burn=no)
++ if test "${enable_burn}" != "yes" ; then
++ sendto_plugin_error_or_ignore "you need gio installed for the caja-burn plugin"
++ add_sendto_plugin="0"
++ fi
++ ;;
++ pidgin)
++ PKG_CHECK_MODULES(PIDGIN, dbus-glib-1 >= $DBUS_GLIB_REQUIRED,
++ enable_pidgin=yes, enable_pidgin=no)
++ if test "${enable_pidgin}" != "yes" ; then
++ sendto_plugin_error_or_ignore "you need dbus-glib to build the pidgin plugin"
++ add_sendto_plugin="0"
++ fi
++ ;;
++ removable-devices)
++ PKG_CHECK_MODULES(GIO, gio-2.0,
++ enable_removable=yes, enable_removable=no)
++ if test "${enable_removable}" != "yes" ; then
++ sendto_plugin_error_or_ignore "you need gio-2.0 to build the removable-devices plugin"
++ add_sendto_plugin="0"
++ fi
++ ;;
++ upnp)
++ PKG_CHECK_MODULES(UPNP, gupnp-1.0 >= $GUPNP_REQUIRED,
++ enable_upnp=yes, enable_upnp=no)
++ if test "${enable_upnp}" != "yes" ; then
++ sendto_plugin_error_or_ignore "you need gupnp installed for the upnp plugin"
++ add_sendto_plugin="0"
++ fi
++ ;;
++ esac
++
++ # Add the specified plugin
++ if test "${add_sendto_plugin}" = "1" ; then
++ used_sendto_plugins2="${used_sendto_plugins2} ${sendto_plugin}"
++ fi
++ done
++
++ ALL_SENDTO_PLUGINS=$allowed_sendto_plugins
++ SENDTO_PLUGINS=$used_sendto_plugins2
++
++ dnl Error out if no plugins will be built
++ if test -z "${SENDTO_PLUGINS}" ; then
++ AC_MSG_ERROR([No sendto plugins will be built, and caja-sendto requires at least one])
++ fi
++
++ AC_MSG_CHECKING([which sendto plugins to compile])
++ AC_MSG_RESULT([$SENDTO_PLUGINS])
++
++ AC_SUBST([ALL_SENDTO_PLUGINS])
++ AC_SUBST([SENDTO_PLUGINS])
++
++ dnl For the pidgin sendto plugin
++ AM_CONDITIONAL(HAVE_SENDTO_PIDGIN, test "x$enable_pidgin" = "xyes")
++
++ dnl For the GIO based plugins
++ enable_nst_common=no
++ if test "x$enable_burn" = "xyes" -o "x$enable_removable" = "xyes"; then
++ enable_nst_common=yes
++ fi
++ AM_CONDITIONAL(HAVE_GIO, test "x$enable_nst_common" = "xyes")
++
++ if test "x${SENDTO_PLUGINS}" != "x" ; then
++ for allowed_sendto_plugin in ${ALL_SENDTO_PLUGINS}; do
++ for sendto_plugin in ${SENDTO_PLUGINS}; do
++ case ${allowed_sendto_plugin} in
++ ${sendto_plugin})
++ AC_MSG_NOTICE([** ${allowed_sendto_plugin} sendto plugin enabled])
++ continue 2
++ ;;
++ *);;
++ esac
++ done
++ AC_MSG_NOTICE([ ${allowed_sendto_plugin} sendto plugin disabled])
++ done
++ else
++ AC_MSG_NOTICE([ No caja-sendto plugins enabled])
++ fi
++fi
+ AM_CONDITIONAL(ENABLE_SENDTO, test x"$enable_sendto" = "xyes")
+
+ # share extension
+diff --git a/sendto/plugins/Makefile.am b/sendto/plugins/Makefile.am
+index 10097e8..6d17c98 100644
+--- a/sendto/plugins/Makefile.am
++++ b/sendto/plugins/Makefile.am
+@@ -1,16 +1,13 @@
+-SUBDIRS = . \
+- caja-burn \
+- emailclient \
+- gajim \
+- pidgin \
+- removable-devices \
+- upnp
++SUBDIRS = . $(SENDTO_PLUGINS)
++DIST_SUBDIRS = $(ALL_SENDTO_PLUGINS)
+
+ NST_COMMON_SOURCES = nst-common.c nst-common.h
+
++if HAVE_GIO
+ noinst_LTLIBRARIES = libnstcommon.la
+ libnstcommon_la_SOURCES = $(NST_COMMON_SOURCES)
+ libnstcommon_la_CFLAGS = $(SENDTO_CFLAGS)
+ libnstcommon_la_LIBADD = $(SENDTO_LIBS)
++endif
+
+ EXTRA_DIST = $(NST_COMMON_SOURCES)
+diff --git a/sendto/plugins/caja-burn/Makefile.am b/sendto/plugins/caja-burn/Makefile.am
+index 50c309b..00f95c2 100644
+--- a/sendto/plugins/caja-burn/Makefile.am
++++ b/sendto/plugins/caja-burn/Makefile.am
+@@ -9,11 +9,12 @@ AM_CPPFLAGS = \
+ -I$(srcdir)/../ \
+ $(SENDTO_CFLAGS) \
+ $(WARN_CFLAGS) \
+- $(DISABLE_DEPRECATED)
++ $(DISABLE_DEPRECATED) \
++ $(GIO_CFLAGS)
+
+ plugin_LTLIBRARIES = libnstburn.la
+
+ libnstburn_la_SOURCES = caja-burn.c
+ libnstburn_la_LDFLAGS = -module -avoid-version
+-libnstburn_la_LIBADD = $(SENDTO_LIBS) $(builddir)/../libnstcommon.la
++libnstburn_la_LIBADD = $(GIO_LIBS) $(SENDTO_LIBS) $(builddir)/../libnstcommon.la
+
+diff --git a/sendto/plugins/emailclient/Makefile.am b/sendto/plugins/emailclient/Makefile.am
+index 31ba40e..c4af752 100644
+--- a/sendto/plugins/emailclient/Makefile.am
++++ b/sendto/plugins/emailclient/Makefile.am
+@@ -7,6 +7,7 @@ AM_CPPFLAGS = \
+ -I$(top_srcdir)/sendto \
+ -I$(top_builddir) \
+ $(SENDTO_CFLAGS) \
++ $(EMAILCLIENT_CFLAGS) \
+ $(DISABLE_DEPRECATED) \
+ $(WARN_CFLAGS)
+
+@@ -14,4 +15,4 @@ plugin_LTLIBRARIES = libnstemailclient.la
+
+ libnstemailclient_la_SOURCES = emailclient.c
+ libnstemailclient_la_LDFLAGS = -module -avoid-version
+-libnstemailclient_la_LIBADD = $(SENDTO_LIBS)
++libnstemailclient_la_LIBADD = $(SENDTO_LIBS) $(EMAILCLIENT_LIBS)
+diff --git a/sendto/plugins/gajim/Makefile.am b/sendto/plugins/gajim/Makefile.am
+index 5acd5b0..c39a3c0 100644
+--- a/sendto/plugins/gajim/Makefile.am
++++ b/sendto/plugins/gajim/Makefile.am
+@@ -7,6 +7,7 @@ AM_CPPFLAGS = \
+ -I$(top_srcdir)/sendto \
+ -I$(top_builddir) \
+ $(SENDTO_CFLAGS) \
++ $(DBUS_CFLAGS) \
+ $(DISABLE_DEPRECATED) \
+ $(WARN_CFLAGS)
+
+@@ -14,5 +15,5 @@ plugin_LTLIBRARIES = libnstgajim.la
+
+ libnstgajim_la_SOURCES = gajim.c
+ libnstgajim_la_LDFLAGS = -module -avoid-version
+-libnstgajim_la_LIBADD = $(SENDTO_LIBS)
++libnstgajim_la_LIBADD = $(DBUS_LIBS) $(SENDTO_LIBS)
+
+diff --git a/sendto/plugins/pidgin/Makefile.am b/sendto/plugins/pidgin/Makefile.am
+index b7f650a..bcfe1d3 100644
+--- a/sendto/plugins/pidgin/Makefile.am
++++ b/sendto/plugins/pidgin/Makefile.am
+@@ -7,6 +7,8 @@ AM_CPPFLAGS = \
+ -I$(top_srcdir)/sendto \
+ -I$(top_builddir) \
+ $(SENDTO_CFLAGS) \
++ $(NST_EBOOK_CFLAGS) \
++ $(PIDGIN_CFLAGS) \
+ $(DISABLE_DEPRECATED) \
+ $(WARN_CFLAGS)
+
+@@ -14,5 +16,5 @@ plugin_LTLIBRARIES = libnstpidgin.la
+
+ libnstpidgin_la_SOURCES = pidgin.c
+ libnstpidgin_la_LDFLAGS = -module -avoid-version
+-libnstpidgin_la_LIBADD = $(SENDTO_LIBS)
++libnstpidgin_la_LIBADD = $(PIDGIN_LIBS) $(SENDTO_LIBS)
+
+diff --git a/sendto/plugins/removable-devices/Makefile.am b/sendto/plugins/removable-devices/Makefile.am
+index 294ca90..797353b 100644
+--- a/sendto/plugins/removable-devices/Makefile.am
++++ b/sendto/plugins/removable-devices/Makefile.am
+@@ -15,5 +15,5 @@ plugin_LTLIBRARIES = libnstremovable_devices.la
+
+ libnstremovable_devices_la_SOURCES = removable-devices.c
+ libnstremovable_devices_la_LDFLAGS = -module -avoid-version
+-libnstremovable_devices_la_LIBADD = $(SENDTO_LIBS) $(builddir)/../libnstcommon.la
++libnstremovable_devices_la_LIBADD = $(GIO_LIBS) $(SENDTO_LIBS) $(builddir)/../libnstcommon.la
+
+diff --git a/sendto/plugins/upnp/Makefile.am b/sendto/plugins/upnp/Makefile.am
+index 4127abd..31a8bd6 100644
+--- a/sendto/plugins/upnp/Makefile.am
++++ b/sendto/plugins/upnp/Makefile.am
+@@ -7,6 +7,7 @@ AM_CPPFLAGS = \
+ -I$(top_srcdir)/sendto \
+ -I$(top_builddir) \
+ $(SENDTO_CFLAGS) \
++ $(UPNP_CFLAGS) \
+ $(DISABLE_DEPRECATED) \
+ $(WARN_CFLAGS)
+
+@@ -14,5 +15,5 @@ plugin_LTLIBRARIES = libnstupnp.la
+
+ libnstupnp_la_SOURCES = upnp.c
+ libnstupnp_la_LDFLAGS = -module -avoid-version
+-libnstupnp_la_LIBADD = $(SENDTO_LIBS)
++libnstupnp_la_LIBADD = $(UPNP_LIBS) $(SENDTO_LIBS)
+
diff --git a/mate-extra/caja-extensions/metadata.xml b/mate-extra/caja-extensions/metadata.xml
new file mode 100644
index 000000000000..d719a85807c0
--- /dev/null
+++ b/mate-extra/caja-extensions/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>mate</herd>
+ <use>
+ <flag name="gajim">Add an extension to support <pkg>net-im/gajim</pkg>.</flag>
+ <flag name="image-converter">Add image conversion support.</flag>
+ <flag name="mail">Add an extension to support e-mail functionality.</flag>
+ <flag name="open-terminal">Add an extension to support an open terminal.</flag>
+ <flag name="pidgin">Add an extension to support <pkg>net-im/pidgin</pkg></flag>
+ <flag name="share">Add an extension to support sharing files.</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">mate-desktop/caja-extensions</remote-id>
+ </upstream>
+</pkgmetadata>