summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /mate-extra/mate-polkit
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'mate-extra/mate-polkit')
-rw-r--r--mate-extra/mate-polkit/Manifest1
-rw-r--r--mate-extra/mate-polkit/mate-polkit-1.8.0.ebuild48
-rw-r--r--mate-extra/mate-polkit/metadata.xml8
3 files changed, 57 insertions, 0 deletions
diff --git a/mate-extra/mate-polkit/Manifest b/mate-extra/mate-polkit/Manifest
new file mode 100644
index 000000000000..602a1f472017
--- /dev/null
+++ b/mate-extra/mate-polkit/Manifest
@@ -0,0 +1 @@
+DIST mate-polkit-1.8.0.tar.xz 324960 SHA256 bc01640c63f6248497ca78c3d8df8ff608d8bf1fbfce7c11416b014a109aeccd SHA512 6e7324c539f86a906cd192f8e6a17c417717ae80c0b9d8d46907f1e911f364f73933365520469bbed3201287ae897d8055a7fa14b103ade8e6c7cee9e30912cf WHIRLPOOL b3243bd5814e2d156fd85a376294f1c102dd8661e8716e2007291a9513429202b11ff15bbb53a5b33ea5a9cabac559836374778b99627767973f935a05617d6f
diff --git a/mate-extra/mate-polkit/mate-polkit-1.8.0.ebuild b/mate-extra/mate-polkit/mate-polkit-1.8.0.ebuild
new file mode 100644
index 000000000000..349d33913c56
--- /dev/null
+++ b/mate-extra/mate-polkit/mate-polkit-1.8.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+GCONF_DEBUG="no"
+
+inherit gnome2 versionator
+
+MATE_BRANCH="$(get_version_component_range 1-2)"
+
+SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz"
+DESCRIPTION="A MATE specific DBUS session bus service that is used to bring up authentication dialogs"
+HOMEPAGE="https://github.com/mate-desktop/mate-polkit"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+IUSE="+introspection"
+
+RDEPEND=">=dev-libs/glib-2.28:2
+ >=sys-auth/polkit-0.102:0[introspection?]
+ >=x11-libs/gtk+-2.24:2[introspection?]
+ x11-libs/gdk-pixbuf:2[introspection?]
+ virtual/libintl:0
+ introspection? ( >=dev-libs/gobject-introspection-0.6.2:0 )"
+
+# We call gtkdocize so we need to depend on gtk-doc.
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-1.3:0
+ >=dev-util/intltool-0.35:*
+ >=mate-base/mate-common-1.8:0
+ sys-devel/gettext:*
+ virtual/pkgconfig:*
+ !<gnome-extra/polkit-gnome-0.102:0"
+
+# Entropy PMS specific. This way we can install the pkg into the build chroots.
+ENTROPY_RDEPEND="!lxde-base/lxpolkit"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection)
+}
+
+DOCS="AUTHORS HACKING NEWS README"
diff --git a/mate-extra/mate-polkit/metadata.xml b/mate-extra/mate-polkit/metadata.xml
new file mode 100644
index 000000000000..98365c2ab31a
--- /dev/null
+++ b/mate-extra/mate-polkit/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>mate</herd>
+ <upstream>
+ <remote-id type="github">mate-desktop/mate-polkit</remote-id>
+ </upstream>
+</pkgmetadata>