summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2016-09-04 13:23:07 -0400
committerEttore Di Giacinto <mudler@gentoo.org>2016-11-21 11:59:46 +0100
commitec425b9c91cfa8f73ca00d879e2253a9ecabb02c (patch)
treebfc9ed203516451f6d196b3ffaf259195f0acbd5 /mate-extra/mate-polkit
parentx11-themes/mate-icon-theme: Version bump to 1.14.0 (diff)
downloadgentoo-ec425b9c91cfa8f73ca00d879e2253a9ecabb02c.tar.gz
gentoo-ec425b9c91cfa8f73ca00d879e2253a9ecabb02c.tar.bz2
gentoo-ec425b9c91cfa8f73ca00d879e2253a9ecabb02c.zip
mate-extra/mate-polkit: Version bump to 1.14.0
Package-Manager: portage-2.3.0
Diffstat (limited to 'mate-extra/mate-polkit')
-rw-r--r--mate-extra/mate-polkit/Manifest1
-rw-r--r--mate-extra/mate-polkit/mate-polkit-1.14.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/mate-extra/mate-polkit/Manifest b/mate-extra/mate-polkit/Manifest
index ad0f32a5b48d..46a10c7b9e8d 100644
--- a/mate-extra/mate-polkit/Manifest
+++ b/mate-extra/mate-polkit/Manifest
@@ -1,2 +1,3 @@
DIST mate-polkit-1.10.3.tar.xz 324732 SHA256 fb829c28da0ba99eddfe3c9440852a301462e95377d064bce9a68a5d2314b20d SHA512 39d5af5d8f1f1db1f45bbbba3b1a21754fb59f1f2682e46008cd3cfedacf22dcb0bca5175d59897206c5a2a17c6a6b4daa132ce8a96462504651884afba25ce6 WHIRLPOOL 08e614fbfd5fab0717b4a981d246127a68ae43d0827e0bc0bec83ed742a7ca35e824e3aaa4daa1756587433ceb5d5d323732310edac9dde381ff56881552ca70
DIST mate-polkit-1.12.0.tar.xz 324708 SHA256 c38f0a0c3d4e10fc95d27fa4e8d47eb6948e8c9279a82f316f563666571bf8b9 SHA512 b6e771062e29d2f4f2823638e39f5e5b349b98fcf8fd8d652d847d568eee919d37956089d7bef1463d96f801f852d10d9423bb8c20f8a54dfe8188d19ab6fb0c WHIRLPOOL bc35601f824af52ac1162aeb3342789e8fbb4f6a09b5352fffd5db87d9c02f6ddba326002a13533531c772234994c845dfbe1473563bec1c442606688b6909f4
+DIST mate-polkit-1.14.0.tar.xz 339872 SHA256 929d5710d6284f924dc65824b75e9da23b5809c50033da18b6b4b79e0f599ddd SHA512 f3507380152798af192e3338b5f056b1105fd297e935f098803c21450b04b6d149bc22106f34129a6394655be2e6505c91ad1433e817c68274a1243cc862bcdf WHIRLPOOL 034f05c91c5f79f1c77b073ff8f310e0264541e9783d98dabdc0dda5b0bc36da83ad4468563d9ecb6bdd389065b1b5d828deba02c15a94867124c6687ff54098
diff --git a/mate-extra/mate-polkit/mate-polkit-1.14.0.ebuild b/mate-extra/mate-polkit/mate-polkit-1.14.0.ebuild
new file mode 100644
index 000000000000..a107de098c9e
--- /dev/null
+++ b/mate-extra/mate-polkit/mate-polkit-1.14.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="A MATE specific DBUS service that is used to bring up authentication dialogs"
+LICENSE="LGPL-2"
+SLOT="0"
+
+IUSE="accountsservice appindicator debug examples gtk3 +introspection"
+
+COMMON_DEPEND=">=dev-libs/glib-2.36:2
+ >=sys-auth/polkit-0.102:0[introspection?]
+ x11-libs/gdk-pixbuf:2[introspection?]
+ virtual/libintl:0
+ !gtk3? (
+ >=x11-libs/gtk+-2.24:2[introspection?]
+ appindicator? ( dev-libs/libappindicator:2 )
+ )
+ gtk3? (
+ >=x11-libs/gtk+-3.0:3[introspection?]
+ appindicator? ( dev-libs/libappindicator:3 )
+ )
+ introspection? ( >=dev-libs/gobject-introspection-0.6.2:= )"
+
+RDEPEND="${COMMON_DEPEND}
+ accountsservice? ( sys-apps/accountsservice:0[introspection?] )"
+
+DEPEND="${COMMON_DEPEND}
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35:*
+ sys-devel/gettext:*
+ >=sys-devel/libtool-2.2.6
+ virtual/pkgconfig:*
+ !<gnome-extra/polkit-gnome-0.102:0"
+
+src_configure() {
+ mate_src_configure \
+ --disable-static \
+ --with-gtk=$(usex gtk3 3.0 2.0) \
+ $(use_enable accountsservice) \
+ $(use_enable appindicator) \
+ $(use_enable debug) \
+ $(use_enable examples) \
+ $(use_enable introspection)
+}