summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2016-02-08 18:44:21 -0500
committerNP-Hardass <NP-Hardass@gentoo.org>2016-02-08 21:44:39 -0500
commit2e74de6f69eb94d618310378c48c9f85546f563b (patch)
tree28c3a44f0357483c5d9a95503fa37e5e31e6edd2 /mate-extra
parentx11-themes/mate-themes: rm old (diff)
downloadgentoo-2e74de6f69eb94d618310378c48c9f85546f563b.tar.gz
gentoo-2e74de6f69eb94d618310378c48c9f85546f563b.tar.bz2
gentoo-2e74de6f69eb94d618310378c48c9f85546f563b.zip
mate-extra/mate-sensors-applet: Adjust nvidia-driver dep per #562910
Now that NVCtrl can be built from source in the nvidia-driver package, nvidia-settings can be deprecated in the near future. This update makes the package ready for that transition. Package-Manager: portage-2.2.26
Diffstat (limited to 'mate-extra')
-rw-r--r--mate-extra/mate-sensors-applet/mate-sensors-applet-1.8.0-r1.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/mate-extra/mate-sensors-applet/mate-sensors-applet-1.8.0-r1.ebuild b/mate-extra/mate-sensors-applet/mate-sensors-applet-1.8.0-r1.ebuild
new file mode 100644
index 00000000000..2e38eef61c1
--- /dev/null
+++ b/mate-extra/mate-sensors-applet/mate-sensors-applet-1.8.0-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 eutils versionator
+
+MATE_BRANCH="$(get_version_component_range 1-2)"
+
+SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz"
+DESCRIPTION="MATE panel applet to display readings from hardware sensors"
+HOMEPAGE="http://mate-desktop.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+dbus hddtemp libnotify lm_sensors video_cards_fglrx video_cards_nvidia"
+
+RDEPEND="app-text/rarian:0
+ >=dev-libs/glib-2.26:2
+ >=mate-base/mate-panel-1.8:0
+ >=x11-libs/cairo-1.0.4:0
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-2.14:2
+ virtual/libintl:0
+ hddtemp? (
+ dbus? (
+ >=dev-libs/dbus-glib-0.80:0
+ >=dev-libs/libatasmart-0.16:0 )
+ !dbus? ( >=app-admin/hddtemp-0.3_beta13:0 ) )
+ libnotify? ( >=x11-libs/libnotify-0.7:0 )
+ lm_sensors? ( sys-apps/lm_sensors:0 )
+ video_cards_fglrx? ( x11-drivers/ati-drivers:* )
+ video_cards_nvidia? ( || (
+ >=x11-drivers/nvidia-drivers-100.14.09:0[static-libs,tools]
+ media-video/nvidia-settings:0
+ ) )"
+
+DEPEND="${RDEPEND}
+ >=app-text/scrollkeeper-dtd-1:1.0
+ app-text/yelp-tools:0
+ dev-util/intltool:*
+ sys-devel/gettext:*
+ virtual/pkgconfig:*"
+
+# Requires libxslt only for use by gnome-doc-utils.
+PDEPEND="hddtemp? ( dbus? ( sys-fs/udisks:0 ) )"
+
+src_configure() {
+ local myconf
+
+ if use hddtemp && use dbus; then
+ myconf="${myconf} $(use_enable dbus udisks)"
+ else
+ myconf="${myconf} --disable-udisks"
+ fi
+
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable libnotify) \
+ $(use_with lm_sensors libsensors) \
+ $(use_with video_cards_fglrx aticonfig) \
+ $(use_with video_cards_nvidia nvidia) \
+ ${myconf}
+}
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"