summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-05-06 02:35:27 +1000
committerMichael Palimaka <kensington@gentoo.org>2016-05-06 02:35:45 +1000
commite5602c28fbad29197c4f485ff7cc0227cc12ad42 (patch)
tree7bc810b4a54b028936383622ffd67d43558821f2 /media-fonts
parentdepend boost has to compile with threads support, thx to T.Foerster on wrt bu... (diff)
downloadgentoo-e5602c28fbad29197c4f485ff7cc0227cc12ad42.tar.gz
gentoo-e5602c28fbad29197c4f485ff7cc0227cc12ad42.tar.bz2
gentoo-e5602c28fbad29197c4f485ff7cc0227cc12ad42.zip
media-fonts/noto: introduce cjk USE flag
The vanilla noto tarball is quite large - approximately 470MB. This can be problematic for users with slow internet connections or have limited storage. Disabling the cjk USE flag causes a much smaller repacked tarball to be used instead, at the cost of support for Chinese, Japanese, and Korean characters. Gentoo-bug: 581344 Package-Manager: portage-2.2.28
Diffstat (limited to 'media-fonts')
-rw-r--r--media-fonts/noto/Manifest1
-rw-r--r--media-fonts/noto/noto-20160305-r1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/media-fonts/noto/Manifest b/media-fonts/noto/Manifest
index 58a0ed598e1a..e4868bb28a68 100644
--- a/media-fonts/noto/Manifest
+++ b/media-fonts/noto/Manifest
@@ -1,3 +1,4 @@
DIST noto-2014.11.zip 381169520 SHA256 6f49663b4a40ed291ff459808a9d1fa6d41f6b3309b79cf7aeaf5fa884040e2c SHA512 36695b99daf870f76d00535513ae0e16170b8d7eb471f75ae016fb970cae236ce6fcf41da790567369dde0bbd87b4c023cac6aa197dd17f8f809d20a4cca3c5b WHIRLPOOL 21977fb0369975ac6ae66c950826478b17f5d5860fd88b2e45f5c016b046e6f17618c1477fb84021348266babecf4c7efa3ca939495cb392bfb4b897466c2218
DIST noto-2015.04.zip 380076754 SHA256 20a467d6664f5bd5d4604e903dd562ba3970dd29b17b09c7b591cb3c293287f6 SHA512 4ed6cb02007d2a96d46a96fba66639cce35019ce0490843d1d1ee3684dca4638227c6b6cb89b49cabe745b523d0e3b48f338555fcbe7168f120107d24d4d2ca7 WHIRLPOOL cc92fceb7e4b260acc936c224cca1cee89d8be3f8dae5b9cbe7426c0787d8ed64aae587f53f46f9fdd327732b7755f04870f69617585f005cb7a3b67434c6452
DIST noto-20160305.zip 494039413 SHA256 a979d9837d4223bcbe55497e3b5c545e0e554a78584f60915f1e620d3fbe508e SHA512 bf20eaf075491d46c7c4d1ea3514f38d0515180879ea4ad0a3a77d72c54cdd4b043e06f4e6852f5f68b1ab2d5f512261ad25ceacdb3e19db2769f0c05c1a795c WHIRLPOOL 75c4bced2caa5990b8688e3c06214ed0dfc1dd85e00607b69c458a39c856835ea7ea9fd6d4f6710945c634991ed41cf3e3c69046e12194c22d73ecd8f46d4fc1
+DIST noto-nocjk-20160305.tar.xz 7818968 SHA256 087c0d920e5ae651ad3671d558de1a11d5832b775f5d4e3e5d287acf9f2866df SHA512 a7c5ef3f74ca8abfd1185cbfba2ddd29c8135162115ef418c41d85813e5823f12d7c78235569ae3288ea8012239052b7cf4cdbe811d014152acd4748bb55c715 WHIRLPOOL bc959cd7acf7f1afb572f6c988f174502291c4b676d5e5c4044c21b2cc61537d0128851d09b6aa6380c4764b37b7d0d9b1958a5a33f70c785d2dd75353261450
diff --git a/media-fonts/noto/noto-20160305-r1.ebuild b/media-fonts/noto/noto-20160305-r1.ebuild
new file mode 100644
index 000000000000..782ec2f16dc2
--- /dev/null
+++ b/media-fonts/noto/noto-20160305-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit font
+
+DESCRIPTION="Google's font family that aims to support all the world's languages"
+HOMEPAGE="https://www.google.com/get/noto/"
+SRC_URI="
+ cjk? ( https://dev.gentoo.org/~pacho/${PN}/${P}.zip )
+ !cjk? ( https://dev.gentoo.org/~kensington/distfiles/${PN}-nocjk-${PV}.tar.xz )
+"
+# renamed from upstream's unversioned Noto-hinted.zip
+# version number based on the timestamp of most recently updated font in the zip
+
+LICENSE="OFL-1.1" # https://github.com/googlei18n/noto-fonts/blob/master/NEWS
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="cjk"
+
+DEPEND="!cjk? ( app-arch/unzip )"
+RESTRICT="binchecks strip"
+
+S=${WORKDIR}
+FONT_S="${S}"
+FONT_SUFFIX="ttf"
+
+src_install() {
+ use cjk && FONT_SUFFIX+=" otf"
+ font_src_install
+}