summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/apng2gif
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/apng2gif')
-rw-r--r--media-gfx/apng2gif/Manifest3
-rw-r--r--media-gfx/apng2gif/apng2gif-1.4.ebuild31
-rw-r--r--media-gfx/apng2gif/apng2gif-1.5.ebuild31
-rw-r--r--media-gfx/apng2gif/apng2gif-1.6.ebuild35
-rw-r--r--media-gfx/apng2gif/files/apng2gif-1.6-gcc-4.3.patch10
-rw-r--r--media-gfx/apng2gif/files/apng2gif-1.6-makefile.patch17
-rw-r--r--media-gfx/apng2gif/metadata.xml8
7 files changed, 135 insertions, 0 deletions
diff --git a/media-gfx/apng2gif/Manifest b/media-gfx/apng2gif/Manifest
new file mode 100644
index 000000000000..8d0b285a7cfa
--- /dev/null
+++ b/media-gfx/apng2gif/Manifest
@@ -0,0 +1,3 @@
+DIST apng2gif-1.4-src.zip 11797 SHA256 be12409304bb268c26c55692822f7aff072315edd6b8120d829264a08e4b2781
+DIST apng2gif-1.5-src.zip 11830 SHA256 024d9f042691216f74d39cec308c447531bd67bee0fab33b32990163559d4978
+DIST apng2gif-1.6-src.zip 455673 SHA256 cd46d7d6de34fed11822ec7f2257b296ec5e45ba1cfa53f70c7974fdae456ffe SHA512 4beeb628f26614b9084ac33eba748559eeb36ee9fb9cf17559973b5c629d898f868a5ae719bff6745ce60dfa99958fd503d2c96bc816f522dbb415383af87462 WHIRLPOOL c969674ea8049c88b8c18c8bd75f8bb6598f61a0e6c84b113b3eba8b4de3a520111a3423c8331969779636aa704c8bcbd96493d3c17b0eeed39c379e080be9eb
diff --git a/media-gfx/apng2gif/apng2gif-1.4.ebuild b/media-gfx/apng2gif/apng2gif-1.4.ebuild
new file mode 100644
index 000000000000..b086df6bb4d6
--- /dev/null
+++ b/media-gfx/apng2gif/apng2gif-1.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="create a GIF from an APNG"
+HOMEPAGE="http://sourceforge.net/projects/apng2gif/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}-src.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDLIBS="-lz" ${PN}
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc readme.txt
+}
diff --git a/media-gfx/apng2gif/apng2gif-1.5.ebuild b/media-gfx/apng2gif/apng2gif-1.5.ebuild
new file mode 100644
index 000000000000..8969f72abb93
--- /dev/null
+++ b/media-gfx/apng2gif/apng2gif-1.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="create a GIF from an APNG"
+HOMEPAGE="http://sourceforge.net/projects/apng2gif/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}-src.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDLIBS="-lz" ${PN}
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc readme.txt
+}
diff --git a/media-gfx/apng2gif/apng2gif-1.6.ebuild b/media-gfx/apng2gif/apng2gif-1.6.ebuild
new file mode 100644
index 000000000000..5f1abf5a1f9b
--- /dev/null
+++ b/media-gfx/apng2gif/apng2gif-1.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="create a GIF from an APNG"
+HOMEPAGE="http://sourceforge.net/projects/apng2gif/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}-src.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/zlib
+ media-libs/libpng:0="
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ epatch "${FILESDIR}"/${P}-gcc-4.3.patch
+
+ tc-export CXX
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc readme.txt
+}
diff --git a/media-gfx/apng2gif/files/apng2gif-1.6-gcc-4.3.patch b/media-gfx/apng2gif/files/apng2gif-1.6-gcc-4.3.patch
new file mode 100644
index 000000000000..b3d32647b19b
--- /dev/null
+++ b/media-gfx/apng2gif/files/apng2gif-1.6-gcc-4.3.patch
@@ -0,0 +1,10 @@
+--- apng2gif-1.6-src/apng2gif.cpp
++++ apng2gif-1.6-src/apng2gif.cpp
+@@ -30,6 +30,7 @@
+ */
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <cstring>
+ #include <vector>
+ #include "png.h" /* original (unpatched) libpng is ok */
+ #include "zlib.h"
diff --git a/media-gfx/apng2gif/files/apng2gif-1.6-makefile.patch b/media-gfx/apng2gif/files/apng2gif-1.6-makefile.patch
new file mode 100644
index 000000000000..c004a3c5c0c4
--- /dev/null
+++ b/media-gfx/apng2gif/files/apng2gif-1.6-makefile.patch
@@ -0,0 +1,17 @@
+--- apng2gif-1.6-src/Makefile
++++ apng2gif-1.6-src/Makefile
+@@ -1,11 +1,10 @@
+ PACKAGE = apng2gif
+-CC = gcc
+-CFLAGS = -Wall -pedantic
+-CFLAGS_OPT = -O2
++CXX ?= g++
++CFLAGS += -Wall -pedantic
+ LIBS = -lstdc++ -lm -lpng -lz
+
+ all :
+- $(CC) $(CFLAGS) $(CFLAGS_OPT) -o apng2gif apng2gif.cpp -s $(LIBS)
++ $(CXX) $(CFLAGS) $(LDFLAGS) -o apng2gif apng2gif.cpp $(LIBS)
+
+ .PHONY : clean
+
diff --git a/media-gfx/apng2gif/metadata.xml b/media-gfx/apng2gif/metadata.xml
new file mode 100644
index 000000000000..cf8762004522
--- /dev/null
+++ b/media-gfx/apng2gif/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>graphics</herd>
+ <upstream>
+ <remote-id type="sourceforge">apng2gif</remote-id>
+ </upstream>
+</pkgmetadata>