summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/cropgui
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/cropgui')
-rw-r--r--media-gfx/cropgui/Manifest1
-rw-r--r--media-gfx/cropgui/cropgui-0.1.1-r3.ebuild53
-rw-r--r--media-gfx/cropgui/files/cropgui-0.1.1-PIL.patch29
-rw-r--r--media-gfx/cropgui/metadata.xml12
4 files changed, 95 insertions, 0 deletions
diff --git a/media-gfx/cropgui/Manifest b/media-gfx/cropgui/Manifest
new file mode 100644
index 000000000000..168914950916
--- /dev/null
+++ b/media-gfx/cropgui/Manifest
@@ -0,0 +1 @@
+DIST cropgui_0.1.1.tar.gz 13142 SHA256 d2bab11c2bafdbcbe9c8cac7827a7e25b909b2962cef29e1ce7181ccb2834a75 SHA512 abfe8dfd46a316e970b0355f6b05e2d2a4a54243e201dfc8434ee09f31c8715471dd1f00bd0c6cda646406e6398e5b43da3269bf74d1f2d9d436d5931d2b968f WHIRLPOOL 1e4f9fca887d2d988c6d944f85cae6125472ea08118e84b5601123e2af603b16d49ed54385f9552f1cd819f447b2ceace742ee4fd1e95f5d0461f4c173a1ef7e
diff --git a/media-gfx/cropgui/cropgui-0.1.1-r3.ebuild b/media-gfx/cropgui/cropgui-0.1.1-r3.ebuild
new file mode 100644
index 000000000000..40548f2b2b92
--- /dev/null
+++ b/media-gfx/cropgui/cropgui-0.1.1-r3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+inherit eutils python-r1
+
+DESCRIPTION="GUI for lossless cropping of jpeg images"
+HOMEPAGE="http://emergent.unpythonic.net/01248401946"
+SRC_URI="http://media.unpythonic.net/emergent-files/01248401946/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${PYTHON_DEPS}
+ virtual/python-imaging[${PYTHON_USEDEP}]
+ dev-python/pygobject:2[${PYTHON_USEDEP}]
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ sed -i -e '/Encoding/d' \
+ -e '/Version/d' \
+ -e '/MimeType/s/$/&;/' \
+ -e '/Categories/s/Application;//' \
+ cropgui.desktop || die 'sed on cropgui.desktop failed'
+ # bug 471530
+ epatch "${FILESDIR}/${P}-PIL.patch"
+
+ epatch_user
+}
+
+install_cropgui_wrapper() {
+ python_domodule cropgtk.py cropgui_common.py filechooser.py cropgui.glade
+ make_wrapper "${PN}.tmp" "${PYTHON} $(python_get_sitedir)/${PN}/cropgtk.py"
+ python_newexe "${ED%/}/usr/bin/${PN}.tmp" "${PN}"
+ rm "${ED%/}/usr/bin/${PN}.tmp" || die
+}
+
+src_install() {
+ local python_moduleroot="${PN}"
+ python_foreach_impl install_cropgui_wrapper
+
+ domenu "${PN}.desktop"
+ doicon "${PN}.png"
+}
diff --git a/media-gfx/cropgui/files/cropgui-0.1.1-PIL.patch b/media-gfx/cropgui/files/cropgui-0.1.1-PIL.patch
new file mode 100644
index 000000000000..88f7ffbfed81
--- /dev/null
+++ b/media-gfx/cropgui/files/cropgui-0.1.1-PIL.patch
@@ -0,0 +1,29 @@
+Только в cropgui: cropgui-0.1.1-PIL.patch
+diff -ru cropgui.orig/cropgui_common.py cropgui/cropgui_common.py
+--- cropgui.orig/cropgui_common.py 2009-07-24 06:15:12.000000000 +0400
++++ cropgui/cropgui_common.py 2013-05-28 21:48:24.000000000 +0400
+@@ -13,9 +13,9 @@
+ # You should have received a copy of the GNU General Public License
+ # along with this program; if not, write to the Free Software
+ # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+-import Image
+-import ImageFilter
+-import ImageDraw
++from PIL import Image
++from PIL import ImageFilter
++from PIL import ImageDraw
+ import subprocess
+ import threading
+ import Queue
+diff -ru cropgui.orig/filechooser.py cropgui/filechooser.py
+--- cropgui.orig/filechooser.py 2009-07-24 06:15:12.000000000 +0400
++++ cropgui/filechooser.py 2013-05-28 21:50:16.000000000 +0400
+@@ -8,7 +8,7 @@
+ import gobject
+
+ import os
+-import Image
++from PIL import Image
+
+ HIGH_WATER, LOW_WATER = 25, 5
+ image_cache = {}
diff --git a/media-gfx/cropgui/metadata.xml b/media-gfx/cropgui/metadata.xml
new file mode 100644
index 000000000000..1b9fb5b7d4b0
--- /dev/null
+++ b/media-gfx/cropgui/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>zlogene@gentoo.org</email>
+ <name>Mikle Kolyada</name>
+ </maintainer>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+</pkgmetadata>