summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/pinta
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/pinta')
-rw-r--r--media-gfx/pinta/Manifest2
-rw-r--r--media-gfx/pinta/metadata.xml20
-rw-r--r--media-gfx/pinta/pinta-1.4.ebuild42
-rw-r--r--media-gfx/pinta/pinta-1.5_pre20121118.ebuild59
-rw-r--r--media-gfx/pinta/pinta-9999.ebuild58
5 files changed, 181 insertions, 0 deletions
diff --git a/media-gfx/pinta/Manifest b/media-gfx/pinta/Manifest
new file mode 100644
index 000000000000..6f0b8a918b8b
--- /dev/null
+++ b/media-gfx/pinta/Manifest
@@ -0,0 +1,2 @@
+DIST pinta-1.4.tar.gz 1230765 SHA256 fde40f78560aab5a891bf499396db099b86bbd365c1eb81df480b35b4d37d8bb SHA512 7a1abd62a10569aa572ab956a860d1813104e4cc35c800798d78085ff2c66f4bf0583f8270d279d1342959c86cdc9383b93e004e1ee8e96cfc99de45bc9fe79f WHIRLPOOL 71101a513748d8cdd0a46ab2c115b1719cb987d5efc6c1ceb24e4a8a0b12e898218209f310887564279065ac8c69a6e349799c7300f1f0bc2a53e8e15ba9d401
+DIST pinta-1.5-preview-20121118.tar.gz 2373151 SHA256 b7ee93a171d24a37237e5d975a2756bd566b5f2c7e5666e591cf42b1aa278c4d SHA512 a954a7556e7e852e3d7bb6eb6dfcf207ed5b22a42d7f278c38815be2d6feacfd006e945f675d86ca923c4cddbf4b2e39e85e1b24bb7d84be6d87397c1e29a604 WHIRLPOOL fa848ef794fb7c5a90fac2d7a6ad3d5e4fe4f3c1d4ca38fcbabbdedc481058fc90836e8e777f8bc76faec0a864dd86834784ed846838f390bf598be8b659348d
diff --git a/media-gfx/pinta/metadata.xml b/media-gfx/pinta/metadata.xml
new file mode 100644
index 000000000000..dcd2a7bc5583
--- /dev/null
+++ b/media-gfx/pinta/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <maintainer status="active">
+ <email>cameronwhite91@gmail.com</email>
+ </maintainer>
+ <changelog>https://github.com/PintaProject/Pinta/commits/1.3</changelog>
+ <doc lang="en">http://pinta-project.com/HowTo.ashx</doc>
+ <bugs-to>https://bugs.launchpad.net/pinta/+filebug</bugs-to>
+ </upstream>
+ <longdescription lang="en">
+ Pinta is a free, open source drawing/editing program modeled after
+ Paint.NET. Its goal is to provide users with a simple yet powerful
+ way to draw and manipulate images on Linux, Mac, and Windows.
+ </longdescription>
+</pkgmetadata>
diff --git a/media-gfx/pinta/pinta-1.4.ebuild b/media-gfx/pinta/pinta-1.4.ebuild
new file mode 100644
index 000000000000..2f27e1e0a1d2
--- /dev/null
+++ b/media-gfx/pinta/pinta-1.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit fdo-mime mono
+
+DESCRIPTION="Simple Painting for Gtk"
+HOMEPAGE="http://pinta-project.com"
+SRC_URI="mirror://github/PintaProject/Pinta/${P}.tar.gz"
+
+LICENSE="MIT CC-BY-3.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+COMMON_DEPEND="dev-dotnet/atk-sharp:2
+ dev-dotnet/gdk-sharp:2
+ dev-dotnet/glib-sharp:2
+ dev-dotnet/gtk-sharp:2
+ dev-dotnet/mono-addins[gtk]
+ dev-dotnet/pango-sharp:2
+ dev-lang/mono"
+RDEPEND="${COMMON_DEPEND}
+ x11-libs/cairo[X]
+ x11-libs/gdk-pixbuf[X,jpeg,tiff]
+ x11-themes/gnome-icon-theme"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
diff --git a/media-gfx/pinta/pinta-1.5_pre20121118.ebuild b/media-gfx/pinta/pinta-1.5_pre20121118.ebuild
new file mode 100644
index 000000000000..d29ee1c69497
--- /dev/null
+++ b/media-gfx/pinta/pinta-1.5_pre20121118.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit fdo-mime gnome2-utils mono
+
+DESCRIPTION="Simple Painting for Gtk"
+HOMEPAGE="http://pinta-project.com"
+SRC_URI="mirror://github/PintaProject/Pinta/${P/_pre/-preview-}.tar.gz"
+
+LICENSE="MIT CC-BY-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPEND="dev-dotnet/atk-sharp:2
+ dev-dotnet/gdk-sharp:2
+ dev-dotnet/glib-sharp:2
+ dev-dotnet/gtk-sharp:2
+ dev-dotnet/mono-addins[gtk]
+ dev-dotnet/pango-sharp:2
+ dev-lang/mono"
+RDEPEND="${COMMON_DEPEND}
+ x11-libs/cairo[X]
+ x11-libs/gdk-pixbuf[X,jpeg,tiff]
+ x11-themes/gnome-icon-theme"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${P%_pre*}
+
+src_prepare() {
+ local i
+ if [[ -n "${LINGUAS+x}" ]] ; then
+ for i in $(cd "${S}"/po ; echo *.po) ; do
+ if ! has ${i%.po} ${LINGUAS} ; then
+ sed -i -e "/po\/${i%.po}.po/{N;N;d;}" Pinta.Install.proj || die
+ fi
+ done
+ fi
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
diff --git a/media-gfx/pinta/pinta-9999.ebuild b/media-gfx/pinta/pinta-9999.ebuild
new file mode 100644
index 000000000000..d95905d276f0
--- /dev/null
+++ b/media-gfx/pinta/pinta-9999.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools fdo-mime gnome2-utils git-2 mono
+
+DESCRIPTION="Simple Painting for Gtk"
+HOMEPAGE="http://pinta-project.com"
+EGIT_REPO_URI="git://github.com/PintaProject/Pinta.git"
+
+LICENSE="MIT CC-BY-3.0"
+SLOT="0"
+KEYWORDS=""
+
+COMMON_DEPEND="dev-dotnet/atk-sharp:2
+ dev-dotnet/gdk-sharp:2
+ dev-dotnet/glib-sharp:2
+ dev-dotnet/gtk-sharp:2
+ dev-dotnet/mono-addins[gtk]
+ dev-dotnet/pango-sharp:2
+ dev-lang/mono"
+RDEPEND="${COMMON_DEPEND}
+ x11-libs/cairo[X]
+ x11-libs/gdk-pixbuf[X,jpeg,tiff]
+ x11-themes/gnome-icon-theme"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+src_prepare() {
+ local i
+ if [[ -n "${LINGUAS+x}" ]] ; then
+ for i in $(cd "${S}"/po ; echo *.po) ; do
+ if ! has ${i%.po} ${LINGUAS} ; then
+ sed -i -e "/po\/${i%.po}.po/{N;N;d;}" Pinta.Install.proj || die
+ fi
+ done
+ fi
+ eautoreconf
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}