summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-12-29 14:30:34 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-12-29 14:31:44 +0100
commit450cbf95fae0141740b2c9f74265220651ee8863 (patch)
tree5b81eb8cc52aa768ca4948d0e28e56cb66fed891 /media-gfx
parentmedia-libs/gexiv2: Really fix build with exiv2-0.27 (diff)
downloadgentoo-450cbf95fae0141740b2c9f74265220651ee8863.tar.gz
gentoo-450cbf95fae0141740b2c9f74265220651ee8863.tar.bz2
gentoo-450cbf95fae0141740b2c9f74265220651ee8863.zip
media-gfx/hugin: Fix build with exiv2-0.27
Switch to eapi7-ver Sync 9999 deps with 2018.0.0 Closes: https://bugs.gentoo.org/673730 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/hugin/files/hugin-2018.0.0-exiv2-0.27.patch28
-rw-r--r--media-gfx/hugin/hugin-2018.0.0.ebuild8
-rw-r--r--media-gfx/hugin/hugin-9999.ebuild7
3 files changed, 37 insertions, 6 deletions
diff --git a/media-gfx/hugin/files/hugin-2018.0.0-exiv2-0.27.patch b/media-gfx/hugin/files/hugin-2018.0.0-exiv2-0.27.patch
new file mode 100644
index 00000000000..23dd5428921
--- /dev/null
+++ b/media-gfx/hugin/files/hugin-2018.0.0-exiv2-0.27.patch
@@ -0,0 +1,28 @@
+--- a/src/hugin_base/panodata/Exiv2Helper.cpp
++++ b/src/hugin_base/panodata/Exiv2Helper.cpp
+@@ -29,6 +29,7 @@
+ #include "hugin_math/hugin_math.h"
+ #include "hugin_utils/utils.h"
+ #include "exiv2/easyaccess.hpp"
++#include "exiv2/version.hpp"
+
+ namespace HuginBase
+ {
+@@ -232,7 +233,7 @@
+ return false;
+ };
+ };
+-#if EXIV2_TEST_VERSION(0,23,0)
++#if defined EXIV2_VERSION && EXIV2_VERSION >= EXIV2_MAKE_VERSION(0,23,0)
+ if (_getExiv2Value(exifData, "Exif.PentaxDng.RedBalance", val1) &&
+ _getExiv2Value(exifData, "Exif.PentaxDng.BlueBalance", val2))
+ {
+@@ -563,7 +564,7 @@
+ std::string lensName;
+ // first we are reading LensModel in Exif section, this is only available
+ // with EXIF >= 2.3
+-#if EXIV2_TEST_VERSION(0,22,0)
++#if defined EXIV2_VERSION && EXIV2_VERSION >= EXIV2_MAKE_VERSION(0,22,0)
+ //the string "Exif.Photo.LensModel" is only defined in exiv2 0.22.0 and above
+ if(_getExiv2Value(exifData, "Exif.Photo.LensModel", lensName))
+ #else
diff --git a/media-gfx/hugin/hugin-2018.0.0.ebuild b/media-gfx/hugin/hugin-2018.0.0.ebuild
index 3b5e82f438d..cb72199b0eb 100644
--- a/media-gfx/hugin/hugin-2018.0.0.ebuild
+++ b/media-gfx/hugin/hugin-2018.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -6,7 +6,7 @@ EAPI=6
WX_GTK_VER="3.0"
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-inherit python-single-r1 wxwidgets versionator cmake-utils
+inherit python-single-r1 wxwidgets cmake-utils eapi7-ver
DESCRIPTION="GUI for the creation & processing of panoramic images"
HOMEPAGE="http://hugin.sf.net"
@@ -55,7 +55,9 @@ REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
DOCS=( authors.txt README TODO )
-S=${WORKDIR}/${PN}-$(get_version_component_range 1-2).0
+PATCHES=( "${FILESDIR}/${P}-exiv2-0.27.patch" )
+
+S=${WORKDIR}/${PN}-$(ver_cut 1-2).0
pkg_setup() {
use python && python-single-r1_pkg_setup
diff --git a/media-gfx/hugin/hugin-9999.ebuild b/media-gfx/hugin/hugin-9999.ebuild
index 8615f1c5a0b..c46a552195e 100644
--- a/media-gfx/hugin/hugin-9999.ebuild
+++ b/media-gfx/hugin/hugin-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -6,7 +6,7 @@ EAPI=6
WX_GTK_VER="3.0"
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-inherit mercurial python-single-r1 wxwidgets versionator cmake-utils
+inherit mercurial python-single-r1 wxwidgets cmake-utils eapi7-ver
DESCRIPTION="GUI for the creation & processing of panoramic images"
HOMEPAGE="http://hugin.sf.net"
@@ -36,6 +36,7 @@ CDEPEND="
media-libs/tiff:0
>=media-libs/vigra-1.11.0[openexr]
sci-libs/fftw:3.0=
+ sci-libs/flann
sys-libs/zlib
virtual/glu
virtual/jpeg:0
@@ -56,7 +57,7 @@ REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
DOCS=( authors.txt README TODO )
-S=${WORKDIR}/${PN}-$(get_version_component_range 1-3)
+S=${WORKDIR}/${PN}-$(ver_cut 1-2).0
pkg_setup() {
use python && python-single-r1_pkg_setup