summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-10-25 16:06:34 +0100
committerPacho Ramos <pacho@gentoo.org>2015-10-25 16:06:58 +0100
commitebb2e705108a6c3b1543e3e983b2b60714f3add5 (patch)
tree9a2786b43d9d11819d410a091da6d293863cd716 /media-gfx
parentmedia-sound/guayadeque: Import debian patchset for wxgtk-3.0 support (diff)
downloadgentoo-ebb2e705108a6c3b1543e3e983b2b60714f3add5.tar.gz
gentoo-ebb2e705108a6c3b1543e3e983b2b60714f3add5.tar.bz2
gentoo-ebb2e705108a6c3b1543e3e983b2b60714f3add5.zip
media-gfx/fontypython: Support wxGTK:3.0
Package-Manager: portage-2.2.23
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/fontypython/files/0001-Do-not-crash-on-empty-pogs-list.patch21
-rw-r--r--media-gfx/fontypython/files/0002-Removed-unused-code-which-causes-crash-with-wx-3.0.patch134
-rw-r--r--media-gfx/fontypython/files/0003-Adapt-to-wxpython-3.0-which-enforces-assertions-on-L.patch28
-rw-r--r--media-gfx/fontypython/fontypython-0.4.4-r3.ebuild39
4 files changed, 222 insertions, 0 deletions
diff --git a/media-gfx/fontypython/files/0001-Do-not-crash-on-empty-pogs-list.patch b/media-gfx/fontypython/files/0001-Do-not-crash-on-empty-pogs-list.patch
new file mode 100644
index 00000000000..b652053596c
--- /dev/null
+++ b/media-gfx/fontypython/files/0001-Do-not-crash-on-empty-pogs-list.patch
@@ -0,0 +1,21 @@
+From: Pietro Battiston <me@pietrobattiston.it>
+Date: Sun, 21 Dec 2014 11:50:28 +0100
+Subject: Do not crash on empty pogs list
+
+---
+ fontypythonmodules/gui_PogChooser.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/fontypythonmodules/gui_PogChooser.py b/fontypythonmodules/gui_PogChooser.py
+index 94b7f2e..f233529 100644
+--- a/fontypythonmodules/gui_PogChooser.py
++++ b/fontypythonmodules/gui_PogChooser.py
+@@ -80,7 +80,7 @@ class PogChooser(wx.ListCtrl) :
+ i = self.FindItem(-1, select)
+ self.indexselected = i # Set this to help initial icon settings.
+ self.Select(i, True)
+- else:
++ elif self.__poglistCopy:
+ self.Select(0, False)
+ self.indexselected = -1
+
diff --git a/media-gfx/fontypython/files/0002-Removed-unused-code-which-causes-crash-with-wx-3.0.patch b/media-gfx/fontypython/files/0002-Removed-unused-code-which-causes-crash-with-wx-3.0.patch
new file mode 100644
index 00000000000..e6f8fb634e8
--- /dev/null
+++ b/media-gfx/fontypython/files/0002-Removed-unused-code-which-causes-crash-with-wx-3.0.patch
@@ -0,0 +1,134 @@
+From: Pietro Battiston <me@pietrobattiston.it>
+Date: Sun, 21 Dec 2014 09:14:19 +0100
+Subject: Removed unused code which causes crash with wx 3.0
+
+---
+ fontypython | 2 --
+ fontypythonmodules/dialogues.py | 4 ----
+ fontypythonmodules/gui_Left.py | 4 ----
+ fontypythonmodules/gui_Middle.py | 5 -----
+ fontypythonmodules/gui_PogChooser.py | 4 ----
+ fontypythonmodules/gui_Right.py | 4 ----
+ fontypythonmodules/gui_ScrolledFontView.py | 4 ----
+ fontypythonmodules/wxgui.py | 4 ----
+ 8 files changed, 31 deletions(-)
+
+diff --git a/fontypython b/fontypython
+index a05290f..e46e34e 100755
+--- a/fontypython
++++ b/fontypython
+@@ -72,8 +72,6 @@ else: # err code -11
+
+ ## Setup wxPython to access translations : enables the stock buttons.
+ localedir = "fontypythonmodules/locales"
+- langid = wx.LANGUAGE_DEFAULT
+- mylocale = wx.Locale( langid )
+
+ iPC = PC.PathControl()
+
+diff --git a/fontypythonmodules/dialogues.py b/fontypythonmodules/dialogues.py
+index 1fbff5f..eba7ab3 100644
+--- a/fontypythonmodules/dialogues.py
++++ b/fontypythonmodules/dialogues.py
+@@ -23,10 +23,6 @@ import wx
+ import wx.html as html
+
+
+-## Setup wxPython to access translations : enables the stock buttons.
+-langid = wx.LANGUAGE_DEFAULT # Picks this up from $LANG
+-mylocale = wx.Locale( langid )
+-
+ ## langcode = locale.getlocale()[0] # I must not use getlocale...
+ ## This is suggested by Martin:
+ loc = locale.setlocale(locale.LC_CTYPE) # use *one* of the categories (not LC_ALL)
+diff --git a/fontypythonmodules/gui_Left.py b/fontypythonmodules/gui_Left.py
+index 5451f39..7b1f0c6 100644
+--- a/fontypythonmodules/gui_Left.py
++++ b/fontypythonmodules/gui_Left.py
+@@ -17,10 +17,6 @@
+
+ import wx, os
+
+-## Setup wxPython to access translations : enables the stock buttons.
+-langid = wx.LANGUAGE_DEFAULT # Picks this up from $LANG
+-mylocale = wx.Locale( langid )
+-
+
+ from pubsub import *
+ from wxgui import ps
+diff --git a/fontypythonmodules/gui_Middle.py b/fontypythonmodules/gui_Middle.py
+index 470e3ea..9af3f9f 100644
+--- a/fontypythonmodules/gui_Middle.py
++++ b/fontypythonmodules/gui_Middle.py
+@@ -19,11 +19,6 @@ import wx
+ import wx.lib.stattext
+ import wx.lib.buttons as buttons
+
+-## Setup wxPython to access translations : enables the stock buttons.
+-langid = wx.LANGUAGE_DEFAULT # Picks this up from $LANG
+-mylocale = wx.Locale( langid )
+-
+-
+ from pubsub import *
+ from wxgui import ps
+
+diff --git a/fontypythonmodules/gui_PogChooser.py b/fontypythonmodules/gui_PogChooser.py
+index f233529..c679191 100644
+--- a/fontypythonmodules/gui_PogChooser.py
++++ b/fontypythonmodules/gui_PogChooser.py
+@@ -17,10 +17,6 @@
+
+ import wx, locale
+
+-## Setup wxPython to access translations : enables the stock buttons.
+-langid = wx.LANGUAGE_DEFAULT # Picks this up from $LANG
+-mylocale = wx.Locale( langid )
+-
+ from pubsub import *
+ from wxgui import ps
+
+diff --git a/fontypythonmodules/gui_Right.py b/fontypythonmodules/gui_Right.py
+index adefa1d..ea5062b 100644
+--- a/fontypythonmodules/gui_Right.py
++++ b/fontypythonmodules/gui_Right.py
+@@ -17,10 +17,6 @@
+
+ import wx
+
+-## Setup wxPython to access translations : enables the stock buttons.
+-langid = wx.LANGUAGE_DEFAULT # Picks this up from $LANG
+-mylocale = wx.Locale( langid )
+-
+ from pubsub import *
+ from wxgui import ps
+
+diff --git a/fontypythonmodules/gui_ScrolledFontView.py b/fontypythonmodules/gui_ScrolledFontView.py
+index d7b3d2f..3e35d62 100644
+--- a/fontypythonmodules/gui_ScrolledFontView.py
++++ b/fontypythonmodules/gui_ScrolledFontView.py
+@@ -20,10 +20,6 @@ import wx.lib.scrolledpanel
+
+ from pubsub import *
+
+-## Setup wxPython to access translations : enables the stock buttons.
+-langid = wx.LANGUAGE_DEFAULT # Picks this up from $LANG
+-mylocale = wx.Locale( langid )
+-
+ import fpsys # Global objects
+
+ from gui_Fitmap import * #Also brings in 'ps' variable
+diff --git a/fontypythonmodules/wxgui.py b/fontypythonmodules/wxgui.py
+index da80d17..6e6716a 100644
+--- a/fontypythonmodules/wxgui.py
++++ b/fontypythonmodules/wxgui.py
+@@ -23,10 +23,6 @@ import fpversion
+ ## Now, bring in all those big modules
+ import wx
+
+-## Setup wxPython to access translations : enables the stock buttons.
+-langid = wx.LANGUAGE_DEFAULT # Picks this up from $LANG
+-mylocale = wx.Locale( langid )
+-
+ ## Fetch my own pubsub stuff
+ from pubsub import *
+ ps = CPubsub()
diff --git a/media-gfx/fontypython/files/0003-Adapt-to-wxpython-3.0-which-enforces-assertions-on-L.patch b/media-gfx/fontypython/files/0003-Adapt-to-wxpython-3.0-which-enforces-assertions-on-L.patch
new file mode 100644
index 00000000000..4875a15ff05
--- /dev/null
+++ b/media-gfx/fontypython/files/0003-Adapt-to-wxpython-3.0-which-enforces-assertions-on-L.patch
@@ -0,0 +1,28 @@
+From: Pietro Battiston <me@pietrobattiston.it>
+Date: Sun, 21 Dec 2014 11:50:09 +0100
+Subject: Adapt to wxpython 3.0, which enforces assertions on ListItems ids.
+
+---
+ fontypythonmodules/gui_PogChooser.py | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/fontypythonmodules/gui_PogChooser.py b/fontypythonmodules/gui_PogChooser.py
+index c679191..4cdf772 100644
+--- a/fontypythonmodules/gui_PogChooser.py
++++ b/fontypythonmodules/gui_PogChooser.py
+@@ -200,6 +200,7 @@ class PogChooser(wx.ListCtrl) :
+ li.SetImage(i)
+ li.SetText(p)
+ id = wx.NewId()
++ li.SetId(id)
+ PogChooser.__poglistCopy[id] = p # record the pog name
+ row = self.InsertItem( li )
+ self.SetItemData( row, id ) # associate back to __poglistCopy
+@@ -214,6 +215,7 @@ class PogChooser(wx.ListCtrl) :
+ li.SetImage(0)
+ li.SetText(pogname)
+ id = wx.NewId()
++ li.SetId(id)
+ self.__poglistCopy[id] = pogname
+ row = self.InsertItem(li)
+ self.SetItemData( row, id )
diff --git a/media-gfx/fontypython/fontypython-0.4.4-r3.ebuild b/media-gfx/fontypython/fontypython-0.4.4-r3.ebuild
new file mode 100644
index 00000000000..7a002b894c3
--- /dev/null
+++ b/media-gfx/fontypython/fontypython-0.4.4-r3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+WX_GTK_VER=3.0
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 multilib wxwidgets
+
+DESCRIPTION="Font preview application"
+HOMEPAGE="http://savannah.nongnu.org/projects/fontypython"
+SRC_URI="http://download.savannah.nongnu.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Crashes w/ debug build of wxGTK (#201315)
+DEPEND="dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/wxpython:${WX_GTK_VER}[${PYTHON_USEDEP}]
+ x11-libs/wxGTK:${WX_GTK_VER}[-debug]"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-pillow.patch"
+ "${FILESDIR}"/0001-Do-not-crash-on-empty-pogs-list.patch
+ "${FILESDIR}"/0002-Removed-unused-code-which-causes-crash-with-wx-3.0.patch
+ "${FILESDIR}"/0003-Adapt-to-wxpython-3.0-which-enforces-assertions-on-L.patch )
+
+src_prepare() {
+ distutils-r1_src_prepare
+ need-wxwidgets unicode
+}
+
+src_install() {
+ distutils-r1_src_install
+ doman "${S}"/fontypython.1
+}