summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-10-17 10:45:16 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-10-17 11:22:35 +0200
commit44f42e93089dc611dadf64c2d6ad7290baa04faa (patch)
tree83b11d1d0e2500cac082f18f83f5033b9764e522 /media-libs/alsa-lib
parentmedia-plugins/gst-plugins-chromaprint-1.14.1-r0: add ~alpha keyword (diff)
downloadgentoo-44f42e93089dc611dadf64c2d6ad7290baa04faa.tar.gz
gentoo-44f42e93089dc611dadf64c2d6ad7290baa04faa.tar.bz2
gentoo-44f42e93089dc611dadf64c2d6ad7290baa04faa.zip
media-libs/alsa-lib: Bump to version 1.1.7
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'media-libs/alsa-lib')
-rw-r--r--media-libs/alsa-lib/Manifest1
-rw-r--r--media-libs/alsa-lib/alsa-lib-1.1.7.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/media-libs/alsa-lib/Manifest b/media-libs/alsa-lib/Manifest
index 35c4fa382680..3eddc7c41cd7 100644
--- a/media-libs/alsa-lib/Manifest
+++ b/media-libs/alsa-lib/Manifest
@@ -2,3 +2,4 @@ DIST alsa-lib-1.1.2.tar.bz2 947423 BLAKE2B 09cd6a625d8f681c5515fd925191fb5468158
DIST alsa-lib-1.1.4.1.tar.bz2 974584 BLAKE2B f3221fa55dc11c04f4a1bc3ee90d2a679ca9b8bde65e2801ae5762fa456ef8e45532624efa57bf7d62f82e5c172eaf10f2286f9acace5a47e20123acf5ce04d2 SHA512 7b548c4ee29c4a1230a0edcd5d19219831290f96a214180a6530628acc05278d1348376195287d188f4f44d6be1914391c63994f1b50985c3eee74352da26b0b
DIST alsa-lib-1.1.5.tar.bz2 979225 BLAKE2B 75683b17bfd51c1e54f1a460ed32a170b07eb227bd6b9ee481d123116464f5c16bbb49f29dfc8d08baaf2f69c5333bf71b70c33b5d420c43e56ae4ace76a6ab0 SHA512 c79ceaa1ebfeda2caf41a0495ea31dd2748a11795989aebc341ae13a5c96d21495e4542571d5590e68b2575ceddd6e84059a950ddb78e6c0b9d94861faee4f58
DIST alsa-lib-1.1.6.tar.bz2 989316 BLAKE2B 2aec62d262148571cc1b93ac8053002b61266951caf8b2855fc65b699ec928672748a21ba11a25e14e752a4a85f68b2f77b5ad6af9b2f1fc5e9de41313ace54a SHA512 00117769a3d5c609019b975188d6e7a07d035bd0461f54c5f291e14667620506f1adb6d61350f78d54648850f31965aae3ab0e697bf9e09c988e2d15bf6b09f0
+DIST alsa-lib-1.1.7.tar.bz2 1005257 BLAKE2B 0ee0eb9db057421d75436bbed49e0a0ef560700d480a5dc73bc0e9e6abaa29892dc4e4482c671996fbc9f6bb5f70ba645010bd714f30959fef897e3dc906980f SHA512 7cc81464d876a137e9ac9700420bfff7cd528338bdc6e0bdbe313d45c5b97c81f1a9483df0556fe390d54a9db747fbec62e843b42d2cbc740d5a91b015714f6c
diff --git a/media-libs/alsa-lib/alsa-lib-1.1.7.ebuild b/media-libs/alsa-lib/alsa-lib-1.1.7.ebuild
new file mode 100644
index 000000000000..69bf71d7b425
--- /dev/null
+++ b/media-libs/alsa-lib/alsa-lib-1.1.7.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} )
+
+inherit autotools multilib multilib-minimal python-single-r1
+
+DESCRIPTION="Advanced Linux Sound Architecture Library"
+HOMEPAGE="https://alsa-project.org/"
+SRC_URI="mirror://alsaproject/lib/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="alisp debug doc elibc_uclibc python +thread-safety"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ doc? ( >=app-doc/doxygen-1.2.6 )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.1.6-missing_files.patch" #652422
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ find . -name Makefile.am -exec sed -i -e '/CFLAGS/s:-g -O2::' {} + || die
+ # https://bugs.gentoo.org/509886
+ use elibc_uclibc && { sed -i -e 's:oldapi queue_timer:queue_timer:' test/Makefile.am || die; }
+ # https://bugs.gentoo.org/545950
+ sed -i -e '5s:^$:\nAM_CPPFLAGS = -I$(top_srcdir)/include:' test/lsb/Makefile.am || die
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --disable-maintainer-mode
+ --disable-resmgr
+ --enable-aload
+ --enable-rawmidi
+ --enable-seq
+ --enable-shared
+ # enable Python only on final ABI
+ $(multilib_native_use_enable python)
+ $(use_enable alisp)
+ $(use_enable thread-safety)
+ $(use_with debug)
+ $(usex elibc_uclibc --without-versioned '')
+ )
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_compile() {
+ emake
+
+ if multilib_is_native_abi && use doc; then
+ emake doc
+ grep -FZrl "${S}" doc/doxygen/html | \
+ xargs -0 sed -i -e "s:${S}::"
+ fi
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+ if multilib_is_native_abi && use doc; then
+ docinto html
+ dodoc -r doc/doxygen/html/.
+ fi
+}
+
+multilib_src_install_all() {
+ find "${ED}" \( -name '*.a' -o -name '*.la' \) -delete || die
+ dodoc ChangeLog doc/asoundrc.txt NOTES TODO
+}