summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-02-28 12:05:07 +0100
committerPacho Ramos <pacho@gentoo.org>2016-02-28 12:08:54 +0100
commit03893ace3ba1704ec4e0757fa4b1d48ae47ea58a (patch)
treef6d08f609a47a4c04111b0fe290a0fd9b9805570 /media-libs/gexiv2
parentmedia-libs/gexiv2: Drop old (diff)
downloadgentoo-03893ace3ba1704ec4e0757fa4b1d48ae47ea58a.tar.gz
gentoo-03893ace3ba1704ec4e0757fa4b1d48ae47ea58a.tar.bz2
gentoo-03893ace3ba1704ec4e0757fa4b1d48ae47ea58a.zip
media-libs/gexiv2: Support python3_5
Package-Manager: portage-2.2.27
Diffstat (limited to 'media-libs/gexiv2')
-rw-r--r--media-libs/gexiv2/gexiv2-0.10.3.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/media-libs/gexiv2/gexiv2-0.10.3.ebuild b/media-libs/gexiv2/gexiv2-0.10.3.ebuild
index 4689ead08970..574db71c79e4 100644
--- a/media-libs/gexiv2/gexiv2-0.10.3.ebuild
+++ b/media-libs/gexiv2/gexiv2-0.10.3.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
inherit eutils multilib python-r1 toolchain-funcs versionator xdg-utils
@@ -24,16 +24,16 @@ REQUIRED_USE="python? ( introspection ${PYTHON_REQUIRED_USE} )"
RDEPEND="${PYTHON_DEPS}
>=dev-libs/glib-2.26.1:2
>=media-gfx/exiv2-0.21:0=
- introspection? ( dev-libs/gobject-introspection )"
+ introspection? ( dev-libs/gobject-introspection:= )"
DEPEND="${RDEPEND}
virtual/pkgconfig"
src_prepare() {
+ xdg_environment_reset
tc-export CXX
}
src_configure() {
- xdg_environment_reset
econf \
$(use_enable introspection) \
$(use_enable static-libs static)