summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/gexiv2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/gexiv2')
-rw-r--r--media-libs/gexiv2/Manifest3
-rw-r--r--media-libs/gexiv2/gexiv2-0.10.2.ebuild51
-rw-r--r--media-libs/gexiv2/gexiv2-0.10.3.ebuild51
-rw-r--r--media-libs/gexiv2/gexiv2-0.6.1.ebuild52
-rw-r--r--media-libs/gexiv2/metadata.xml5
5 files changed, 162 insertions, 0 deletions
diff --git a/media-libs/gexiv2/Manifest b/media-libs/gexiv2/Manifest
new file mode 100644
index 000000000000..3002b7180d7a
--- /dev/null
+++ b/media-libs/gexiv2/Manifest
@@ -0,0 +1,3 @@
+DIST gexiv2-0.10.2.tar.xz 242704 SHA256 2fd21f0ed5125e51d02226e7f41be751cfa8ae411a8ed1a651e16b06d79047b2 SHA512 4f2f666b0dc1beb730dbd791dc690bebd8acefbc32a5e2d22fc72a4e2d839d3965b5367134c79c6076507713369193d5fb3e6d0fad984d53e53d57a20e41deab WHIRLPOOL d29a2e13ab12ce7f78ec664ce08f10efb70ce38bae6c8eb4061b16925c6eb498265ceb936eeef35788ea7ac5dc8fd98ddd873dcbd686ceb38f6bd1ebd571810f
+DIST gexiv2-0.10.3.tar.xz 244816 SHA256 390cfb966197fa9f3f32200bc578d7c7f3560358c235e6419657206a362d3988 SHA512 a258a95e3e9dddc6636430d8a2bc222b6605e5d0d122ea1b951f97568cecd04b2d3cbc522625918faf3b5a3e670b01db81a45c2c5c5d65e6eb4b4f4a2ac69e8f WHIRLPOOL e50401f642a2252cad664716004038fdd364e9a42b93c7b9748e0f93b652cad31432f7f58571dd0ff67c8dcb1deca590eaaf42ad287d8d27110d0626a352154b
+DIST libgexiv2_0.6.1.tar.xz 27300 SHA256 72ee2fcc6a98c9e83467adea45b10d1b61c55654c204dcce9c2463615389a9e3 SHA512 76aecd20ffac202badb51eab4e40fee563c3073892beec716bcf24e285df42f2498594a9e0bf487e198e8c955047d55e5b49b506bbf8b67c64956c0b99a84b1b WHIRLPOOL f0d9b514c96ecd8924395a614f4e69d046eff7f99dcad332c843d934923d5a2ad115975c083cfa9fb5b6fe620e5a8fe662738691a54d5c42219279591d79846d
diff --git a/media-libs/gexiv2/gexiv2-0.10.2.ebuild b/media-libs/gexiv2/gexiv2-0.10.2.ebuild
new file mode 100644
index 000000000000..31254672ea42
--- /dev/null
+++ b/media-libs/gexiv2/gexiv2-0.10.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit eutils multilib python-r1 toolchain-funcs versionator
+
+MY_PV=$(get_version_component_range 1-2)
+
+DESCRIPTION="GObject-based wrapper around the Exiv2 library"
+HOMEPAGE="https://wiki.gnome.org/Projects/gexiv2"
+SRC_URI="mirror://gnome/sources/${PN}/${MY_PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~ia64 ppc ~ppc64 sparc x86"
+IUSE="introspection python static-libs"
+
+REQUIRED_USE="python? ( introspection ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.26.1:2
+ >=media-gfx/exiv2-0.21:0=
+ introspection? ( dev-libs/gobject-introspection )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ tc-export CXX
+}
+
+src_configure() {
+ econf \
+ $(use_enable introspection) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIB="$(get_libdir)" install
+ dodoc AUTHORS NEWS README THANKS
+
+ if use python ; then
+ python_moduleinto gi/overrides/
+ python_foreach_impl python_domodule GExiv2.py
+ fi
+
+ use static-libs || prune_libtool_files --modules
+}
diff --git a/media-libs/gexiv2/gexiv2-0.10.3.ebuild b/media-libs/gexiv2/gexiv2-0.10.3.ebuild
new file mode 100644
index 000000000000..c7cf51ee86dd
--- /dev/null
+++ b/media-libs/gexiv2/gexiv2-0.10.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit eutils multilib python-r1 toolchain-funcs versionator
+
+MY_PV=$(get_version_component_range 1-2)
+
+DESCRIPTION="GObject-based wrapper around the Exiv2 library"
+HOMEPAGE="https://wiki.gnome.org/Projects/gexiv2"
+SRC_URI="mirror://gnome/sources/${PN}/${MY_PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="introspection python static-libs"
+
+REQUIRED_USE="python? ( introspection ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.26.1:2
+ >=media-gfx/exiv2-0.21:0=
+ introspection? ( dev-libs/gobject-introspection )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ tc-export CXX
+}
+
+src_configure() {
+ econf \
+ $(use_enable introspection) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIB="$(get_libdir)" install
+ dodoc AUTHORS NEWS README THANKS
+
+ if use python ; then
+ python_moduleinto gi/overrides/
+ python_foreach_impl python_domodule GExiv2.py
+ fi
+
+ use static-libs || prune_libtool_files --modules
+}
diff --git a/media-libs/gexiv2/gexiv2-0.6.1.ebuild b/media-libs/gexiv2/gexiv2-0.6.1.ebuild
new file mode 100644
index 000000000000..ad1f26ea23c3
--- /dev/null
+++ b/media-libs/gexiv2/gexiv2-0.6.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit eutils multilib python-r1 toolchain-funcs versionator
+
+MY_PV=$(get_version_component_range 1-2)
+
+DESCRIPTION="GObject-based wrapper around the Exiv2 library"
+HOMEPAGE="http://trac.yorba.org/wiki/gexiv2/"
+SRC_URI="http://www.yorba.org/download/${PN}/${MY_PV}/lib${PN}_${PV}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86"
+IUSE="introspection static-libs"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-libs/glib:2
+ >=media-gfx/exiv2-0.21"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/lib${P}
+
+src_prepare() {
+ tc-export CXX
+ sed -e 's:CFLAGS:CXXFLAGS:g' -i Makefile || die
+}
+
+src_configure() {
+ ./configure \
+ --prefix=/usr \
+ $(use_enable introspection) \
+ || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIB="$(get_libdir)" install
+ dodoc AUTHORS NEWS README THANKS
+
+ python_moduleinto gi/overrides/
+ python_foreach_impl python_domodule GExiv2.py
+
+ use static-libs || find "${D}" \( -name '*.a' -or -name '*.la' \) -delete
+}
diff --git a/media-libs/gexiv2/metadata.xml b/media-libs/gexiv2/metadata.xml
new file mode 100644
index 000000000000..9be90a258970
--- /dev/null
+++ b/media-libs/gexiv2/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>graphics</herd>
+</pkgmetadata>