summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-10-25 11:57:25 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2015-10-25 18:31:20 +0100
commita2d122b99fe54bf65d906fc26e70b59bd449beb4 (patch)
tree32c5aecd176786c50a1a4f576a7a984a6d5be928 /media-libs/gst-plugins-good/gst-plugins-good-1.6.0.ebuild
parentmedia-plugins/gst-plugins-libvisual: version bump to 1.6.0 (diff)
downloadgentoo-a2d122b99fe54bf65d906fc26e70b59bd449beb4.tar.gz
gentoo-a2d122b99fe54bf65d906fc26e70b59bd449beb4.tar.bz2
gentoo-a2d122b99fe54bf65d906fc26e70b59bd449beb4.zip
media-libs/gst-plugins-good: version bump to 1.6.0
Package-Manager: portage-2.2.23
Diffstat (limited to 'media-libs/gst-plugins-good/gst-plugins-good-1.6.0.ebuild')
-rw-r--r--media-libs/gst-plugins-good/gst-plugins-good-1.6.0.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/media-libs/gst-plugins-good/gst-plugins-good-1.6.0.ebuild b/media-libs/gst-plugins-good/gst-plugins-good-1.6.0.ebuild
new file mode 100644
index 000000000000..637d812b0ffd
--- /dev/null
+++ b/media-libs/gst-plugins-good/gst-plugins-good-1.6.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+GST_ORG_MODULE="gst-plugins-good"
+inherit eutils flag-o-matic gstreamer
+
+DESCRIPTION="Basepack of plugins for GStreamer"
+HOMEPAGE="http://gstreamer.freedesktop.org/"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="+orc"
+
+# dtmf plugin moved from bad to good in 1.2
+RDEPEND="
+ >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ >=media-libs/gstreamer-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ >=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}]
+ >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
+ orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
+
+ !<media-libs/gst-plugins-bad-1.1:${SLOT}
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+"
+
+src_configure() {
+ # gst doesnt handle optimisations well
+ strip-flags
+ replace-flags "-O3" "-O2"
+ # https://bugs.gentoo.org/show_bug.cgi?id=22249
+ filter-flags "-fprefetch-loop-arrays"
+
+ multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+ # Always enable optional bz2 support for matroska
+ # Always enable optional zlib support for qtdemux and matroska
+ # Many media files require these to work, as some container headers are often
+ # compressed, bug #291154
+ gstreamer_multilib_src_configure \
+ --enable-bz2 \
+ --enable-zlib \
+ --disable-examples \
+ --with-default-audiosink=autoaudiosink \
+ --with-default-visualizer=goom
+}
+
+multilib_src_install_all() {
+ DOCS="AUTHORS ChangeLog NEWS README RELEASE"
+ einstalldocs
+ prune_libtool_files --modules
+}