summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2016-11-13 00:15:57 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-11-13 00:15:57 +0100
commit67adb6a84bf16648502a63f83ba2674767849e64 (patch)
tree08038b562fdd362d7fafb51cf16e6a5410cd28eb /media-libs/libeot/libeot-9999.ebuild
parentnet-print/cups-filters: depend on app-text/mupdf (diff)
downloadgentoo-67adb6a84bf16648502a63f83ba2674767849e64.tar.gz
gentoo-67adb6a84bf16648502a63f83ba2674767849e64.tar.bz2
gentoo-67adb6a84bf16648502a63f83ba2674767849e64.zip
media-libs/libeot: New package, needed for app-text/writeperfect
Package-Manager: portage-2.3.2
Diffstat (limited to 'media-libs/libeot/libeot-9999.ebuild')
-rw-r--r--media-libs/libeot/libeot-9999.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-libs/libeot/libeot-9999.ebuild b/media-libs/libeot/libeot-9999.ebuild
new file mode 100644
index 000000000000..e03d810892f2
--- /dev/null
+++ b/media-libs/libeot/libeot-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+EGIT_REPO_URI="https://github.com/umanwizard/libeot.git"
+inherit eutils autotools
+[[ ${PV} == 9999 ]] && inherit git-r3
+
+DESCRIPTION="Library for parsing Embedded OpenType files (Microsoft embedded font 'standard')"
+HOMEPAGE="https://github.com/umanwizard/libeot"
+[[ ${PV} == 9999 ]] || SRC_URI="https://github.com/umanwizard/libeot/archive/v${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}