summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-03-17 14:43:20 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-03-17 14:43:30 +0100
commit8b027a1630d19999f03a141f7d1be13d285571f6 (patch)
tree6ff5a10acf1063657a4a076420cc2ac7db37fdba /media-libs/libvorbis
parentdev-java/lucene: Drop dependencies on obsolete dev-java/ant-trax and dev-java... (diff)
downloadgentoo-8b027a1630d19999f03a141f7d1be13d285571f6.tar.gz
gentoo-8b027a1630d19999f03a141f7d1be13d285571f6.tar.bz2
gentoo-8b027a1630d19999f03a141f7d1be13d285571f6.zip
media-libs/libvorbis: bump to 1.3.6
Bug: https://bugs.gentoo.org/631632 Bug: https://bugs.gentoo.org/650654 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'media-libs/libvorbis')
-rw-r--r--media-libs/libvorbis/Manifest1
-rw-r--r--media-libs/libvorbis/libvorbis-1.3.6.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/media-libs/libvorbis/Manifest b/media-libs/libvorbis/Manifest
index e1df2df2cb49..363030b55d91 100644
--- a/media-libs/libvorbis/Manifest
+++ b/media-libs/libvorbis/Manifest
@@ -1 +1,2 @@
DIST libvorbis-1.3.5.tar.xz 1193144 BLAKE2B 8f1b7dc9e25147fdb6304e2630a0f90a8766338b4566e9ad2f288f8e6cbcfa98b9d471dbd33e98882711319c74d5ebe78728b4c7376e07b2ab5b08a3b67c74a1 SHA512 f18f32edc43f65fea2dd4133e2828a0ced9e5b0797c4569bd26989fc1409ad599359e7c796bffc082ad36189f9722c7b38837384cea66d217beac8b425299ef8
+DIST libvorbis-1.3.6.tar.xz 1195388 BLAKE2B 9fc1dd125fdecb95687ea159b75cd66eed21329ec0795a3050e52e6cc58e1aac7b084ca25c4e52ca6f251ff474f6d71a716c0fbb2367beda8eb6a51a8fa9049a SHA512 a5d990bb88db2501b16f8eaee9f2ecb599cefd7dab2134d16538d8905263a972157c7671867848c2a8a358bf5e5dbc7721205ece001032482f168be7bda4f132
diff --git a/media-libs/libvorbis/libvorbis-1.3.6.ebuild b/media-libs/libvorbis/libvorbis-1.3.6.ebuild
new file mode 100644
index 000000000000..92e37324f12b
--- /dev/null
+++ b/media-libs/libvorbis/libvorbis-1.3.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-multilib
+
+DESCRIPTION="The Ogg Vorbis sound file format library"
+HOMEPAGE="https://xiph.org/vorbis/"
+SRC_URI="https://downloads.xiph.org/releases/vorbis/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+RDEPEND=">=media-libs/libogg-1.3.0[${MULTILIB_USEDEP}]
+ abi_x86_32? ( !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig"
+
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+
+src_prepare() {
+ sed -i \
+ -e '/CFLAGS/s:-O20::' \
+ -e '/CFLAGS/s:-mcpu=750::' \
+ -e '/CFLAGS/s:-mno-ieee-fp::' \
+ configure.ac || die
+
+ # Un-hack docdir redefinition.
+ find -name 'Makefile.am' \
+ -exec sed -i \
+ -e 's:$(datadir)/doc/$(PACKAGE)-$(VERSION):@docdir@/html:' \
+ {} + || die
+
+ AT_M4DIR="m4" \
+ autotools-multilib_src_prepare
+}