summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2018-01-15 09:43:39 -0500
committerIan Stakenvicius <axs@gentoo.org>2018-01-15 09:44:41 -0500
commit16c2853397bbd0cc422aece6a75d329222a605d0 (patch)
tree8e0f49e97875327f01f60adebb513a8ecd3972fb /media-libs/openh264
parentmedia-libs/openh264: drop old (diff)
downloadgentoo-16c2853397bbd0cc422aece6a75d329222a605d0.tar.gz
gentoo-16c2853397bbd0cc422aece6a75d329222a605d0.tar.bz2
gentoo-16c2853397bbd0cc422aece6a75d329222a605d0.zip
media-libs/openh264: rename utils to avoid file collisions
The binaries h264enc and h264dec are now installed with names openh264enc and openh264dec, respectively, to avoid file collisions with media-video/h264enc Bug: http://bugs.gentoo.org/634914 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'media-libs/openh264')
-rw-r--r--media-libs/openh264/openh264-1.7.0-r1.ebuild (renamed from media-libs/openh264/openh264-1.7.0.ebuild)12
1 files changed, 10 insertions, 2 deletions
diff --git a/media-libs/openh264/openh264-1.7.0.ebuild b/media-libs/openh264/openh264-1.7.0-r1.ebuild
index 1c42837a9727..ef0c663fca56 100644
--- a/media-libs/openh264/openh264-1.7.0.ebuild
+++ b/media-libs/openh264/openh264-1.7.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -57,7 +57,10 @@ multilib_src_compile() {
multilib_src_install() {
emakecmd DESTDIR="${D}" install-shared
- use utils && dobin h264{enc,dec}
+ if use utils ; then
+ newbin h264enc openh264enc
+ newbin h264dec openh264dec
+ fi
if use plugin; then
local plugpath="usr/$(get_libdir)/${PLUGINS_DIR}/gmp-gmp${PN}/system-installed"
@@ -92,4 +95,9 @@ pkg_postinst() {
elog "over any gmp-gmpopenh264 that may be installed in a user's profile."
elog ""
fi
+ if use utils; then
+ elog "Utilities h264enc and h264dec are installed as openh264enc and openh264dec"
+ elog "to avoid file collisions with media-video/h264enc"
+ elog ""
+ fi
}