summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-08-08 00:14:41 -0400
committerTim Harder <radhermit@gentoo.org>2016-08-08 00:15:10 -0400
commit2bc13a02731fbeb9eb2b19fa353dae13dd6604ef (patch)
tree716dff3c06241111f92f9f77821cfc229cde6307 /media-libs/rtaudio
parentsci-visualization/paraview: Fix dependency on dev-qt:qtx11extras:5 (diff)
downloadgentoo-2bc13a02731fbeb9eb2b19fa353dae13dd6604ef.tar.gz
gentoo-2bc13a02731fbeb9eb2b19fa353dae13dd6604ef.tar.bz2
gentoo-2bc13a02731fbeb9eb2b19fa353dae13dd6604ef.zip
media-libs/rtaudio: version bump to 4.1.2
Diffstat (limited to 'media-libs/rtaudio')
-rw-r--r--media-libs/rtaudio/Manifest1
-rw-r--r--media-libs/rtaudio/files/rtaudio-4.1.2-cflags.patch12
-rw-r--r--media-libs/rtaudio/files/rtaudio-4.1.2-configure.patch68
-rw-r--r--media-libs/rtaudio/rtaudio-4.1.2.ebuild64
4 files changed, 145 insertions, 0 deletions
diff --git a/media-libs/rtaudio/Manifest b/media-libs/rtaudio/Manifest
index 7972183601ce..15d08938e6a2 100644
--- a/media-libs/rtaudio/Manifest
+++ b/media-libs/rtaudio/Manifest
@@ -1 +1,2 @@
DIST rtaudio-4.0.12.tar.gz 330048 SHA256 5179056c796b9582e375d352efa0598e674b9719cf78a85a426517b375ff1cab SHA512 43068cafaf460425334588775bbeee115d1651142d8fa62808880296763952159bff297c482e6d58200cfb6d382205778405993dbbb3a769e4b1228ff0aee3b6 WHIRLPOOL 252fc02dbebdc1777314a97e4acc18ce615f78a82a12cdf6bcf2759867a3da6c755977dec832351c5b86aec7825d07882024179703c746e654a5f7bc2d32b9ce
+DIST rtaudio-4.1.2.tar.gz 682382 SHA256 294d044da313a430c44d311175a4f51c15d56d87ecf72ad9c236f57772ecffb8 SHA512 1e7f7f0f4dc451d023a7c8ab287fe63034cf6b4e18fe138bab253c307d6dd0cddb669b031f6c21325aaac0ce53002acd2a17dd1e47bd8ac2cb14e058cfce1a21 WHIRLPOOL c1e76424c02c43b7328ea4eb7ff632477d2eace02c9d4b9b4ba029cce4f939263a2f4035288503f65efe9a7bf93ddc797e341d7a64d0864c49f19526125860d3
diff --git a/media-libs/rtaudio/files/rtaudio-4.1.2-cflags.patch b/media-libs/rtaudio/files/rtaudio-4.1.2-cflags.patch
new file mode 100644
index 000000000000..49978458c682
--- /dev/null
+++ b/media-libs/rtaudio/files/rtaudio-4.1.2-cflags.patch
@@ -0,0 +1,12 @@
+--- rtaudio-4.1.2/configure.ac
++++ rtaudio-4.1.2/configure.ac
+@@ -62,8 +62,7 @@
+ AC_MSG_CHECKING(whether to compile debug version)
+ AC_ARG_ENABLE(debug,
+ [AS_HELP_STRING([--enable-debug],[enable various debug output])],
+- [: ${CXXFLAGS="-g -O0"};] [AC_DEFINE([__RTAUDIO_DEBUG__])],
+- [: ${CXXFLAGS="-O3"}])
++ [AC_DEFINE([__RTAUDIO_DEBUG__])], )
+
+ # Checks for programs.
+ AC_PROG_CXX(g++ CC c++ cxx)
diff --git a/media-libs/rtaudio/files/rtaudio-4.1.2-configure.patch b/media-libs/rtaudio/files/rtaudio-4.1.2-configure.patch
new file mode 100644
index 000000000000..fa33fb21fee2
--- /dev/null
+++ b/media-libs/rtaudio/files/rtaudio-4.1.2-configure.patch
@@ -0,0 +1,68 @@
+--- rtaudio-4.1.2/configure.ac
++++ rtaudio-4.1.2/configure.ac
+@@ -69,9 +69,9 @@
+ AC_PROG_CXX(g++ CC c++ cxx)
+ AM_PROG_AR
+ AC_PATH_PROG(AR, ar, no)
+-if [[ $AR = "no" ]] ; then
+- AC_MSG_ERROR("Could not find ar - needed to create a library");
+-fi
++AS_IF([test "x$AR" == "x" ], [
++ AC_MSG_ERROR("Could not find ar - needed to create a library")
++])
+
+ # Initialize libtool
+ LT_INIT([win32-dll])
+@@ -131,38 +130,41 @@
+ ;;
+
+ *-*-linux*)
+- AC_ARG_WITH(jack, [ --with-jack = choose JACK server support (mac and linux only)], [
++ AC_ARG_WITH([jack], AS_HELP_STRING([--with-jack], [choose JACK server support (mac and linux only)]))
++ AS_IF([test "x$with_jack" != "xno"], [
+ api="$api -D__UNIX_JACK__"
+ AC_MSG_RESULT(using JACK)
+ AC_CHECK_LIB(jack, jack_client_open, , AC_MSG_ERROR(JACK support requires the jack library!))
+- AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(Jack support also requires the asound library!))], )
++ AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(Jack support also requires the asound library!))])
+
+ # Look for ALSA flag
+- AC_ARG_WITH(alsa, [ --with-alsa = choose native ALSA API support (linux only)], [
++ AC_ARG_WITH([alsa], AS_HELP_STRING([--with-alsa], [choose native ALSA API support (linux only)]))
++ AS_IF([test "x$with_alsa" != "xno"], [
+ api="$api -D__LINUX_ALSA__"
+ req="$req alsa"
+ AC_MSG_RESULT(using ALSA)
+- AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(ALSA support requires the asound library!))], )
++ AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(ALSA support requires the asound library!))])
+
+ # Look for PULSE flag
+- AC_ARG_WITH(pulse, [ --with-pulse = choose PulseAudio API support (linux only)], [
++ AC_ARG_WITH([pulse], AS_HELP_STRING([--with-pulse], [choose PulseAudio API support (linux only)]))
++ AS_IF([test "x$with_pulse" != "xno"], [
+ api="$api -D__LINUX_PULSE__"
+ req="$req libpulse-simple"
+ AC_MSG_RESULT(using PulseAudio)
+- AC_CHECK_LIB(pulse-simple, pa_simple_flush, , AC_MSG_ERROR(PulseAudio support requires the pulse-simple library!))], )
++ AC_CHECK_LIB(pulse-simple, pa_simple_flush, , AC_MSG_ERROR(PulseAudio support requires the pulse-simple library!))])
+
+ # Look for OSS flag
+- AC_ARG_WITH(oss, [ --with-oss = choose OSS API support (linux only)], [
++ AC_ARG_WITH([oss], AS_HELP_STRING([--with-oss], [choose OSS API support (linux only)]))
++ AS_IF([test "x$with_oss" != "xno"], [
+ api="$api -D__LINUX_OSS__"
+- AC_MSG_RESULT(using OSS)], )
++ AC_MSG_RESULT(using OSS)])
+
+ # If no audio api flags specified, use ALSA
+- if [test "$api" == "";] then
++ AS_IF([test "x$api" == "x"], [
+ AC_MSG_RESULT(using ALSA)
+ AC_SUBST( api, [-D__LINUX_ALSA__] )
+ req="$req alsa"
+- AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(ALSA support requires the asound library!))
+- fi
++ AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(ALSA support requires the asound library!))])
+
+ AC_CHECK_LIB(pthread, pthread_create, , AC_MSG_ERROR(RtAudio requires the pthread library!))
+ ;;
diff --git a/media-libs/rtaudio/rtaudio-4.1.2.ebuild b/media-libs/rtaudio/rtaudio-4.1.2.ebuild
new file mode 100644
index 000000000000..604a64003780
--- /dev/null
+++ b/media-libs/rtaudio/rtaudio-4.1.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils autotools
+
+DESCRIPTION="A set of cross-platform C++ classes for realtime audio I/O"
+HOMEPAGE="http://www.music.mcgill.ca/~gary/rtaudio/"
+SRC_URI="http://www.music.mcgill.ca/~gary/${PN}/release/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+alsa doc jack pulseaudio static-libs"
+REQUIRED_USE="|| ( alsa jack pulseaudio )"
+
+RDEPEND="alsa? ( media-libs/alsa-lib )
+ jack? (
+ media-libs/alsa-lib
+ media-sound/jack-audio-connection-kit
+ )
+ pulseaudio? ( media-sound/pulseaudio )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ local PATCHES=(
+ "${FILESDIR}"/${P}-configure.patch
+ "${FILESDIR}"/${P}-cflags.patch
+ )
+
+ default
+
+ # don't rebuild docs
+ export ac_cv_prog_DOXYGEN=
+
+ eautoreconf
+}
+
+src_configure() {
+ # OSS support requires OSSv4
+ local myconf=(
+ $(use_enable static-libs static)
+ $(use_with jack)
+ $(use_with alsa)
+ $(use_with pulseaudio pulse)
+ --without-oss
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc readme doc/release.txt
+ if use doc ; then
+ dodoc -r doc/html
+ dodoc -r doc/images
+ fi
+
+ prune_libtool_files
+}