summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Lothian <mike@fireburn.co.uk>2019-02-26 20:30:39 +0000
committerNick Sarnie <sarnex@gentoo.org>2019-02-26 19:44:49 -0500
commit2723658eef767bf02cb68f3873e63aac643ed6f2 (patch)
tree3f273274c0847e8585fee0091fb239395406fd21 /media-libs/vulkan-layers/vulkan-layers-1.1.92.0-r1.ebuild
parentgnome-base/gdm: require older gnome-settings-daemon for older gdm (diff)
downloadgentoo-2723658eef767bf02cb68f3873e63aac643ed6f2.tar.gz
gentoo-2723658eef767bf02cb68f3873e63aac643ed6f2.tar.bz2
gentoo-2723658eef767bf02cb68f3873e63aac643ed6f2.zip
media-libs/vulkan-layers: Install headers into /usr/include/vulkan
This is required to allow the new mesa vulkan-overlay-layer to build correctly Closes: https://github.com/gentoo/gentoo/pull/11166 Signed-off-by: Mike Lothian <mike@fireburn.co.uk> Signed-off-by: Nick Sarnie <sarnex@gentoo.org>
Diffstat (limited to 'media-libs/vulkan-layers/vulkan-layers-1.1.92.0-r1.ebuild')
-rw-r--r--media-libs/vulkan-layers/vulkan-layers-1.1.92.0-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/media-libs/vulkan-layers/vulkan-layers-1.1.92.0-r1.ebuild b/media-libs/vulkan-layers/vulkan-layers-1.1.92.0-r1.ebuild
new file mode 100644
index 000000000000..c37c62f8b84b
--- /dev/null
+++ b/media-libs/vulkan-layers/vulkan-layers-1.1.92.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/KhronosGroup/Vulkan-ValidationLayers.git"
+ EGIT_SUBMODULES=()
+ inherit git-r3
+else
+ EGIT_COMMIT="6e6da6ccab8931f7c30815966ef839b1155e5bec"
+ KEYWORDS="amd64"
+ SRC_URI="https://github.com/KhronosGroup/Vulkan-ValidationLayers/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/Vulkan-ValidationLayers-${EGIT_COMMIT}"
+fi
+
+inherit python-any-r1 cmake-multilib
+
+DESCRIPTION="Vulkan Validation Layers"
+HOMEPAGE="https://github.com/KhronosGroup/Vulkan-ValidationLayers"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="X wayland"
+
+DEPEND="${PYTHON_DEPS}
+ >=dev-util/glslang-7.10.2984:=[${MULTILIB_USEDEP}]
+ >=dev-util/spirv-tools-2018.2-r1:=[${MULTILIB_USEDEP}]
+ >=dev-util/vulkan-headers-1.1.92.0
+ wayland? ( dev-libs/wayland:=[${MULTILIB_USEDEP}] )
+ X? (
+ x11-libs/libX11:=[${MULTILIB_USEDEP}]
+ x11-libs/libXrandr:=[${MULTILIB_USEDEP}]
+ )"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_SKIP_RPATH=True
+ -DBUILD_WSI_WAYLAND_SUPPORT=$(usex wayland)
+ -DBUILD_WSI_XCB_SUPPORT=$(usex X)
+ -DBUILD_WSI_XLIB_SUPPORT=$(usex X)
+ -DBUILD_TESTS=False
+ -DGLSLANG_INSTALL_DIR="/usr"
+ -DCMAKE_INSTALL_INCLUDEDIR="/usr/include/vulkan/"
+ )
+ cmake-utils_src_configure
+}