summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-03-16 08:23:13 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-03-16 08:23:59 +0100
commit9797d5a6967b83503c0a2aa37d5c16dc7df25822 (patch)
tree3dfe0aa46d268f3402ac877311489c5bf20b47de /media-libs/zimg
parentmedia-libs/zimg: Sync live ebuild hidden keywords (diff)
downloadgentoo-9797d5a6967b83503c0a2aa37d5c16dc7df25822.tar.gz
gentoo-9797d5a6967b83503c0a2aa37d5c16dc7df25822.tar.bz2
gentoo-9797d5a6967b83503c0a2aa37d5c16dc7df25822.zip
media-libs/zimg: Bump to 2.5
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'media-libs/zimg')
-rw-r--r--media-libs/zimg/Manifest1
-rw-r--r--media-libs/zimg/zimg-2.5.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/media-libs/zimg/Manifest b/media-libs/zimg/Manifest
index 6dc76f870750..89580f025b31 100644
--- a/media-libs/zimg/Manifest
+++ b/media-libs/zimg/Manifest
@@ -1 +1,2 @@
DIST zimg-2.4.tar.gz 193791 SHA256 996ea0e446df6ff4d6cb9c04a77d60978eca47c32d3785cd63fe8c29a9523d1f SHA512 978a344c8f91327c7b92c6354526042d3901ce8ca3db19ba1ea1c81f4a1f980a64290223c202af354abd9efd821664d1743714acee171529a30f3742a0195e9e WHIRLPOOL cbae92a607d94c61860461d054e2a68220b2f7039e5aaade0dc869267795759076edd42bd30f4b03d816119b181a5c703a7d7382a7ff751433eace9d8050466b
+DIST zimg-2.5.tar.gz 213054 SHA256 50b2bcc49e51cd36011a0c363ff914a81b6f161aefdffeaa2bc4a4627c13784d SHA512 7fc48c704b434d837c36d4bafc51b35789eaf90fc81a68dcd7ec546f1e82a3e41c53263f8d381541d5c0ce58e25dddf0adaf1c3575512842ae633b5581778938 WHIRLPOOL 38ec8b7c26b8b358551a8158372f0cf1d27fbb4a0666ec8b56c3b7227f18bda4267f252596eba5a26347463ef8426982c9befe2ccf9bb1384a17d393ff35390a
diff --git a/media-libs/zimg/zimg-2.5.ebuild b/media-libs/zimg/zimg-2.5.ebuild
new file mode 100644
index 000000000000..5826bad7c0df
--- /dev/null
+++ b/media-libs/zimg/zimg-2.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=yes
+
+SCM=""
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/sekrit-twc/zimg"
+fi
+
+inherit autotools-multilib ${SCM}
+
+DESCRIPTION="Scaling, colorspace conversion, and dithering library"
+HOMEPAGE="https://github.com/sekrit-twc/zimg"
+
+if [ "${PV#9999}" = "${PV}" ] ; then
+ SRC_URI="https://github.com/sekrit-twc/zimg/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~x86"
+ S="${WORKDIR}/${PN}-release-${PV}/"
+fi
+
+LICENSE="WTFPL-2"
+SLOT="0"
+IUSE="static-libs cpu_flags_x86_sse"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ autotools-multilib_src_configure \
+ $(use_enable cpu_flags_x86_sse x86simd)
+}