summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2018-01-17 18:22:13 +0100
committerSebastian Pipping <sping@gentoo.org>2018-01-17 18:22:46 +0100
commit678cc27e1de8f8b38acefd42590c24217b5808e8 (patch)
tree877fc0f0aed62ab1e654e30bf45e44a2396766b1 /media-libs
parentdev-db/mysql: repoman: Fix DoubleEmptyLine warning (diff)
downloadgentoo-678cc27e1de8f8b38acefd42590c24217b5808e8.tar.gz
gentoo-678cc27e1de8f8b38acefd42590c24217b5808e8.tar.bz2
gentoo-678cc27e1de8f8b38acefd42590c24217b5808e8.zip
media-libs/babl: 0.1.40
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/babl/Manifest1
-rw-r--r--media-libs/babl/babl-0.1.40.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/media-libs/babl/Manifest b/media-libs/babl/Manifest
index 19409873904a..f7e8d125afdd 100644
--- a/media-libs/babl/Manifest
+++ b/media-libs/babl/Manifest
@@ -6,3 +6,4 @@ DIST babl-0.1.24.tar.bz2 616887 BLAKE2B 7f553076b8d540089d4825747d1d02d6480c3015
DIST babl-0.1.26.tar.bz2 614865 BLAKE2B 537f1f2e23f2df7710d79f7733f8cbad7c9ae79ca39fea16af267488f4e6be429ad8eb41843b2ff6497a9c036f89f840baa8f2e0fa7e56994305b1d72942e010 SHA512 6db3e6edaa6b40a114733c517d565dc2c38f3e445a72df5efa85647f693785ca0e8290daa698a93e8aba01ea96ea59de4d53caf9162000cce55cf30c8c868e5f
DIST babl-0.1.30.tar.bz2 616595 BLAKE2B e93f56c243373634ad8c2f5a493cae80113c9b9174bf388525b943e7702024fd4d2afeaf544fbeb01b44b3c77d90c7ebcb064f94a6953876bb91c06fbcb30311 SHA512 391182786312140fe3fa8b4b8448df2829230ef6a1d9957d8bb729c464e94f5b1300ad761d04f51b3d777c4de9fb462dd0391c3f0c2daa53e9c53bf697e58dca
DIST babl-0.1.38.tar.bz2 653047 BLAKE2B 8bc43a7e0b7265f72122743ff4b3e25825e4bbe6797a6e077de16d47239a67cc8fcb93253f54de31012cfb1622cafed2c220cba5cb3cdd9eb1599e5d11b4000f SHA512 4b55b666170322adad4b4624c98110d7a34c496f7aadb22a53c09d1ce5ae518122c2105fd2cb2a057e752fe1540beb703f8192e48e7c43601342a75db2bfdca0
+DIST babl-0.1.40.tar.bz2 653272 BLAKE2B 4e5694db5a6d29c2faeada7046cacc511623bf54794386a47c6403abb2e86cfd5d0953cf9198e8a5cf20060366e770a344a8c8b503c0496d95ce9d92e149a4f6 SHA512 73812247bade66ce38cb4239974e94a6ced05e4d9f5feae7eb111ffdf2c364197c0a2d9883ba28f5ff839f9f9ffb9dd272209c4720046c12cf2446fedae34ce1
diff --git a/media-libs/babl/babl-0.1.40.ebuild b/media-libs/babl/babl-0.1.40.ebuild
new file mode 100644
index 000000000000..f5da34a496f1
--- /dev/null
+++ b/media-libs/babl/babl-0.1.40.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+if [[ ${PV} == *9999* ]]; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="git://git.gnome.org/babl"
+ SRC_URI=""
+else
+ SRC_URI="http://ftp.gimp.org/pub/${PN}/${PV:0:3}/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="A dynamic, any to any, pixel format conversion library"
+HOMEPAGE="http://www.gegl.org/babl/"
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="altivec cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse4_1 cpu_flags_x86_mmx cpu_flags_x86_f16c"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-2.2
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ [[ ${PV} == *9999* ]] && eautoreconf
+}
+
+src_configure() {
+ # Automagic rsvg support is just for website generation we do not call,
+ # so we don't need to fix it
+ # w3m is used for dist target thus no issue for us that it is automagically
+ # detected
+ econf \
+ --disable-docs \
+ --disable-static \
+ --disable-maintainer-mode \
+ $(use_enable altivec) \
+ $(use_enable cpu_flags_x86_f16c f16c) \
+ $(use_enable cpu_flags_x86_mmx mmx) \
+ $(use_enable cpu_flags_x86_sse sse) \
+ $(use_enable cpu_flags_x86_sse2 sse2) \
+ $(use_enable cpu_flags_x86_sse4_1 sse4_1)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}