summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-02-15 22:06:54 +0100
committerMichał Górny <mgorny@gentoo.org>2017-02-15 22:08:34 +0100
commit8887e178a3f5bbd7a8959a4bbd6a0282cb698659 (patch)
tree0890b26d59b7d8da53ed0095faee12bfe77ae769 /media-libs
parentmozconfig-v6.45.eclass: remove gstreamer:0.10 capability (diff)
downloadgentoo-8887e178a3f5bbd7a8959a4bbd6a0282cb698659.tar.gz
gentoo-8887e178a3f5bbd7a8959a4bbd6a0282cb698659.tar.bz2
gentoo-8887e178a3f5bbd7a8959a4bbd6a0282cb698659.zip
media-libs/mesa: Fix uncond call to llvm_pkg_setup, #608536
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/mesa/mesa-17.0.0.ebuild4
-rw-r--r--media-libs/mesa/mesa-9999.ebuild4
2 files changed, 6 insertions, 2 deletions
diff --git a/media-libs/mesa/mesa-17.0.0.ebuild b/media-libs/mesa/mesa-17.0.0.ebuild
index b35f0bc5ef27..d6d58afc0dd6 100644
--- a/media-libs/mesa/mesa-17.0.0.ebuild
+++ b/media-libs/mesa/mesa-17.0.0.ebuild
@@ -201,7 +201,9 @@ pkg_setup() {
ewarn "detected! This can cause problems. For details, see bug 459306."
fi
- LLVM_MAX_SLOT=4 llvm_pkg_setup
+ if use llvm || use opencl; then
+ LLVM_MAX_SLOT=4 llvm_pkg_setup
+ fi
python-any-r1_pkg_setup
}
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index fe87f66a7bdf..2f05b05d304b 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -188,7 +188,9 @@ pkg_setup() {
ewarn "detected! This can cause problems. For details, see bug 459306."
fi
- llvm_pkg_setup
+ if use llvm || use opencl; then
+ llvm_pkg_setup
+ fi
python-any-r1_pkg_setup
}