summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2021-02-13 22:01:09 +0200
committerMart Raudsepp <leio@gentoo.org>2021-02-13 23:39:47 +0200
commit9c6164c6309b70550fdb6c40a43cf72b53253e12 (patch)
tree8b381928b6956b079f644ea88091297c73fb61b0 /media-plugins/gst-plugins-libav
parentdev-python/tubes: Fix DISTUTILS_USE_SETUPTOOLS (diff)
downloadgentoo-9c6164c6309b70550fdb6c40a43cf72b53253e12.tar.gz
gentoo-9c6164c6309b70550fdb6c40a43cf72b53253e12.tar.bz2
gentoo-9c6164c6309b70550fdb6c40a43cf72b53253e12.zip
media-plugins/gst-plugins-libav: bump to 1.16.3
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'media-plugins/gst-plugins-libav')
-rw-r--r--media-plugins/gst-plugins-libav/Manifest1
-rw-r--r--media-plugins/gst-plugins-libav/gst-plugins-libav-1.16.3.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-libav/Manifest b/media-plugins/gst-plugins-libav/Manifest
index 005b1f9290bb..9c0c950788b5 100644
--- a/media-plugins/gst-plugins-libav/Manifest
+++ b/media-plugins/gst-plugins-libav/Manifest
@@ -2,3 +2,4 @@ DIST ffmpeg-4.1.3.tar.bz2 10689073 BLAKE2B 8486e21c8df116af802bb7f9208e702ec1fea
DIST gst-libav-1.14.4-ffmpeg4-patchset.tar.xz 49428 BLAKE2B 74c3e0b25643bcfdf01d1d16514401fef4bb988ba3d1f306b647ba0cd6e89f0205cc33e6d144889d6b2f7fab9e4fae946e03821a85009fa95c68f3cedf25068a SHA512 1347424ed342f00c25ac4780670611a24eeaf708426b6efc6d9f6c6fa7bf91ef292302a5363afe9523c497265b8c0d7ad81374364cbecb2924b749e716819745
DIST gst-libav-1.14.4.tar.xz 9036732 BLAKE2B 1c2e257912f61dac71e1d890f4cb650e0cdbbf4472cbd8dc6b73e471d1914409b71699bd198c154069e15e68364530e91f76619afb52b91e373e58c9237ab7cb SHA512 4a0e9a91c23cba82e6a6b8eb65ff42b9d80389dd232b08c22b3431d3942fb93a6a7e64be97083d11cbceb2abe5d45dc5b37d230f7552e1a7fb193610d0530717
DIST gst-libav-1.16.2.tar.xz 9466288 BLAKE2B c14f3921bf357541b6ae4b5095dbff963fec90aa9ae3ef59e7b52c1d1f68fce8f497de017a6654f293d7b489ff5a880896018f5de0412456668f60bae1b2a32a SHA512 10817dec823b8ca84372d16e36c4ee11ab7a96a9168418f4c0bd0909fbda0ff45426bd3f754d7d491d4b07a51ec7eaa8e065e7e5c1daa120828c35a68adb312d
+DIST gst-libav-1.16.3.tar.xz 9472760 BLAKE2B 3e98381244d74aa695c737a898711b311518749c6f949af7bd03d08cdf383cbe1a78cea8e3f0268fdb2132bec930803f8fa31e919c6c268b6f8d58092f01fd04 SHA512 37fe621a8d45ac6bf51383a776f3091cc114faaf84b0097e86f33eb4e8c0b70b4cc6fa467aad63daca9b1b24db24c10a067c973ef8232c2965eedeba3d251b0b
diff --git a/media-plugins/gst-plugins-libav/gst-plugins-libav-1.16.3.ebuild b/media-plugins/gst-plugins-libav/gst-plugins-libav-1.16.3.ebuild
new file mode 100644
index 000000000000..c5d5851a2aa1
--- /dev/null
+++ b/media-plugins/gst-plugins-libav/gst-plugins-libav-1.16.3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eapi7-ver multilib-minimal
+
+MY_PN="gst-libav"
+
+DESCRIPTION="FFmpeg based gstreamer plugin"
+HOMEPAGE="https://gstreamer.freedesktop.org/modules/gst-libav.html"
+SRC_URI="https://gstreamer.freedesktop.org/src/${MY_PN}/${MY_PN}-${PV}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86"
+IUSE="+orc"
+
+RDEPEND="
+ >=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
+ >=media-libs/gstreamer-${PV}:1.0[${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-base-${PV}:1.0[${MULTILIB_USEDEP}]
+ >=media-video/ffmpeg-4:0=[${MULTILIB_USEDEP}]
+ orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RESTRICT="test" # FIXME: tests seem to get stuck at one point; investigate properly
+
+PATCHES=(
+ "${FILESDIR}"/external-ffmpeg4-dep.patch # Automatically rescan available elements for registry when system ffmpeg changes
+)
+
+multilib_src_configure() {
+ GST_PLUGINS_BUILD=""
+
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-maintainer-mode \
+ --with-package-name="Gentoo GStreamer ebuild" \
+ --with-package-origin="https://www.gentoo.org" \
+ --disable-fatal-warnings \
+ --with-system-libav \
+ $(use_enable orc)
+}
+
+multilib_src_compile() {
+ # Don't build with -Werror; verbose build
+ emake ERROR_CFLAGS= V=1
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -name '*.la' -delete || die
+}