summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-08-18 22:14:10 -0400
committerTim Harder <radhermit@gentoo.org>2016-08-18 22:15:42 -0400
commit329fdb7f5a54504f0a8672179ba5ddf40d053b24 (patch)
tree816eb8b61910f722a264cde7ade5b6d7877ffe19 /media-sound/lilypond/lilypond-9999.ebuild
parentnet-firewall/iptables: drop iptables.service (diff)
downloadgentoo-329fdb7f5a54504f0a8672179ba5ddf40d053b24.tar.gz
gentoo-329fdb7f5a54504f0a8672179ba5ddf40d053b24.tar.bz2
gentoo-329fdb7f5a54504f0a8672179ba5ddf40d053b24.zip
media-sound/lilypond: version bump to 2.19.46
Also, fix build with guile2.
Diffstat (limited to 'media-sound/lilypond/lilypond-9999.ebuild')
-rw-r--r--media-sound/lilypond/lilypond-9999.ebuild23
1 files changed, 14 insertions, 9 deletions
diff --git a/media-sound/lilypond/lilypond-9999.ebuild b/media-sound/lilypond/lilypond-9999.ebuild
index f27ba3673fd5..2a3aaafdadd4 100644
--- a/media-sound/lilypond/lilypond-9999.ebuild
+++ b/media-sound/lilypond/lilypond-9999.ebuild
@@ -52,7 +52,7 @@ DEPEND="${RDEPEND}
# Correct output data for tests isn't bundled with releases
RESTRICT="test"
-DOCS=( README.txt )
+DOCS=( DEDICATION HACKING README.txt ROADMAP )
pkg_setup() {
# make sure >=metapost-1.803 is selected if it's installed, bug 498704
@@ -67,6 +67,8 @@ pkg_setup() {
}
src_prepare() {
+ default
+
if ! use vim-syntax ; then
sed -i 's/vim//' GNUmakefile.in || die
fi
@@ -84,8 +86,6 @@ src_prepare() {
# remove bundled texinfo file (fixes bug #448560)
rm tex/texinfo.tex || die
- eapply_user
-
eautoreconf
}
@@ -93,13 +93,18 @@ src_configure() {
# documentation generation currently not supported since it requires a newer
# version of texi2html than is currently in the tree
- econf \
- --with-texgyre-dir=/usr/share/fonts/tex-gyre \
- --disable-documentation \
- --disable-optimising \
- --disable-pipe \
- $(use_enable debug debugging) \
+ local myeconfargs+=(
+ --with-texgyre-dir=/usr/share/fonts/tex-gyre
+ --disable-documentation
+ --disable-optimising
+ --disable-pipe
+ $(use_enable debug debugging)
$(use_enable profile profiling)
+ )
+
+ has_version ">=dev-scheme/guile-2" && myeconfargs+=( --enable-guile2 )
+
+ econf "${myeconfargs[@]}"
}
src_compile() {